Closed Bug 753659 Opened 8 years ago Closed 7 years ago

Use fatal assertions for refcounting-on-the-wrong-thread assertions

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: khuey, Assigned: khuey)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
Exactly what it says on the box.
Attachment #622636 - Flags: review?(benjamin)
Comment on attachment 622636 [details] [diff] [review]
Patch

In our attempt to make better assertions, we now have assertion implementations spread across XPCOM and MFBT. Do we plan on removing the NS_ variants of these, or just spreading out the mess across more directories?
Attachment #622636 - Flags: review?(benjamin) → review+
Duplicate of this bug: 771148
Bug 771148 was a dupe of this; but note that since a patch from bug 754572, the patch is slightly changed, see

  https://bugzilla.mozilla.org/attachment.cgi?id=639343&action=diff

in particular the MOZ_FATAL_ASSERTIONS_FOR_THREAD_SAFETY should go away.

Kyle are you going to land this soon?
https://hg.mozilla.org/mozilla-central/rev/9d285bedbc1f
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Depends on: 793657
No longer depends on: 793676
You need to log in before you can comment on or make changes to this bug.