Last Comment Bug 753677 - Visually distinguish between configurable, enumerable and writable properties
: Visually distinguish between configurable, enumerable and writable properties
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 12 Branch
: All All
: P3 normal (vote)
: Firefox 15
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on: 759135
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 01:19 PDT by Victor Porof [:vporof][:vp]
Modified: 2012-06-02 02:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (4.53 KB, patch)
2012-05-30 06:15 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review
v1-2 (3.66 KB, patch)
2012-05-30 09:38 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review
v1-2-fix (7.30 KB, patch)
2012-05-30 23:48 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v-fold (9.13 KB, patch)
2012-06-01 08:36 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2012-05-10 01:19:14 PDT
A few visual metaphors for these properties may be nice.
Comment 1 Victor Porof [:vporof][:vp] 2012-05-10 01:25:59 PDT
The "enumerable" part of this bug is mostly taken care of in bug 752834.
Comment 2 Victor Porof [:vporof][:vp] 2012-05-23 07:12:16 PDT
We'll just need a lock icon for the unwritable properties.
Comment 3 Panos Astithas [:past] 2012-05-29 23:37:33 PDT
Frozen objects should be identified as well:

https://mail.mozilla.org/pipermail/es-discuss/2012-May/022991.html

As a matter of fact, why not indicate all object extensibility characteristics? I imagine a single character at the right side of the object value, with a "float: right" alignment, that reads either F(rozen), S(ealed) or N(on-extensible).
Comment 4 Victor Porof [:vporof][:vp] 2012-05-30 06:15:41 PDT
Created attachment 628321 [details] [diff] [review]
v1
Comment 5 Victor Porof [:vporof][:vp] 2012-05-30 09:00:45 PDT
(In reply to Panos Astithas [:past] from comment #3)
> Frozen objects should be identified as well:
> 
> https://mail.mozilla.org/pipermail/es-discuss/2012-May/022991.html
> 
> As a matter of fact, why not indicate all object extensibility
> characteristics? I imagine a single character at the right side of the
> object value, with a "float: right" alignment, that reads either F(rozen),
> S(ealed) or N(on-extensible).

How about a followup for this?
Comment 6 Panos Astithas [:past] 2012-05-30 09:09:46 PDT
(In reply to Victor Porof from comment #5)
> (In reply to Panos Astithas [:past] from comment #3)
> > Frozen objects should be identified as well:
> > 
> > https://mail.mozilla.org/pipermail/es-discuss/2012-May/022991.html
> > 
> > As a matter of fact, why not indicate all object extensibility
> > characteristics? I imagine a single character at the right side of the
> > object value, with a "float: right" alignment, that reads either F(rozen),
> > S(ealed) or N(on-extensible).
> 
> How about a followup for this?

I'm fine with that.
Comment 7 Victor Porof [:vporof][:vp] 2012-05-30 09:38:36 PDT
Created attachment 628360 [details] [diff] [review]
v1-2

Part 2: make the variables obey these same rules as properties (I didn't think we need another bug for this).
Comment 8 Panos Astithas [:past] 2012-05-30 12:44:12 PDT
Comment on attachment 628321 [details] [diff] [review]
v1

Review of attachment 628321 [details] [diff] [review]:
-----------------------------------------------------------------

I very much like the decorations, but they are not terribly intuitive. Can't we add tooltips or something?
Comment 9 Victor Porof [:vporof][:vp] 2012-05-30 12:46:00 PDT
(In reply to Panos Astithas [:past] from comment #8)
> Comment on attachment 628321 [details] [diff] [review]
> v1
> 
> Review of attachment 628321 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I very much like the decorations, but they are not terribly intuitive. Can't
> we add tooltips or something?

Indeed. I was hoping that this will be just temporary, and shorlander will think of something awesome as always.
Comment 10 Victor Porof [:vporof][:vp] 2012-05-30 23:48:03 PDT
Created attachment 628612 [details] [diff] [review]
v1-2-fix

Added tooltips copied CSS bits to gnomestripe and pinstripe as well.
Comment 11 Panos Astithas [:past] 2012-05-31 03:02:03 PDT
I like the tooltips! One thing I noticed though, after playing with the patch some more, is that the dotted underline beneath non-writable and non-configurable properties is barely visible next to the dotted separator between properties. Perhaps using a dashed underline will make it more prominent, and also emphasize the color difference between noon-writable and non-configurable properties (due to the extra colored pixels), which is now too subtle.
Comment 12 Rob Campbell [:rc] (:robcee) 2012-05-31 16:29:28 PDT
I could not apply this. Needs a little rebase.
Comment 13 Victor Porof [:vporof][:vp] 2012-06-01 08:22:04 PDT
There are two patches in this bug:
v1: which is part1
v1-2-fix: which is part2 with nits addressed from panos.

I'll address comment 11 and reupload a single patch :)
Comment 14 Victor Porof [:vporof][:vp] 2012-06-01 08:36:32 PDT
Created attachment 629206 [details] [diff] [review]
v-fold

Addressed comments and qfolded. Land me.
Comment 15 Panos Astithas [:past] 2012-06-01 09:37:00 PDT
https://hg.mozilla.org/integration/fx-team/rev/1bc2c4e1493b
Comment 16 Panos Astithas [:past] 2012-06-02 02:27:55 PDT
https://hg.mozilla.org/mozilla-central/rev/1bc2c4e1493b

Note You need to log in before you can comment on or make changes to this bug.