Closed Bug 753762 Opened 8 years ago Closed 8 years ago

Panning, zooming and layout issues

Categories

(Firefox for Android Graveyard :: General, defect, blocker)

Firefox 14
ARM
Android
defect
Not set
blocker

Tracking

(firefox14 affected, blocking-fennec1.0 -)

RESOLVED DUPLICATE of bug 749953
Tracking Status
firefox14 --- affected
blocking-fennec1.0 --- -

People

(Reporter: xti, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [14.0b1])

Attachments

(1 file)

Attached image screenshot
Firefox 14.0b1 (2012-05-09) build#2
Devices: EEE Transformer TF101 (4.0.2), LG Optimus 2X (2.2), Samsung Galaxy S2 (2.3.4)

Steps to reproduce:
1. Open Fennec
2. Go to news.google.com (Desktop version)
3. Double tap to zoom in
4. Double tap to zoom out
5. Close the tab and undo this action
6. Pan down to the bottom of the page

Expected result:
No issues occur while performing the above str.

Actual result:
After step 4, half (more or less) of the screen is blank.
After step 6, the page cannot be panned to the bottom (seems to be stuck on the lower side of it)

Notes:
- sometimes pan or/and zoom are locked.
- please this video and attached screenshot: http://youtu.be/IYlJgmn9o5Y
- this bug occurs both on phones and tablets
Whiteboard: [14.0b1]
I assume this is a regression?
Seems like a painting/invalidation issue. I can correct this by pinch-zooming outwards/rotation. I dont see this on all pages, nor do I see a 'lock' on panning/zooming as mentioned. Tested with the Galaxy Tab 10.1 (4.0.3) (14.0b1-XUL)
blocking-fennec1.0: --- → ?
I can also reproduce this in Aurora 14.0a2 builds.
(In reply to Cristian Nicolae (:xti) from comment #4)
> Bad build: 04/20
> Ok build: 04/21
> 
> Regression range:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=22bfdebf5cae&tochange=97170e7a5f84

Would it be possible to dig a little deeper for the regression? The range you found has a lot of "mozilla-inbound" patches in it. Could you use these tinderbox builds to narrow down the regression?

http://stage.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/

Please note that because mozilla-inbound is merged daily to mozilla-central, the regression is likely a day or two older than the range you found on mozilla-central.
I've seen this recently on XUL Nightly on my TF101, and found out that rotating the device 90°, let the browser switch orientation, and do the same in reverse fixes the missing strip of painting on the right side, but it breaks again when I pan/scroll the page in any way. Also, when rotated 90°, I can scroll not only to the bottom of the page, but way over the bottom, and once I have done that and rotate back, I also can see the bottom of the page in the previous (landscape) orientation.
(In reply to Matt Brubeck (:mbrubeck) from comment #7)
> Maybe related to bug 733596:
> http://hg.mozilla.org/mozilla-central/rev/27a52fed91a5

That patch (should) affect Native Fennec only, but this bug is happening on XUL Fennec.
(In reply to Cristian Nicolae (:xti) from comment #9)
> Good build: 
> http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-
> inbound-android-xul/1334957403/

I can reproduce the bug on this build.

> Regression range: 
> http://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=bce6cabacc88&tochange=47da536b5144

This rage includes only one patch, which touches only Mac Firefox code.
From using hg bisect on local builds:

The first bad revision is:
changeset:   92049:e9053acaa5e1
user:        Jeff Muizelaar <jmuizelaar@mozilla.com>
date:        Thu Apr 12 15:55:26 2012 -0400
summary:     Bug 744901 - Store the page size in FrameMetrics in CSS pixels in addition to device pixels. r=cjones
This bug may be a duplicate of bug 749953; testing the patch there.
This is fixed by the patch in bug 749953.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749953
blocking-fennec1.0: ? → -
You need to log in before you can comment on or make changes to this bug.