Note: There are a few cases of duplicates in user autocompletion which are being worked on.

panning (scrolling) does not work correctly on Android XUL nightly builds and wikipedia home page displays incorrectly

VERIFIED FIXED in Firefox 14

Status

()

Core
Layout
--
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: WG9s, Assigned: jrmuizel)

Tracking

({regression, top50})

14 Branch
mozilla15
ARM
Android
regression, top50
Points:
---

Firefox Tracking Flags

(firefox14+ fixed, firefox15+ verified, blocking-fennec1.0 -)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I see this on a Samsung Galaxy Tab 8.9 running Honeycomb 3.2

While viewing http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/ I am unable to pan to the bottom of the page in landscape mode, yet can pan way past the bottom of the page if in Portrait.

hg bisect determined the following:

The first bad revision is:
changeset:   92047:e9053acaa5e1
user:        Jeff Muizelaar <jmuizelaar@mozilla.com>
date:        Thu Apr 12 15:55:26 2012 -0400
summary:     Bug 744901 - Store the page size in FrameMetrics in CSS pixels in addition to device pixels. r=cjones
(Assignee)

Comment 1

5 years ago
Created attachment 619306 [details] [diff] [review]
Revert a hunk
(Assignee)

Updated

5 years ago
Whiteboard: [autoland-try]

Updated

5 years ago
Whiteboard: [autoland-try] → [autoland-in-queue]

Comment 2

5 years ago
Autoland Patchset:
	Patches: 619306
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=3cbb8707c98d
Try run started, revision 3cbb8707c98d. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=3cbb8707c98d
(Reporter)

Comment 3

5 years ago
That will fix it.  I already proved that.  I was going to post a workaround patch that reverted that part only on XUL builds.
(Reporter)

Comment 4

5 years ago
OK.  So, This patch results in both XUL and native android builds being able to correctly pan http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/ correctly.

Comment 5

5 years ago
Try run for 3cbb8707c98d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=3cbb8707c98d
Results (out of 15 total builds):
    success: 15
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-3cbb8707c98d

Updated

5 years ago
Whiteboard: [autoland-in-queue]
(Reporter)

Comment 6

5 years ago
Just a stupid question, but what does "autoland-in-queue" mean? seeing as how this is something I am not familiar with, and this does not appear to have landed anywhere.
(Reporter)

Comment 7

5 years ago
OIC.  That has to do with the try build.  Nervermind!
(Reporter)

Comment 8

5 years ago
This issue seems to also break the display of http://en.wikipedia.org/wiki/Main_Page setting to top50 site broken.
Keywords: top50
(Reporter)

Comment 9

5 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #1)
> Created attachment 619306 [details] [diff] [review]
> Revert a hunk

So, what is the status of this patch?  I notice you have neither taken the bug nor asked for review.  Is this on a track to land, or are you waiting to see my kludgey patch first?
(Reporter)

Comment 10

5 years ago
Changing severity to blocker.  It is is impossible to test Fennec XUL nightly builds with this issue present because it causes so many things to render incorrectly.
Severity: major → blocker
(Reporter)

Updated

5 years ago
Summary: panning (scrolling) does not work correctly on Android XUL nightly builds → panning (scrolling) does not work correctly on Android XUL nightly buildsand widipedia home page displays incorrectly
(Reporter)

Updated

5 years ago
Summary: panning (scrolling) does not work correctly on Android XUL nightly buildsand widipedia home page displays incorrectly → panning (scrolling) does not work correctly on Android XUL nightly build sand widipedia home page displays incorrectly
(Reporter)

Updated

5 years ago
Summary: panning (scrolling) does not work correctly on Android XUL nightly build sand widipedia home page displays incorrectly → panning (scrolling) does not work correctly on Android XUL nightly builds and widipedia home page displays incorrectly
(Reporter)

Updated

5 years ago
Component: Panning/Zooming → General
QA Contact: pan-zoom → general
(Reporter)

Updated

5 years ago
Component: General → Layout
Product: Fennec → Core
QA Contact: general → layout
Requesting tracking-firefox14 because this is a bad regression in XUL Fennec 14.
status-firefox14: --- → affected
tracking-firefox14: --- → ?

Updated

5 years ago
Assignee: nobody → jmuizelaar
tracking-firefox14: ? → +
Duplicate of this bug: 753762
Jeff, can this patch get reviewed and landed?  This is a blocker for the XUL Fennec 14 beta release.
blocking-fennec1.0: --- → ?
Version: Trunk → 14 Branch
(Assignee)

Comment 14

5 years ago
Comment on attachment 619306 [details] [diff] [review]
Revert a hunk

Revert a hunk from 744901 that causes regressions for reasons I don't understand.
Attachment #619306 - Flags: review?(jones.chris.g)

Updated

5 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

5 years ago
Summary: panning (scrolling) does not work correctly on Android XUL nightly builds and widipedia home page displays incorrectly → panning (scrolling) does not work correctly on Android XUL nightly builds and wikipedia home page displays incorrectly
blocking-fennec1.0: ? → -

Comment 15

5 years ago
Even if this ended up not blocking anything due to us continuing to ship 13.0b2 to tablets for now, we should give the people using XUL Aurora or Nightly on tablets a decent experience, esp. if it's a simple backout of a hunk that fixes this and should not make other stuff worse. Also, we should have the choice to actually ship 14 on the beta channel to tablets once it hits the beta repo - not saying that we will or have plans, but we should enable the choice for release managers if it's easy.

So, ping on the review?
tracking-firefox15: --- → ?
Comment on attachment 619306 [details] [diff] [review]
Revert a hunk

*shrug*
Attachment #619306 - Flags: review?(jones.chris.g) → review+

Updated

5 years ago
tracking-firefox15: ? → +
(Assignee)

Comment 17

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/804afa6bce8e
(Assignee)

Updated

5 years ago
Target Milestone: --- → mozilla15
(Assignee)

Comment 18

5 years ago
Looks like we don't store the device pixels content size anymore...
(Assignee)

Comment 19

5 years ago
We need to use the rect, backed out for now:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a7b4bd185f18
(Reporter)

Comment 20

5 years ago
OK so now that backing out no longer works, the implications of this regression are much more severe.
(Reporter)

Comment 21

5 years ago
But then I have no idea how to make it more severe than blocker.
Duplicate of this bug: 750306
(Assignee)

Comment 23

5 years ago
Lets try again:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb4ba09133ab
https://hg.mozilla.org/mozilla-central/rev/eb4ba09133ab
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 25

5 years ago
From what I see in some testing on my tablet, this indeed fixed it. Could we have that for 14 as well, please?
Status: RESOLVED → VERIFIED
Duplicate of this bug: 759395
We're never going to put out a 14 XUL Fennec, so marking status as wontfix.
status-firefox14: affected → wontfix
(In reply to Lukas Blakk [:lsblakk] from comment #27)
> We're never going to put out a 14 XUL Fennec, so marking status as wontfix.

In the planning meeting yesterday, it was stated that:
> XUL Fennec 14 beta 5 will be released as a security update for beta tablet users on 6/7
https://wiki.mozilla.org/Firefox/Planning/2012-05-30

See also the diagram: http://cl.ly/2A2T3u1v2Y3C0M1X230e

Are we no longer planning to release XF 14 beta?
status-firefox14: wontfix → affected
Yes, we'll have XF beta, sorry for the lack of clarity in my earlier statement. If we want this on the beta channel (never to be released) then please go ahead and nominate for aurora approval.
(Assignee)

Comment 30

5 years ago
Comment on attachment 619306 [details] [diff] [review]
Revert a hunk

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 744901 
User impact if declined: panning is broken on Android XUL nightly builds
Testing completed (on m-c, etc.): been on m-c for a bit
Risk to taking this patch (and alternatives if risky): This just reverts part of 744901 the risk should be pretty low.
String or UUID changes made by this patch: None
Attachment #619306 - Flags: approval-mozilla-aurora?
Comment on attachment 619306 [details] [diff] [review]
Revert a hunk

Looks good, low risk and bake time on m-c, approving.
Attachment #619306 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/3bd9d0c544e0
status-firefox14: affected → fixed

Updated

5 years ago
status-firefox15: --- → verified
You need to log in before you can comment on or make changes to this bug.