Note: There are a few cases of duplicates in user autocompletion which are being worked on.

ringmark's matchMedia test fails because we don't flush to create presContext for newly-created iframe

RESOLVED FIXED in mozilla16

Status

()

Core
DOM: CSS Object Model
P4
normal
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

Trunk
mozilla16
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Steps to reproduce:
 1. load http://rng.io/?all and let it run
 2. open Ring 1
 3. open 2D Games
 4. open CSS3 MediaQueries
 5. look at the results

Actual results: second and third tests fail

Expected results: all tests pass

What's happening here is that we're failing this null-check:
http://hg.mozilla.org/mozilla-central/file/6fe7dd2f8f57/dom/base/nsGlobalWindow.cpp#l3817
because presContext is null.

If I add a FlushPendingNotifications(Flush_Layout) call earlier in the method, the tests pass.

The question is whether there's any weaker flush (e.g., flush on the parent) that would be sufficient to ensure that nsGlobalWindow::GetPresContext gives an up-to-date result.

Comment 1

5 years ago
I _think_ that a Flush_Style on the parent should be sufficient if we don't care about having the prescontext size up to date.
(Assignee)

Comment 2

5 years ago
Er, I meant to do Flush_Frames and then I did Flush_Layout for some reason.

I think we do need the size up-to-date, though, and I *think* something deeper in the code does a flush to ensure that, though I need to check.

Comment 3

5 years ago
OK.  Worst case, a Flush_Layout on the parent would suffice; nsGlobalWindow even has an EnsureSizeUpToDate helper for that.
(Assignee)

Comment 4

5 years ago
nsDOMMediaQueryList actually doesn't have any flushes, but almost certainly needs them
(Assignee)

Comment 5

5 years ago
Created attachment 639487 [details] [diff] [review]
patch

Anyway, we should get this in.  comment 4 should be a separate bug.
Attachment #639487 - Flags: review?(bzbarsky)

Comment 6

5 years ago
Comment on attachment 639487 [details] [diff] [review]
patch

r=me
Attachment #639487 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/70995c6989e4
Target Milestone: --- → mozilla16
https://hg.mozilla.org/mozilla-central/rev/70995c6989e4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

3 years ago
Filed bug 1011468 on comment 4.
You need to log in before you can comment on or make changes to this bug.