Closed Bug 75407 Opened 24 years ago Closed 24 years ago

Crash sending 2nd html mail

Categories

(MailNews Core :: Composition, defect, P1)

x86
Windows 2000
defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9

People

(Reporter: scottputterman, Assigned: pavlov)

References

Details

(Whiteboard: [nsbeta1+])

Attachments

(2 files)

Using 2001041004 on Win 2000.

1. Send a mail to an address that will bring up the dialog that asks whether you
want to send it as html and plaintext, html, or plaintext
2.  In this message add some html so that it will bring up this dialog.  For
example add some bold text.
3.  Send it however you choose.
4. Repeat the process.
5.  When you hit send it crashes.

I tried this with messages with bold and with messages with links.  It appears
you can't send a 2nd html message in a given session.
marking as a smoketest blocker. cc'ing twalker to see if someone else can
reproduce besides me.
Severity: normal → blocker
Keywords: nsbeta1, smoketest
Priority: -- → P1
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9
reassigning to pavlov. will attach the stack trace afterwards.
Assignee: ducarroz → pavlov
Did you have an image in the message?
Attached file stack trace
There was no image. 
i am not able to repoduce this. I am using a windows98 machine, though.  It was 
also not reproducable on red hat linux 6.x or mac OS9.
the chrome has images, right?

my patch fixes the crasher for me, but obviously pav needs to address the real 
issue.
Argh, more papering over libpr0n problems.  Pav, you're going to fix this stuff
for real, right?

sr=shaver
patch checked in.  no longer a blocker.
Severity: blocker → critical
Keywords: smoketest
I think this is the same crash as bug 75397.
Can we put an assertion in there that says, ``fix me, pavlov!''
Severity: critical → blocker
Keywords: smoketest
the patch I checked in has a #ifdef DEBUG_pavlov that asserts.

no longer a blocker.
Severity: blocker → critical
Keywords: smoketest
Blocks: 66967
*** Bug 75225 has been marked as a duplicate of this bug. ***
real fix checked in a few days ago.
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
Using build 2001-05-02 on win, mac and linux and scott's scenario this is fixed. 
verified.
Status: RESOLVED → VERIFIED
Keywords: nsenterprise
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: