Last Comment Bug 754142 - ASSERTION: Why don't we have a Window here?
: ASSERTION: Why don't we have a Window here?
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla17
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
Depends on: 780625
Blocks: 746439 674720 678695
  Show dependency treegraph
 
Reported: 2012-05-10 18:14 PDT by Gregor Wagner [:gwagner]
Modified: 2012-08-06 09:26 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
Patch (928 bytes, patch)
2012-05-14 11:37 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
no flags Details | Diff | Review
Patch (7.93 KB, patch)
2012-05-14 14:29 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
bent.mozilla: review+
Details | Diff | Review

Description Gregor Wagner [:gwagner] 2012-05-10 18:14:57 PDT
###!!! ASSERTION: Why don't we have a Window here?: 'window', file /Users/idefix2/code/gaia/src/dom/indexedDB/IndexedDatabaseManager.cpp, line 870
WARNING: NS_ENSURE_TRUE(sop) failed: file /Users/idefix2/code/gaia/src/dom/indexedDB/CheckQuotaHelper.cpp, line 77
WARNING: SQLite returned error code 1 , Storage will convert it to NS_ERROR_FAILURE: file /Users/idefix2/code/gaia/src/storage/src/mozStoragePrivateHelpers.cpp, line 113
WARNING: Failed to rollback transaction!: file /Users/idefix2/code/gaia/src/dom/indexedDB/IDBTransaction.cpp, line 771
Comment 1 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-05-14 09:37:25 PDT
Maybe khuey can take this?
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-05-14 09:48:55 PDT
Not without a test case or any useful STR.
Comment 3 Gregor Wagner [:gwagner] 2012-05-14 10:49:36 PDT
Use the emulator build of B2G: https://wiki.mozilla.org/Gaia/Hacking and load a bunch of contacts via "UI tests"->"Insert fake contacts"
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-05-14 11:37:29 PDT
Created attachment 623738 [details] [diff] [review]
Patch

Some context would have been useful in the bug report.
Comment 5 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-05-14 12:24:43 PDT
Comment on attachment 623738 [details] [diff] [review]
Patch

Review of attachment 623738 [details] [diff] [review]:
-----------------------------------------------------------------

We talked about this, and we think there is a better way.
Comment 6 Gregor Wagner [:gwagner] 2012-05-14 13:16:20 PDT
Now I need a way to set dependencies to the gaia repository...
This blocks the favorite-contact feature for gaia.
Comment 7 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-05-14 13:17:13 PDT
There's a reason we track everything in Bugzilla ;-)
Comment 8 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-05-14 14:29:05 PDT
Created attachment 623817 [details] [diff] [review]
Patch
Comment 9 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-05-14 14:31:59 PDT
Comment on attachment 623817 [details] [diff] [review]
Patch

Review of attachment 623817 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/indexedDB/IndexedDatabaseManager.cpp
@@ +716,3 @@
>    NS_ENSURE_TRUE(ss, NS_ERROR_FAILURE);
>  
> +  if (mPrivilege == Content) {

Let's do != Chrome here, and below.
Comment 10 Brad Jackson 2012-05-16 15:19:47 PDT
My build is broken with this error. I am using GCC 4.7.

../../../dist/include/mozilla/dom/indexedDB/IndexedDatabaseManager.h:72:6: error: use of enum ‘FactoryPrivilege’ without previous declaration
../../../dist/include/mozilla/dom/indexedDB/IndexedDatabaseManager.h:158:38: error: ‘FactoryPrivilege’ has not been declared
Comment 11 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-05-17 11:12:03 PDT
Tried to land this, but GCC doesn't like forward declared enums.
Comment 12 Gregor Wagner [:gwagner] 2012-05-23 19:17:33 PDT
Kyle, any chance you can fix this?
Comment 13 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-05-28 00:56:45 PDT
It's on the list.  There's another problem here we still need to solve though.  deleteDatabase uses sqlite3_quota_remove to delete files, and if we don't install the quota handler that doesn't work.
Comment 14 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-06-28 03:11:52 PDT
We need to fix this.
Comment 15 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-06-28 03:15:04 PDT
I think i fixed the places where sqlite3_quota_remove wasn't removing files (in the android test patch). And use a bool (mIsChrome? mIsPrivileged?) instead of the enum.
Comment 16 Jonas Sicking (:sicking) PTO Until July 5th 2012-06-29 16:22:03 PDT
Not blocking unprefixing since this doesn't affect web developers. But still important to fix of course.
Comment 17 Gregor Wagner [:gwagner] 2012-07-13 15:42:25 PDT
Can we fix this now with a bool as ben suggested?
Comment 18 Gregor Wagner [:gwagner] 2012-07-25 16:29:21 PDT
Ping! We really need this fixed.
Comment 19 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-08-01 14:15:57 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/19609455b05d
Comment 20 Ryan VanderMeulen [:RyanVM] 2012-08-01 19:38:51 PDT
https://hg.mozilla.org/mozilla-central/rev/19609455b05d

Note You need to log in before you can comment on or make changes to this bug.