Last Comment Bug 726378 - Unprefix IndexedDB
: Unprefix IndexedDB
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: mozilla16
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
: Hsin-Yi Tsai [:hsinyi]
Mentors:
Depends on: 664029 idb 748630 755503 755507 755508 755509 755510 755511 755512 755514 755515 755767 757222 758357 758497 759970 762206 767999 769356 769537 770844
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-11 18:33 PST by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2014-12-27 05:56 PST (History)
10 users (show)
khuey: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (101.27 KB, patch)
2012-06-27 11:58 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
no flags Details | Diff | Splinter Review
Patch (126.03 KB, patch)
2012-06-28 19:17 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
jonas: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-11 18:33:54 PST

    
Comment 1 Jan Varga [:janv] 2012-02-11 23:38:39 PST
So if this lands, should I use something like db.mozCreateFile() in writable files patch ?
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-02-12 00:06:45 PST
Yeah. And we should moz-prefix getAll.

However I don't think we should fix this bug at least until our error handling has improved to match that of the spec.
Comment 3 Maxime RETY 2012-03-09 05:45:54 PST
About getAll : I use it
Comment 4 Maxime RETY 2012-03-09 05:51:11 PST
About get All :

I use it in production, in a real world application (used by more than 1000 people), and it proved to be a really useful method.
It's both really fast (compared to cursor iteration) and very handy.

I would definitely advocate keeping it, whether it will be in the spec one day or not.

Just my 2 cents... thanks.
Comment 5 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-03-09 16:11:07 PST
Maxime: No-one is suggesting we remove it. I'm just saying we should prefix it until it's in spec.
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-27 11:58:14 PDT
Created attachment 637200 [details] [diff] [review]
Patch
Comment 7 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-06-28 05:18:54 PDT
Comment on attachment 637200 [details] [diff] [review]
Patch

Review of attachment 637200 [details] [diff] [review]:
-----------------------------------------------------------------

You need to prefix getAll and getAllKeys at the same time too.
Comment 8 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-28 05:44:19 PDT
Comment on attachment 637200 [details] [diff] [review]
Patch

I don't think we should prefix those methods.  There's only one reasonable thing they can do, so I don't think we're constraining the future spec in any meaningful way by doing this.
Comment 9 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-06-28 09:45:39 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #8)

I'm with sicking on this. It's unlikely, but something like switching the order of the two optional args could happen. Or something we can't predict. And we should set a good example.
Comment 10 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-28 19:17:55 PDT
Created attachment 637763 [details] [diff] [review]
Patch

I'm still not thrilled about this, but here's the patch.
Comment 11 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-06-28 19:31:06 PDT
Comment on attachment 637763 [details] [diff] [review]
Patch

Review of attachment 637763 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, but we should only check this in once all dependencies are fixed.
Comment 12 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-29 11:55:43 PDT
https://hg.mozilla.org/mozilla-central/rev/8f307e676f32
Comment 13 Chris Pearce (:cpearce) 2012-07-01 22:03:41 PDT
Unfortunately I had to backout bug 758357 due to it causing bug 770085, so I assume that Jonas' requirement that all dependencies be fixed before we ship this are now no longer upheld...
Comment 14 Jean-Yves Perrier [:teoli] 2014-12-27 05:56:59 PST
All pages of doc have been unprefixed long ago + info up-to-date on https://developer.mozilla.org/en-US/Firefox/Releases/16#API.2FDOM

Note You need to log in before you can comment on or make changes to this bug.