Closed Bug 754203 Opened 8 years ago Closed 7 years ago

Incorrect image in sent message in TB version 11 and 12.0.1

Categories

(Thunderbird :: General, defect)

12 Branch
x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 766495

People

(Reporter: ykloh9228, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

When I forward an email with an embedded picture, the mail was sent with a different picture from an earlier email I had received and forwarded months ago.


Actual results:

I discover this when I checked my SENT Folder on the email I sent or forwarded and found the mistake. 
Thunderbird had embedded the wrong picture from an earlier email received and forwarded months ago.
Also I found in the Drafts Folder all my sent emails appearing there as duplicates, including the one sent with the wrong embedded pic. 
However this draft copy has the correct embedded picture so I had to Resend this particular email again with an apology.


Expected results:

Thunderbird should not have embedded the wrong picture TAKEN from an earlier email and replace it when I forward my mails. 
I believe TB 12.0.1 is mixing things up in the program.
This had happened twice....once in version 11.0.1 and now in version 12.0.1.
(In reply to ykloh9228 from comment #0)
Maybe this is caused by an add-on you have. Start Thunderbird in safe-mode and re-try.
Can you also confirm that the recipient received the wrong image?
It may be that TB only wrongly displays the message on your machine, but the message was sent correctly.
Summary: This started happening in version 11 and continue in version 12.0.1 → Incorrect image in sent message in TB version 11 and 12.0.1
Same problem still in TB 15.0.1. TB is randomly replacing inline images in Reply / Forward messages with always the same image from message, that was longer in the Drafts folder. Messages are sent with wrong image.
In addition, wrong image is stretched / resampled to the size of previous correct image.
Same thing with TB 17.0 

Pretty embarrassing results with an image attached to a message in the DRAFTS folder that replaced the content of an embedded image in a forwarded message.

This seriously needs to be fixed.
To bug opener and all problem reporter in this bug: 

Problem on mail in local mail folder? (POP3/Local Folders, not IMAP)
Do you enable auto-compact?
Do you enable auto-save?
Was offset of forwarded mail changed by Compact while you are composing forward mail?

Same problem as bug 766495?

As I wrote in bug 766495 comment #14, that bug is not draft only problem.
See bug 817245(and bugs pointed in that bug) for variants of phenomenon or external symptom.
(In reply to WADA from comment #5)

Problem on mail in local mail folder? -> POP3/Local Folders
Do you enable auto-compact? -> yes, 20 MB threshold
Do you enable auto-save? -> yes, every 5 minutes
Was offset of forwarded mail changed by Compact while you are composing forward mail? -> don't know

I cannot decide whether the behavior I saw is similar to the other bugs. What happened in my case is described above in https://bugzilla.mozilla.org/show_bug.cgi?id=754203#c4 and https://bugzilla.mozilla.org/show_bug.cgi?id=754203#c0 in the "steps to reproduce" section.

Thunderbird did not display the wrong image in my SENT folder, the image simply appeared to be broken (invisible) in HTML view. When switching to text view and saving the attachments on the file system though, the first attachment was the wrong image. 

After forwarding the corrupt message to my Lotus Notes address, I was able to see the wrong embedded image as well.
(In reply to osu from comment #6)
> Thunderbird did not display the wrong image in my SENT folder, the image
> simply appeared to be broken (invisible) in HTML view.
> When switching to text view and saving the attachments on the file system though, 
> the first attachment was the wrong image. 
> After forwarding the corrupt message to my Lotus Notes address, I was able
> to see the wrong embedded image as well.

Do you read bug 817245 well?
As written in that bug, bug 766495 and bug 799450 can occur on image part.
If part in wrongly referred mail(placed at same offset by Compact) is different image type(for example, image/jpeg in current mail, but image/png in the wrongly referred mail), such phenomenon may occur.
Are you talking about which part of what kind of part type under which part of multipart of what kind of multipart?

Anyway, because your case is local mail folder, auto-compact=enabled, problem like bug 766495, bug 799450, and bug 817245 can occur.
Setting dependency to bug 766495 and bug 799450, for ease of tracking and analysis.

If you'll see problem again, check "image location:" and "offset of (wrongly) referenced mail", please.
Depends on: 799450, 766495
(In reply to WADA from comment #7)
> Do you read bug 817245 well?
> As written in that bug, bug 766495 and bug 799450 can occur on image part.
> If part in wrongly referred mail(placed at same offset by Compact) is
> different image type(for example, image/jpeg in current mail, but image/png
> in the wrongly referred mail), such phenomenon may occur.
Indeed: The wrong image sent was a TIFF image, the correct image would have been a JPEG image.

Thanks for your efforts and happy new year!
Oliver.
If closing as dup is wrong, re-open this bug with sufficient data for problem analysis, please.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
No longer depends on: 766495, 799450
Resolution: --- → DUPLICATE
Duplicate of bug: 766495
Had the same problem occasionally even in TB Ver17, but after DISABLING all Add-ons (both Plugins and Extensions)I haven't encounter any errors YET so far.
I had this same problem today.  I replied to an email that had a small embedded real estate advertisement at the end of the email text(and a pdf attachment) and the reply that was sent wrongly (and bizarrely) picked up and inserted in it's place an embedded photo from one of my old (2013) draft email messages, which had been stored there without an email address.  As per ykloh9228@gmail.com the image was stretched and distorted.  I also had two duplicates of my new email (one incomplete) sitting in my drafts.

I'm using TB 31.7.0

Strange days.
Hi!

We had the same issue some weeks ago; Thunderbird keeps replacing images randomly when I reply, and makes a lot of drafts. Version 38.5.1
The same problem on Linux Version 45.7.0. 
This is very serious privacy bug, because private screen shots are sent to unwanted recipients RANDOMly. 
The shame is that chache doesn't use good hashing.
You need to log in before you can comment on or make changes to this bug.