Last Comment Bug 754209 - OSFileConstants.cpp does not build with VC9
: OSFileConstants.cpp does not build with VC9
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: js-ctypes (show other bugs)
: unspecified
: All Windows XP
: -- normal (vote)
: mozilla15
Assigned To: David Rajchenbach-Teller [:Yoric] (please use "needinfo")
:
Mentors:
Depends on: 739740
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 02:24 PDT by David Rajchenbach-Teller [:Yoric] (please use "needinfo")
Modified: 2012-05-14 14:12 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for VC9 (1.38 KB, patch)
2012-05-11 02:27 PDT, David Rajchenbach-Teller [:Yoric] (please use "needinfo")
no flags Details | Diff | Splinter Review
Patch for VC9 (1.47 KB, patch)
2012-05-11 02:50 PDT, David Rajchenbach-Teller [:Yoric] (please use "needinfo")
neil: review+
Details | Diff | Splinter Review
Patch for VC9 (1.48 KB, patch)
2012-05-11 03:06 PDT, David Rajchenbach-Teller [:Yoric] (please use "needinfo")
no flags Details | Diff | Splinter Review

Description David Rajchenbach-Teller [:Yoric] (please use "needinfo") 2012-05-11 02:24:11 PDT
Quote from bug 739740: « This doesn't build on VC9 because it doesn't have ELOOP, ELOOP, EOPNOTSUPP, EOVERFLOW, ETIMEDOUT or EWOULDBLOCK. »
Comment 1 David Rajchenbach-Teller [:Yoric] (please use "needinfo") 2012-05-11 02:27:49 PDT
Created attachment 623081 [details] [diff] [review]
Patch for VC9
Comment 2 David Rajchenbach-Teller [:Yoric] (please use "needinfo") 2012-05-11 02:30:29 PDT
Comment on attachment 623081 [details] [diff] [review]
Patch for VC9

Neil, does this patch fix the issue for you?
Comment 3 neil@parkwaycc.co.uk 2012-05-11 02:44:47 PDT
Comment on attachment 623081 [details] [diff] [review]
Patch for VC9

>+#if defined(ELOOP) // not defined with VC9
>   INT_CONSTANT(ELOOP),
>+#endif // defined(ELOOP)
>   INT_CONSTANT(EMFILE),
>   INT_CONSTANT(ENAMETOOLONG),
>   INT_CONSTANT(ENFILE),
>   INT_CONSTANT(ELOOP),
Still fails here ;-)
Comment 4 David Rajchenbach-Teller [:Yoric] (please use "needinfo") 2012-05-11 02:50:54 PDT
Created attachment 623086 [details] [diff] [review]
Patch for VC9

Same one, with just one ELOOP :)
Comment 5 David Rajchenbach-Teller [:Yoric] (please use "needinfo") 2012-05-11 03:06:00 PDT
Created attachment 623090 [details] [diff] [review]
Patch for VC9
Comment 6 Philip Chee 2012-05-12 02:29:26 PDT
Does not apply cleanly due to bug 747872 being backed out.
Comment 7 Philip Chee 2012-05-12 02:33:23 PDT
> Does not apply cleanly due to bug 747872 being backed out.
I guess attachment 622753 [details] [diff] [review] needs to be applied first.
Comment 9 Matt Brubeck (:mbrubeck) 2012-05-14 14:12:35 PDT
https://hg.mozilla.org/mozilla-central/rev/6309cc2b328d

Note You need to log in before you can comment on or make changes to this bug.