Last Comment Bug 754872 - Avoid using two passes for glyph overlap on mobile
: Avoid using two passes for glyph overlap on mobile
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
: 748522 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 08:59 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-05-21 18:14 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
soft
+


Attachments
Avoid using two passes for glyph overlap on mobile (3.62 KB, patch)
2012-05-14 08:59 PDT, Jeff Muizelaar [:jrmuizel]
joe: review+
blassey.bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-05-14 08:59:46 PDT
Created attachment 623692 [details] [diff] [review]
Avoid using two passes for glyph overlap on mobile

Chrome & Safari both use a single pass for overlapping glyphs. We shouldn't try so hard when running on mobile.
Comment 1 Ed Morley [:emorley] 2012-05-15 06:29:28 PDT
https://hg.mozilla.org/mozilla-central/rev/9b064f0ec4f8
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-05-18 06:14:07 PDT
*** Bug 748522 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-05-18 06:15:52 PDT
Comment on attachment 623692 [details] [diff] [review]
Avoid using two passes for glyph overlap on mobile

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: Slower text rendering
Testing completed (on m-c, etc.): Been on mozilla-central for a while
Risk to taking this patch (and alternatives if risky): Mobile only, possible incorrect rendering, but the patch is just avoiding a slow path. It shouldn't add any new bugs.
Comment 4 Jeff Muizelaar [:jrmuizel] 2012-05-21 18:13:31 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/7cee34548471

Note You need to log in before you can comment on or make changes to this bug.