Toolbar button indicator for not logged in (assuming sidebar is closed)

RESOLVED DUPLICATE of bug 763837

Status

()

Firefox
SocialAPI
RESOLVED DUPLICATE of bug 763837
5 years ago
4 years ago

People

(Reporter: mixedpuppy, Assigned: Boriss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs-ux][Fx16])

(Reporter)

Description

5 years ago
moved from https://github.com/mozilla/socialapi-dev/issues/34

We need a story for when the sidebar isn't visible (or for when a provider isn't the current provider) but the user is not logged in. I guess we would need some visual indication of that state in the toolbar area, and some action taken when they click on said indication.

Updated

5 years ago
Whiteboard: [needs-ux] → [needs-ux][Fx16]

Comment 1

5 years ago
Boriss, can you help us figure out what the indicator is when a user is not logged in (and they can't tell because the sidebar is closed.)
Assignee: nobody → jboriss
Blocks: 763837
Summary: login state → Toolbar button indicator for not logged in (assuming sidebar is closed)
I can take this bug once Boriss has put together her thoughts on this.

If we have a button available, then I think we could do a grayscaled version of the providers icon (using SVG) to show that they are not logged in. If the user clicks on the button then we could either do a dropdown menu with an option to log in, or we could take the user to a login screen directly.
(Reporter)

Comment 3

5 years ago
(In reply to Jared Wein [:jaws] from comment #2)
> I can take this bug once Boriss has put together her thoughts on this.
> 
> If we have a button available, then I think we could do a grayscaled version
> of the providers icon (using SVG) to show that they are not logged in. If
> the user clicks on the button then we could either do a dropdown menu with
> an option to log in, or we could take the user to a login screen directly.

I'm already doing a bunch of work on the toolbarbutton in bug 763837, and will have the logout logic added to the api docs soon.  I just need to know the desired ux to finish bug 763837.  Then the implement/land bug can be started.
(Reporter)

Comment 4

5 years ago
I'm going to dup this to 763837.  Implementation and docs are done for supporting logout state including basic UI.  UI review/enhancement requested in bug 763837, as well there is an attachment there showing the logged out state UI.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763837
You need to log in before you can comment on or make changes to this bug.