Last Comment Bug 755511 - Revert all in-memory data when aborting versionchange transactions.
: Revert all in-memory data when aborting versionchange transactions.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
: Hsin-Yi Tsai [:hsinyi]
Mentors:
Depends on:
Blocks: 726378
  Show dependency treegraph
 
Reported: 2012-05-15 14:28 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2016-09-14 16:28 PDT (History)
2 users (show)
khuey: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (17.27 KB, patch)
2012-06-27 06:38 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
jonas: review-
Details | Diff | Splinter Review
Patch (20.45 KB, patch)
2012-06-28 13:14 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
jonas: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-05-15 14:28:42 PDT

    
Comment 1 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-05-17 14:25:42 PDT
By the way, this includes reverting the .indexNames property on deleted objectStores.
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-27 06:38:12 PDT
Created attachment 637100 [details] [diff] [review]
Patch
Comment 3 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-06-28 09:35:38 PDT
This patch won't revert the indexNames property for deleted object stores, will it?
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-28 09:37:02 PDT
Sure it will.  Look at the test.
Comment 5 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-06-28 09:56:51 PDT
Comment on attachment 637100 [details] [diff] [review]
Patch

Review of attachment 637100 [details] [diff] [review]:
-----------------------------------------------------------------

r- due to the deleted object stores thing.

::: dom/indexedDB/test/error_events_abort_transactions_iframe.html
@@ +156,4 @@
>        ok(db.objectStoreNames.contains("foo"), "Has correct objectStore");
> +      ok(db.objectStoreNames.contains("bar"), "Has correct objectStore");
> +
> +      db.close();

Why add this .close() call? Might be nicer to not have that to make sure that we revert even if the database isn't explicitly closed.
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-28 13:14:34 PDT
Created attachment 637645 [details] [diff] [review]
Patch

The db.close call is necessary to start the next versionchange transaction.
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-29 11:52:54 PDT
https://hg.mozilla.org/mozilla-central/rev/f6b519d4881b

Note You need to log in before you can comment on or make changes to this bug.