Input not accepting angled brackets on Gingerbread

VERIFIED FIXED in Firefox 14

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: are.zee.dee, Assigned: cpeterson)

Tracking

(Blocks 1 bug, {inputmethod, regression})

Trunk
Firefox 16
ARM
Android
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, firefox16 verified, blocking-fennec1.0 +)

Details

(Whiteboard: [VKB])

Attachments

(1 attachment)

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19

Steps to reproduce:

Mobile Firefox Beta (android).
My password for fb.me ( facebook.com ) begins with a <


Actual results:

nothing, < character wasnt input


Expected results:

it should have inserted a * character.
Robert, can you provide us with which phone you're testing with, and which Android Input Method? You can find that out by long-tap and holding on any input field, a context-menu will appear with "Select Input Method".

Back to the bug, I tried this on my Samsung Galaxy Nexus (Android 4.0.4) on http://www.facebook.com's sign-in and could not reproduce. I entered a single '<' and '>' and both we're accepted and masked appropriately.
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Summary: input field → Input not accepting angled brackets?
I can reproduce this on the Galaxy SII, using current trunk build.
In fact, I can reproduce this bug on every text input. I'm just unable to input the '<' and '>' on that device.
It works fine on the Galaxy Nexus.

It seems to work fine in XUL Fennec, btw.

So a regression range might be useful here.
Status: UNCONFIRMED → NEW
blocking-fennec1.0: --- → ?
Ever confirmed: true
Whiteboard: [VKB]
Version: Firefox 15 → Trunk
Assignee

Updated

7 years ago
Component: General → IME
QA Contact: general → ime
Summary: Input not accepting angled brackets? → Input not accepting angled brackets on Galaxy SII
I think this might be a dup?  Need to double check
I am able to type <> in all inputs (address bar, content text fields).
Good build: Nightly 14.0a1 (2012-04-19)
Bad build: Nightly 14.0a1 (2012-05-20)

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=da53be684794&tochange=22bfdebf5cae
Martijn says he can reproduce on trunk and Kevin says he can't. Can you guys figure out what is different between you two so we can narrow down the STR?
Assignee: nobody → cpeterson
blocking-fennec1.0: ? → +
Keywords: qawanted
Assignee

Comment 8

7 years ago
Martijn, are you using the Galaxy SII's stock VKB? Do you have predictive text input enabled (i.e. text is underlined and VKB displays word suggestions)? Are all websites affected?
blocking-fennec1.0: + → ?
blocking-fennec1.0: ? → +
It looks like the bug is reproducible on all non-ICS devices and affects every text input:

Reproducible:
Samsung Galaxy SII (2.3.4) - default VKB, Swype and Hacker's keyboard 
Htc Desire (2.2) - default VKB
Htc Desire Z (2.3.3) - default VKB and SwiftKey
LG Optimus 2x (2.2) - default VKB and SwiftKey

Not reproducible:
Samsung Galaxy Nexus (4.0.2) - default VKB

Predictive text was disable all the time.
This still works for me on my Galaxy SII (4.0.4), stock VKB
Assignee

Comment 11

7 years ago
I can reproduce this on Galaxy SII (stock Gingerbread), but I am just beginning to investigate.

This bug would affect a lot of users, so I'm surprised it was not reported earlier.
Status: NEW → ASSIGNED
For future reference - we're leaving this on the blocker list because it's a recent regression and we therefore can't confidently reason about the user impact post-release.
Assignee

Comment 13

7 years ago
Given the regression window, cset 23ad93b7c90a for bug 687717 is the likely culprit. We are probably not correctly synthesizing KeyEvents for '<', '>', and possibly other shifted characters.
Keywords: qawanted
Assignee

Comment 14

7 years ago
I am not able to input the following symbol characters on Gingerbread (Galaxy SII and Note):

  < maps to keycode ALT+B
  > maps to keycode ALT+N
  & maps to keycode ALT+7
  € (Euro) maps to keycode ALT+SHIFT+R
  ¥ (Yen) maps to keycode ALT+SHIFT+F
  ¡ (Inverted exclamation mark) maps to keycode ALT+SHIFT+Y

These symbols all work on ICS, which produces saner keycodes that match a desktop keyboard:

  < maps to keycode SHIFT+,
  > maps to keycode SHIFT+.
  & maps to keycode SHIFT+7
  € (Euro) has no keycode mapping, so we send composition string "€"
  ¥ (Yen) has no keycode mapping, so we send composition string "¥"
  ¡ (Inverted exclamation mark) has no keycode mapping, so we send composition string "¡"
Assignee

Comment 15

7 years ago
qawanted, do the < > & € ¥ ¡ symbols work correctly on Froyo and Honeycomb? I'm curious if this problem is unique to Gingerbread.
Keywords: qawanted
Summary: Input not accepting angled brackets on Galaxy SII → Input not accepting angled brackets on Gingerbread
Assignee

Comment 16

7 years ago
I am testing Froyo and Honeycomb keycodes now. I will then post a patch that special cases these symbol characters for the affected Android OS versions.
Assignee

Comment 17

7 years ago
Honeycomb works correctly. It produces the same keycodes as ICS.

Froyo is broken like Gingerbread. The < > € ¥ ¡ symbols do not work, but surprisingly the & symbol does.

After testing some alternate VKBs, I see that the • and … symbols are also broken on Froyo and Gingerbread.
Assignee

Comment 18

7 years ago
On Froyo and Gingerbread:

'•' maps to keycode ALT+SHIFT+@
'…' maps to keycode ALT+SHIFT+.
SwiftkeyX, Swype, Stock keyboard doesn't seem to type the < >; Simeji and Kaede IME do type the < >.
Assignee

Comment 20

7 years ago
Remap Gingerbread's unusual keycodes for some symbol characters.
Attachment #631247 - Flags: review?(blassey.bugs)
Comment on attachment 631247 [details] [diff] [review]
remap-gingerbread-symbols.patch

Review of attachment 631247 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/GeckoInputConnection.java
@@ +656,5 @@
>      }
>  
> +    private KeyEvent[] synthesizeKeyEvents(char inputChar) {
> +        // Some symbol characters produce unusual key events on Froyo and Gingerbread.
> +        if (Build.VERSION.SDK_INT <= 10) {

I believe you want < 10 (less than Honeycomb). Either way use the named constant (Build.VERSION_CODES.HONEYCOMB)
Attachment #631247 - Flags: review?(blassey.bugs) → review+
Keywords: qawanted
Assignee

Comment 22

7 years ago
(In reply to Brad Lassey [:blassey] from comment #21)
> I believe you want < 10 (less than Honeycomb). Either way use the named
> constant (Build.VERSION_CODES.HONEYCOMB)

I'll use the named constants like you recommend. I prefer them, but other reviewers have asked me to replace the named constants with numbers. :)

btw, Honeycomb is API Level 11:
https://developer.android.com/guide/appendix/api-levels.html#intro
Assignee

Comment 23

7 years ago
Comment on attachment 631247 [details] [diff] [review]
remap-gingerbread-symbols.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Froyo and Gingerbread users will not be able to type some symbol characters, such as < and >
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Android Java only. Some Froyo or Gingerbread devices may produce different keycodes than the phones I have tested. In that unlikely scenario, the devices may or may not work.
String or UUID changes made by this patch: N/A
Attachment #631247 - Flags: approval-mozilla-beta?
Attachment #631247 - Flags: approval-mozilla-aurora?
Attachment #631247 - Flags: approval-mozilla-beta?
Attachment #631247 - Flags: approval-mozilla-beta+
Attachment #631247 - Flags: approval-mozilla-aurora?
Attachment #631247 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/f72e14bf569b

Per the tree rules, please set the target milestone when landing on inbound.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Assignee

Updated

7 years ago
Depends on: 768727

Comment 28

7 years ago
The issues are not reproducible anymore. Verified on:
Samsung Galaxy SII (2.3.4) - default VKB, Hacker's keyboard 
Htc Desire (2.2) - default VKB
Htc Desire Z (2.3.3) - default VKB and Hacker's keyboard 
Using:
Nightly Fennec 16.0a1 (2012-07-02)
Nightly Aurora 16.0a2 (2012-07-02)
Firefox Mobile 14 beta 10 build2

The only issue that remains is Bug 768727 that i can reproduce on Htc Desire Z (2.3.3) for both  Aurora 16.0a2 (2012-07-02) and Firefox Mobile 14 beta 10 build2. Waiting for the patch in Bug 768727 to land in Aurora and Beta to mark this verified/fixed.

Comment 29

7 years ago
The issue in Bug 768727 was fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.