Droid Bionic interprets SHIFT+7 as number '7', not ampersand '&'

VERIFIED FIXED in Firefox 14

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: cpeterson, Assigned: bnicholson)

Tracking

16 Branch
Firefox 16
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, firefox16 verified, blocking-fennec1.0 .N+, fennec14+)

Details

(Whiteboard: VKB)

Attachments

(1 attachment)

gatordan reported this problem at https://news.ycombinator.com/item?id=4162812

> in every website I visit when I type an & symbol into an input element it is 
> replaced with a 7 (e.g. I type "password&" the input shows "password7"). It's 
> happening across all sites for both text and more importantly password inputs so 
> I can't login to many of sites I regularly visit and really try the app.
> 
> I'm using a Droid Bionic, android version 2.3.4 and this is on the default 
> virtual keyboard. Ampersand is the only character affected as far as i can tell.
I've got a Droid Bionic at the Toronto office. I can verify this for you on Thursday if need be.
(In reply to Aaron Train [:aaronmt] from comment #1)
> I've got a Droid Bionic at the Toronto office. I can verify this for you on
> Thursday if need be.

Thanks, Aaron. I don't have a Droid Bionic, so I was trying to track one down. :)
I haven't reproduced this bug yet, but it should probably be a 14.0.1 soft blocker. Some keyboards can't type '&' if it is SHIFT+7.

This bug is a regression from bug 755517, where I needed to remap ALT+7 to SHIFT+7.
Blocks: 755517
Status: NEW → ASSIGNED
Yes, I can reproduce this simply enough by visiting Gmail and tapping on '&' in the password field and out comes a '7'.
blocking-fennec1.0: --- → ?
This is a critical bug because some people can't enter passwords containing '&' characters!
We need to make sure work is progressing on this bug. Chris should bring in Brian to help out and keep it moving forward.
tracking-fennec: --- → 14+
blocking-fennec1.0: ? → .N+
Confirming that non-password masked fields are affected too; simply used Google Search field and SUMO's Ask a Question field. & -> 7.
Tested a fennec build in-channel of Chris's and it fixes the issue on the Droid Bionic.
(In reply to Aaron Train [:aaronmt] from comment #8)
> Tested a fennec build in-channel of Chris's and it fixes the issue on the
> Droid Bionic.

Does it regress the fix in bug 755517?
(In reply to Mark Finkle (:mfinkle) from comment #9)
> Does it regress the fix in bug 755517?
No.
Send '&' as composition string because some Gingerbread VKBs incorrectly map '&' key events.
Attachment #637977 - Flags: review?(blassey.bugs)
Attachment #637977 - Flags: feedback?(bnicholson)
r=blassey

not marking the patch because this bug report is exhibiting a bug in bugzilla that some of the bugzilla maintainers have been trying to get a look at.
Attachment #637977 - Flags: feedback?(bnicholson) → feedback+
Oops, just saw comment 12 - hope I didn't ruin anything.
Comment on attachment 637977 [details] [diff] [review]
fix-gingerbread-ampersand.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 755517
User impact if declined: Some Gingerbread users will not be able to type '&' which sucks if their passwords include '&'!
Testing completed (on m-c, etc.): local builds
Risk to taking this patch (and alternatives if risky): Low risk because this code path ONLY affects Froyo and Gingerbread devices when they are typing '&'.
String or UUID changes made by this patch:
Attachment #637977 - Flags: approval-mozilla-beta?
Attachment #637977 - Flags: approval-mozilla-aurora?
Brian, I'll be on PTO next week. Do you mind uplifting this patch to Aurora and Beta after it's approved? I'd like to get this fix into 14.0.1.
Assignee: cpeterson → bnicholson
https://hg.mozilla.org/mozilla-central/rev/edd37b3c169d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Comment on attachment 637977 [details] [diff] [review]
fix-gingerbread-ampersand.patch

Approved, we definitely want people on those systems to be able to use '&' how they need to.  Please land to tip of mozilla-beta so it can go out in 14.0.1
Attachment #637977 - Flags: approval-mozilla-beta?
Attachment #637977 - Flags: approval-mozilla-beta+
Attachment #637977 - Flags: approval-mozilla-aurora?
Attachment #637977 - Flags: approval-mozilla-aurora+
Verified/fixed on:
Htc Desire Z (2.3.3) - default VKB and Hacker's keyboard 
Using:
Nightly Fennec 16.0a1 (2012-07-02)

The issue is still reproducible for both  Aurora 16.0a2 (2012-07-02) and Firefox Mobile 14 beta 10 build2. Waiting for the patch to land in Aurora and Beta to mark this verified/fixed.
Paul,

You would need to verify this on the Droid Bionic ......
Verified/fixed on:
Nightly Fennec 16.0a1 (2012-07-03)
Aurora Fennec 15.0a2 (2012-07-03)
Using:
Droid Bionic (2.3.4) - default VKB

The issue is still for Firefox Beta 14.0b10 . Waiting for the patch to land in Beta to mark this verified/fixed.
Comment on attachment 637977 [details] [diff] [review]
fix-gingerbread-ampersand.patch

Review of attachment 637977 [details] [diff] [review]:
-----------------------------------------------------------------

r=blassey
Attachment #637977 - Flags: review?(blassey.bugs) → review+
Verified/fixed on:
Firefox Beta 14.0b11 (2012-07-05)
Using:
Droid Bionic (2.3.4) - default VKB
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.