Closed Bug 755590 Opened 8 years ago Closed 2 years ago

Add UA override for sites.google.com - top bar doesn't show up in Firefox for Android

Categories

(Web Compatibility :: Interventions, defect, P1)

ARM
Android
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jsmith, Assigned: denschub)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [serversniff][google][sitewait][country-all][sitepatch-built])

Attachments

(3 files)

The search bar does not appear on fennec native on the main starting page on google sites (sites.google.com) after logging in. On the stock browser, the search bar does appear. Strangely enough, this works on desktop firefox fine. Might be worth investigating to see if this is a problem on our end before determining that this is an evangelism issue.

Webkit Used:

-webkit-tap-highlight
-webkit-box-shadow
-webkit-border-radius
-webkit-box-pack
-webkit-box-orient
-webkit-box-align
-webkit-box
-webkit-gradient
-webkit-box-shadow
-webkit-background-size
-webkit-transform
-webkit-box-flex
-webkit-text-size-adjust
Component: General → Evangelism
QA Contact: general → evangelism
UA sniffing evident that causes the search bar to appear or not. This is an evangelism problem.
No longer blocks: google-evangelism
blocking-kilimanjaro: --- → +
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 15 → unspecified
Server-side sniffing omits parts of the page, including a SCRIPT element that starts 
var searchBox = new sites.Searchbox('sites-searchbox-select-button') ...
Whiteboard: [serversniff][google][contactready]
I wonder if it's a similar issue than Bug 920466 	


1. Go to http://sites.google.com/
2. Log in to a Google Account

* on IOS there's a top bar with Google+, Gmail, Sites, Web, plus
* on Firefox for Android no top bar.


To contact.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [serversniff][google][contactready] → [serversniff] [google] [contactready]
Whiteboard: [serversniff] [google] [contactready] → [serversniff] [google] [contactready] [country-all]
Changing to sitewait. As we contacted them for Bug 920466.
Whiteboard: [serversniff] [google] [contactready] [country-all] → [serversniff] [google] [sitewait] [country-all]
See Also: → 920466
the issue is still there, and also no top bar with Firefox OS.
Summary: Google Sites Main Page - Search Bar Does Not Appear on Fennec Native, Shows Up on Webkit → sites.google.com - top bar doesn't show up in Firefox for Android
Attached image fxand-sites.png
rendered on firefox with a firefox mobile android UA
UA override + unprefixing service will sove some of the issues.
Note that Opera/Blink is being given the desktop site.
The top bar of site Google sites is appearing now only if we fake as Chrome.
With webkit prefs set to true we get the right layout.

but as Firefox + webkit prefs, no luck.
Let's do a UA override here.
Flags: needinfo?(miket)
So, if we override this now we'll end up making it look more broken for release and beta users. We need to wait on 1259345 making it to release.
Depends on: 1259345
Summary: sites.google.com - top bar doesn't show up in Firefox for Android → Add UA override for sites.google.com - top bar doesn't show up in Firefox for Android
mike,

from experience, it's usually better to open a separate bug for the UA override and create a dependency.
Flags: needinfo?(miket)
Flags: needinfo?(miket)
(In reply to Karl Dubost :karlcow from comment #13)
> from experience, it's usually better to open a separate bug for the UA
> override and create a dependency.

Yeah, sorry. Will do in the future. ^_^

Note to self: when 1259345 is in Release (either 48 or 49 -- we'll know more in a few days) we can move forward with this.
Dennis, when we can do UA overrides in Fennec with gofaster, will you add one for this?
Assignee: kdubost → dschubert
Priority: -- → P1
blocking-kilimanjaro: + → ---
Component: Mobile → Go Faster
Flags: needinfo?(dschubert)
Product: Tech Evangelism → Web Compatibility Tools
Flags: needinfo?(dschubert)
Attachment #8997390 - Flags: review?(twisniewski)
Attachment #8997390 - Flags: review?(twisniewski) → review+
Blocks: 1338586
The UA override is built and landing is happening in bug 1338586, so we can close this.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Verified as fixed on Latest build of Nightly with GoFaster add-on 2.0.1 installed. 
Device: OnePlus 5T (Android 8.1.0), Nokia 6 (Android 7.1.1), Motorola Nexus 6 (Android 7.1.1).
Status: RESOLVED → VERIFIED
Whiteboard: [serversniff] [google] [sitewait] [country-all] → [serversniff][google][sitewait][country-all][sitepatch-built]
You need to log in before you can comment on or make changes to this bug.