Last Comment Bug 755692 - accessible/public/msaa is being rebuilt unnecessarily using pymake on Windows
: accessible/public/msaa is being rebuilt unnecessarily using pymake on Windows
Status: RESOLVED FIXED
[buildfaster:?]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Gregory Szorc [:gps]
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: 755684
  Show dependency treegraph
 
Reported: 2012-05-16 05:22 PDT by Ed Morley [:emorley]
Modified: 2012-05-28 10:41 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ed Morley [:emorley] 2012-05-16 05:22:10 PDT
Broken out from bug 755684.

On Windows using pymake, after two successive |pymake -f client.mk| with no changes made:

{
make.py[7]: Entering directory 'd:\obj-inbound\accessible\public\msaa'
ISimpleDOMDocument_i.c
ISimpleDOMDocument_p.c
ISimpleDOMText_p.c
ISimpleDOMText_i.c
ISimpleDOMNode_i.c
ISimpleDOMNode_p.c
ISimpleDOMDocument_i.c

ISimpleDOMNode_i.c

ISimpleDOMText_i.c

ISimpleDOMNode_p.c

ISimpleDOMDocument_p.c

ISimpleDOMText_p.c

   Creating library AccessibleMarshal.lib and object AccessibleMarshal.exp
d:\srcdirs\inbound\config\rules.mk:1116:0$ c:/mozilla-build/python/python2.7.exe -O d:/srcdirs/inbound/build/cl.py cl -FoISimpleDOMDocument_i.obj -c  -DREGISTER_PROXY_DLL  -Id:/srcdirs/inbound/accessible/public/msaa -I. -I../../../dist/include -I../../../dist/include/nsprpub  -Id:/obj-inbound/dist/include/nspr -Id:/obj-inbound/dist/include/nss        -TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553  -DNDEBUG -DTRIMMED -Oy- -MD            -FI ../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT d:/obj-inbound/accessible/public/msaa/ISimpleDOMDocument_i.c
d:\srcdirs\inbound\config\rules.mk:1116:0$ c:/mozilla-build/python/python2.7.exe -O d:/srcdirs/inbound/build/cl.py cl -FoISimpleDOMDocument_p.obj -c  -DREGISTER_PROXY_DLL  -Id:/srcdirs/inbound/accessible/public/msaa -I. -I../../../dist/include -I../../../dist/include/nsprpub  -Id:/obj-inbound/dist/include/nspr -Id:/obj-inbound/dist/include/nss        -TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553  -DNDEBUG -DTRIMMED -Oy- -MD            -FI ../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT d:/obj-inbound/accessible/public/msaa/ISimpleDOMDocument_p.c
d:\srcdirs\inbound\config\rules.mk:1116:0$ c:/mozilla-build/python/python2.7.exe -O d:/srcdirs/inbound/build/cl.py cl -FoISimpleDOMText_p.obj -c  -DREGISTER_PROXY_DLL  -Id:/srcdirs/inbound/accessible/public/msaa -I. -I../../../dist/include -I../../../dist/include/nsprpub  -Id:/obj-inbound/dist/include/nspr -Id:/obj-inbound/dist/include/nss        -TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553  -DNDEBUG -DTRIMMED -Oy- -MD            -FI ../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT d:/obj-inbound/accessible/public/msaa/ISimpleDOMText_p.c
d:\srcdirs\inbound\config\rules.mk:1116:0$ c:/mozilla-build/python/python2.7.exe -O d:/srcdirs/inbound/build/cl.py cl -FoISimpleDOMText_i.obj -c  -DREGISTER_PROXY_DLL  -Id:/srcdirs/inbound/accessible/public/msaa -I. -I../../../dist/include -I../../../dist/include/nsprpub  -Id:/obj-inbound/dist/include/nspr -Id:/obj-inbound/dist/include/nss        -TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553  -DNDEBUG -DTRIMMED -Oy- -MD            -FI ../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT d:/obj-inbound/accessible/public/msaa/ISimpleDOMText_i.c
d:\srcdirs\inbound\config\rules.mk:1116:0$ c:/mozilla-build/python/python2.7.exe -O d:/srcdirs/inbound/build/cl.py cl -FoISimpleDOMNode_p.obj -c  -DREGISTER_PROXY_DLL  -Id:/srcdirs/inbound/accessible/public/msaa -I. -I../../../dist/include -I../../../dist/include/nsprpub  -Id:/obj-inbound/dist/include/nspr -Id:/obj-inbound/dist/include/nss        -TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553  -DNDEBUG -DTRIMMED -Oy- -MD            -FI ../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT d:/obj-inbound/accessible/public/msaa/ISimpleDOMNode_p.c
d:\srcdirs\inbound\config\rules.mk:1116:0$ c:/mozilla-build/python/python2.7.exe -O d:/srcdirs/inbound/build/cl.py cl -FoISimpleDOMNode_i.obj -c  -DREGISTER_PROXY_DLL  -Id:/srcdirs/inbound/accessible/public/msaa -I. -I../../../dist/include -I../../../dist/include/nsprpub  -Id:/obj-inbound/dist/include/nspr -Id:/obj-inbound/dist/include/nss        -TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553  -DNDEBUG -DTRIMMED -Oy- -MD            -FI ../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT d:/obj-inbound/accessible/public/msaa/ISimpleDOMNode_i.c
d:\srcdirs\inbound\config\rules.mk:1026:0$ c:/mozilla-build/python/python2.7.exe d:/srcdirs/inbound/config/pythonpath.py -I../../../config d:/srcdirs/inbound/config/expandlibs_exec.py --uselist -- link -NOLOGO -DLL -OUT:AccessibleMarshal.dll -PDB:AccessibleMarshal.pdb -SUBSYSTEM:WINDOWS -MACHINE:X86  dlldata.obj ISimpleDOMNode_p.obj ISimpleDOMNode_i.obj ISimpleDOMDocument_p.obj ISimpleDOMDocument_i.obj ISimpleDOMText_p.obj ISimpleDOMText_i.obj   ./module.res -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE -SAFESEH  -DEF:d:/srcdirs/inbound/accessible/public/msaa/AccessibleMarshal.def     d:/obj-inbound/dist/lib/mozglue.lib kernel32.lib rpcns4.lib rpcrt4.lib oleaut32.lib    
d:\srcdirs\inbound\config\rules.mk:1044:0$ chmod +x AccessibleMarshal.dll
d:\srcdirs\inbound\config\makefiles\target_libs.mk:108:0$ d:/obj-inbound/config/nsinstall.exe -m 755 AccessibleMarshal.lib ../../../dist/lib
d:\srcdirs\inbound\config\makefiles\target_libs.mk:113:0$ d:/obj-inbound/config/nsinstall.exe -m 755 AccessibleMarshal.dll ../../../dist/bin
d:\srcdirs\inbound\config\rules.mk:1439:0$ d:/obj-inbound/config/nsinstall.exe -m 644 _xpidlgen/accessibility-msaa.xpt ../../../dist/bin/components
make.py[7]: Leaving directory 'd:\obj-inbound\accessible\public\msaa'
}
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-05-16 11:16:51 PDT
I can't reproduce this.
Comment 2 Ed Morley [:emorley] 2012-05-28 10:41:33 PDT
Seems to have been also fixed by bug 755828 (see log in bug 755684 comment 6) :-)

Note You need to log in before you can comment on or make changes to this bug.