Closed Bug 755781 Opened 8 years ago Closed 7 years ago

Debug tests should always download symbol zip

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: khuey, Assigned: catlee)

References

Details

(Keywords: regression, Whiteboard: [tests])

Attachments

(1 file)

Right now our assertion stacks are totally busted because we don't download symbols.
I thought we were downloading on demand now, per bug 561754?
Component: Release Engineering: Automation (Release Automation) → Release Engineering: Automation (General)
QA Contact: bhearsum → catlee
Yeah, but it ignored bug 561754 comment 30, which said that we would still need to download symbols for all debug tests, since printing assertion stacks requires symbols, and that doesn't know how to download on demand, and download on demand would be pointless since demand is "every single debug test run ever, for all time" because we'll never be assertion-free.
Blocks: 561754
Keywords: regression
So who is going to make this happen?
moi
Assignee: nobody → catlee
Priority: -- → P2
Whiteboard: [tests]
pong - this is getting bumped by higher priority work ATM. I may have some time next week to look at it.
Blocks: 773163
Talked to dbaron a bit, he says if we stopped running the stack fixing scripts on the machines we could process the logs offline to get usable stacks on Mac/Linux.
I would really really like to see this fixed. I just spent hours trying to reproduce assertions locally and failed; if I could get the stacks from tinderbox I wouldn't have had to do that. As it is, I don't know how I'm going to figure out this problem so I can get my code landed.
Comment on attachment 692461 [details] [diff] [review]
ignore download_symbols_ondemand for debug tests

I'm not sure if I have to make a similar change in mozharness/scripts/desktop_unittest.py.

Adding to my todo list
Attachment #692461 - Flags: review?(aki) → review+
Attachment #692461 - Flags: checked-in+
This is in production.
Please re-open if this isn't working properly
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
This does not seem to work properly yet for the Jetpack tree. We're hitting an assertion, but aren't seeing any debug symbols in the resulting stack trace (bug 629263)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: catlee → nobody
That bug is marked FIXED, so if there's additional work to do here please file a new bug.
Assignee: nobody → catlee
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.