Last Comment Bug 775467 - Make readyState progress through all states without duplicate transitions
: Make readyState progress through all states without duplicate transitions
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
:
Mentors:
Depends on: 779430 787726 1221856
Blocks: sync-about-blank
  Show dependency treegraph
 
Reported: 2012-07-19 03:43 PDT by Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
Modified: 2016-01-29 09:24 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make readyState less broken (11.94 KB, patch)
2012-07-23 06:15 PDT, Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01)
bzbarsky: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-07-19 03:43:40 PDT
Bug 744366 didn't fully fix readyState. Need to make it so that readyState always progresses through all states and never transitions to the state that's already the current state.
Comment 1 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-07-23 06:15:08 PDT
Created attachment 644910 [details] [diff] [review]
Make readyState less broken

Waiting for Windows try results still.
Comment 2 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-07-23 08:01:05 PDT
Comment on attachment 644910 [details] [diff] [review]
Make readyState less broken

This deals with neglected parts of MediaDocuments and XSLT readyState and fixes a couple of related bugs: aborting a doc that is being transformed by XSLT and making MediaDocuments come out of bfcache more properly.
Comment 3 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-07-24 00:56:21 PDT
I should mention that the reason why this doesn't come with a test case is that except for the fatal assertions themselves, all the changes in the patch are changes required to make sure the fatal assertions don't fire on our existing test suite.
Comment 4 Boris Zbarsky [:bz] 2012-07-26 13:04:07 PDT
Comment on attachment 644910 [details] [diff] [review]
Make readyState less broken

r=me
Comment 5 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-07-27 06:37:52 PDT
Thanks.

http://hg.mozilla.org/integration/mozilla-inbound/rev/fa6a84e7ba53
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-07-28 18:38:23 PDT
https://hg.mozilla.org/mozilla-central/rev/fa6a84e7ba53
Comment 7 Henri Sivonen (:hsivonen) (Not doing reviews or reading bugmail until 2016-08-01) 2012-07-31 05:47:40 PDT
Follow-up filed: bug 779100.

Note You need to log in before you can comment on or make changes to this bug.