Last Comment Bug 755869 - [Skia] Update Skia to a more recent revision
: [Skia] Update Skia to a more recent revision
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Linux
-- normal with 3 votes (vote)
: mozilla15
Assigned To: George Wright (:gw280) (needinfo me!)
:
: Milan Sreckovic [:milan]
Mentors:
: 759411 (view as bug list)
Depends on:
Blocks: skia-updates 751418 759671 759683
  Show dependency treegraph
 
Reported: 2012-05-16 12:34 PDT by George Wright (:gw280) (needinfo me!)
Modified: 2015-10-02 10:41 PDT (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Bug 755869 - [1/10] Update Skia to r3996 (2.00 MB, patch)
2012-05-18 13:05 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [2/10] Update Makefile.in for the new Skia (7.24 KB, patch)
2012-05-18 13:05 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [3/10] Re-apply bug 689069 - Patch to get arm opts to build with frame pointers enabled. (2.07 KB, patch)
2012-05-18 13:05 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [4/10] Re-apply bug 687189 - Implement SkPaint::getPosTextPath (2.70 KB, patch)
2012-05-18 13:05 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [5/10] Re-apply bug 688366 - Fix Skia marking radial gradients with the same radius as invalid. (1.23 KB, patch)
2012-05-18 13:05 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [6/10] Re-apply SkUserConfig (no original bug) (1.53 KB, patch)
2012-05-18 13:05 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [7/10] Re-apply bug 722011 - Fix trailing commas at end of enum lists (15.95 KB, patch)
2012-05-18 13:05 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [8/10] Re-apply bug 731384 - Fix compile errors on older versions of clang (1.08 KB, patch)
2012-05-18 13:06 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [9/10] Re-apply bug 751814 - Various Skia fixes for ARM without EDSP and ARMv6+ (8.29 KB, patch)
2012-05-18 13:06 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
Bug 755869 - [10/10] Re-apply bug 719872 - Fix crash on Android by reverting to older FontHost impl (21.85 KB, patch)
2012-05-18 13:06 PDT, George Wright (:gw280) (needinfo me!)
no flags Details | Diff | Splinter Review
fix b2g build (889 bytes, patch)
2012-05-24 17:58 PDT, George Wright (:gw280) (needinfo me!)
mwu.code: review+
Details | Diff | Splinter Review
Bug 755869 - [3] Re-apply bug 689069 - Patch to get arm opts to build with frame pointers enabled. (2.07 KB, patch)
2012-05-28 08:39 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [4] Re-apply bug 687189 - Implement SkPaint::getPosTextPath (2.69 KB, patch)
2012-05-28 08:39 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [5] Re-apply bug 688366 - Fix Skia marking radial gradients with the same radius as invalid. (1.22 KB, patch)
2012-05-28 08:39 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [6] Re-apply SkUserConfig (no original bug) (1.53 KB, patch)
2012-05-28 08:39 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [7] Re-apply bug 722011 - Fix trailing commas at end of enum lists (15.94 KB, patch)
2012-05-28 08:39 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [8] Re-apply bug 731384 - Fix compile errors on older versions of clang (1.07 KB, patch)
2012-05-28 08:40 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [9] Re-apply bug 751814 - Various Skia fixes for ARM without EDSP and ARMv6+ (8.29 KB, patch)
2012-05-28 08:40 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [10] Re-apply bug 719872 - Fix crash on Android by reverting to older FontHost impl (21.86 KB, patch)
2012-05-28 08:40 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [11] Re-apply bug 687188 - Skia radial gradients should use the 0/1 color stop values for clamping. (10.92 KB, patch)
2012-05-28 08:40 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [12] Re-apply bug 749533 - Add support for GNU/kFreeBSD and Hurd in Skia. (1.07 KB, patch)
2012-05-28 08:40 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
Bug 755869 - [13] Re-apply bug 750733 - Use handles in API object hooks where possible (1.05 KB, patch)
2012-05-28 08:41 PDT, George Wright (:gw280) (needinfo me!)
matt.woodrow: review+
Details | Diff | Splinter Review
fix clang mac build (1.27 KB, patch)
2012-05-29 09:11 PDT, OFFLINE UNTIL 27 FEB 2017 Nicholas Hurley [:nwgh][:hurley] (also hurley@todesschaf.org)
gw: review+
Details | Diff | Splinter Review
Bug 755869 - Update the patches directory (64.81 KB, patch)
2012-05-30 11:05 PDT, George Wright (:gw280) (needinfo me!)
joe: review+
Details | Diff | Splinter Review

Description User image George Wright (:gw280) (needinfo me!) 2012-05-16 12:34:12 PDT
We should try to keep up to date. At the moment we're running r2980, and upstream they're on r3817.
Comment 1 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:05:22 PDT
Created attachment 625214 [details] [diff] [review]
Bug 755869 - [1/10] Update Skia to r3996
Comment 2 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:05:28 PDT
Created attachment 625215 [details] [diff] [review]
Bug 755869 - [2/10] Update Makefile.in for the new Skia
Comment 3 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:05:34 PDT
Created attachment 625216 [details] [diff] [review]
Bug 755869 - [3/10] Re-apply bug 689069 - Patch to get arm opts to build with frame pointers enabled.
Comment 4 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:05:39 PDT
Created attachment 625217 [details] [diff] [review]
Bug 755869 - [4/10] Re-apply bug 687189 - Implement SkPaint::getPosTextPath
Comment 5 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:05:45 PDT
Created attachment 625218 [details] [diff] [review]
Bug 755869 - [5/10] Re-apply bug 688366 - Fix Skia marking radial gradients with the same radius as invalid.
Comment 6 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:05:51 PDT
Created attachment 625219 [details] [diff] [review]
Bug 755869 - [6/10] Re-apply SkUserConfig (no original bug)
Comment 7 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:05:56 PDT
Created attachment 625220 [details] [diff] [review]
Bug 755869 - [7/10] Re-apply bug 722011 - Fix trailing commas at end of enum lists
Comment 8 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:06:01 PDT
Created attachment 625221 [details] [diff] [review]
Bug 755869 - [8/10] Re-apply bug 731384 - Fix compile errors on older versions of clang
Comment 9 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:06:06 PDT
Created attachment 625222 [details] [diff] [review]
Bug 755869 - [9/10] Re-apply bug 751814 - Various Skia fixes for ARM without EDSP and ARMv6+
Comment 10 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:06:11 PDT
Created attachment 625223 [details] [diff] [review]
Bug 755869 - [10/10] Re-apply bug 719872 - Fix crash on Android by reverting to older FontHost impl
Comment 11 User image George Wright (:gw280) (needinfo me!) 2012-05-18 13:17:52 PDT
https://tbpl.mozilla.org/?tree=Try&rev=d7240a3dffeb
Comment 12 User image George Wright (:gw280) (needinfo me!) 2012-05-24 17:58:44 PDT
Created attachment 627054 [details] [diff] [review]
fix b2g build

From IRC:

01:49:12 < gw280> cjones: does this look right to you: https://hg.mozilla.org/try/rev/948df947f0aa
01:52:09 < cjones> gw280, maybe, what's it supposed to do?
01:53:47 < gw280> cjones: with the skia rebase they updated SkThread_platform.h to inline different atomic functions depending on whether you're configured to build for Android or Android NDK
01:54:34 < gw280> cjones: some files in libui in gonk are including skia headers and somehow they're getting mismatched between NDK and non-NDK, which causes a link failure with b2g on the skia rebase because symbols are multiply defined as different things 
01:54:54 < gw280> cjones: so this just does what we do in gfx/skia anyway which is say we're always building for the NDK
01:55:30 < cjones> gw280, that seems ok
01:56:03 < cjones> might want to check with mwu
Comment 13 User image George Wright (:gw280) (needinfo me!) 2012-05-24 18:00:58 PDT
Try builds are:

b2g fix:

https://tbpl.mozilla.org/?tree=Try&rev=948df947f0aa

rebase to r4037 w/azure canvas force enabled:

https://tbpl.mozilla.org/?tree=Try&rev=06aa51a1b0b5

Only the Linux/Android reftests should be considered on these builds as they're the only ones where azure => skia by default.
Comment 14 User image Michael Wu [:mwu] 2012-05-24 19:08:20 PDT
Currently we rely on http://hg.mozilla.org/mozilla-central/file/bd4201e13a9f/gfx/skia/include/core/SkPreConfig.h#l39 to set SK_BUILD_FOR_ANDROID_NDK for us on B2G. Why doesn't this work anymore?
Comment 15 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:39:01 PDT
Created attachment 627707 [details] [diff] [review]
Bug 755869 - [3] Re-apply bug 689069 - Patch to get arm opts to build with frame pointers enabled.
Comment 16 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:39:15 PDT
Created attachment 627708 [details] [diff] [review]
Bug 755869 - [4] Re-apply bug 687189 - Implement SkPaint::getPosTextPath
Comment 17 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:39:28 PDT
Created attachment 627709 [details] [diff] [review]
Bug 755869 - [5] Re-apply bug 688366 - Fix Skia marking radial gradients with the same radius as invalid.
Comment 18 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:39:38 PDT
Created attachment 627710 [details] [diff] [review]
Bug 755869 - [6] Re-apply SkUserConfig (no original bug)
Comment 19 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:39:51 PDT
Created attachment 627711 [details] [diff] [review]
Bug 755869 - [7] Re-apply bug 722011 - Fix trailing commas at end of enum lists
Comment 20 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:40:15 PDT
Created attachment 627712 [details] [diff] [review]
Bug 755869 - [8] Re-apply bug 731384 - Fix compile errors on older versions of clang
Comment 21 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:40:26 PDT
Created attachment 627713 [details] [diff] [review]
Bug 755869 - [9] Re-apply bug 751814 - Various Skia fixes for ARM without EDSP and ARMv6+
Comment 22 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:40:37 PDT
Created attachment 627714 [details] [diff] [review]
Bug 755869 - [10] Re-apply bug 719872 - Fix crash on Android by reverting to older FontHost impl
Comment 23 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:40:48 PDT
Created attachment 627715 [details] [diff] [review]
Bug 755869 - [11] Re-apply bug 687188 - Skia radial gradients should use the 0/1 color stop values for clamping.
Comment 24 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:40:59 PDT
Created attachment 627716 [details] [diff] [review]
Bug 755869 - [12] Re-apply bug 749533 - Add support for GNU/kFreeBSD and Hurd in Skia.
Comment 25 User image George Wright (:gw280) (needinfo me!) 2012-05-28 08:41:10 PDT
Created attachment 627718 [details] [diff] [review]
Bug 755869 - [13] Re-apply bug 750733 - Use handles in API object hooks where possible
Comment 26 User image George Wright (:gw280) (needinfo me!) 2012-05-28 20:08:36 PDT
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=545eb36e7207
Comment 27 User image Boris Zbarsky [:bz] (still a bit busy) 2012-05-29 07:45:58 PDT
This broke clang builds with this build error (presumably due to -Werror silliness):

../../../mozilla/gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:810:28: error: non-constant-expression cannot be narrowed from type 'CGFloat' (aka 'double') to 'SkScalar' (aka 'float') in initializer list [-Wc++11-narrowing]
    const SkPoint trans = {(vertOffset.width),
                           ^~~~~~~~~~~~~~~~~~
../../../mozilla/gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:810:28: note: override this message by inserting an explicit cast
    const SkPoint trans = {(vertOffset.width),
                           ^~~~~~~~~~~~~~~~~~
                           static_cast<SkScal)r>(

and similar on line 811.
Comment 28 User image Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-05-29 07:57:39 PDT
(In reply to Boris Zbarsky (:bz) from comment #27)
> This broke clang builds with this build error (presumably due to -Werror
> silliness):
> 
> ../../../mozilla/gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:810:28:
> error: non-constant-expression cannot be narrowed from type 'CGFloat' (aka
> 'double') to 'SkScalar' (aka 'float') in initializer list [-Wc++11-narrowing]
>     const SkPoint trans = {(vertOffset.width),
>                            ^~~~~~~~~~~~~~~~~~
> ../../../mozilla/gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:810:28:
> note: override this message by inserting an explicit cast
>     const SkPoint trans = {(vertOffset.width),
>                            ^~~~~~~~~~~~~~~~~~
>                            static_cast<SkScal)r>(
> 
> and similar on line 811.

This would be an hard error on c++11, so it is probably better to fix it instead of just disabling the warning.
Comment 29 User image OFFLINE UNTIL 27 FEB 2017 Nicholas Hurley [:nwgh][:hurley] (also hurley@todesschaf.org) 2012-05-29 09:05:50 PDT
It looks like applying the patch from bug 719575 on top of the new skia fixes the clang build errors.
Comment 30 User image OFFLINE UNTIL 27 FEB 2017 Nicholas Hurley [:nwgh][:hurley] (also hurley@todesschaf.org) 2012-05-29 09:11:47 PDT
Created attachment 627984 [details] [diff] [review]
fix clang mac build

Here's the patch from bug 719575 on top of the new skia.
Comment 31 User image Boris Zbarsky [:bz] (still a bit busy) 2012-05-29 09:33:02 PDT
Can we possibly get that into our set of local changes to skia, if we have one, so we don't keep clobbering it?
Comment 32 User image George Wright (:gw280) (needinfo me!) 2012-05-29 09:33:59 PDT
Yes, I'll update our local patches to skia.
Comment 34 User image Gregory Szorc [:gps] (away until 2017-03-20) 2012-05-29 11:02:51 PDT
This has broken my trunk Clang builds. I'll let others decide how to triage.

SkFontHost_mac_coretext.cpp
../../../gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:810:28: error: non-constant-expression cannot be narrowed from type 'CGFloat' (aka 'double') to 'SkScalar' (aka 'float') in initializer list [-Wc++11-narrowing]
    const SkPoint trans = {SkFloatToScalar(vertOffset.width),
                           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../../gfx/skia/include/core/SkScalar.h:111:37: note: expanded from macro 'SkFloatToScalar'
    #define SkFloatToScalar(n)      (n)
                                    ^~~
../../../gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:810:28: note: override this message by inserting an explicit cast
    const SkPoint trans = {SkFloatToScalar(vertOffset.width),
                           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                           static_cast<SkScalar>(           )
../../../gfx/skia/include/core/SkScalar.h:111:37: note: expanded from macro 'SkFloatToScalar'
    #define SkFloatToScalar(n)      (n)
                                    ^~~
../../../gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:811:28: error: non-constant-expression cannot be narrowed from type 'CGFloat' (aka 'double') to 'SkScalar' (aka 'float') in initializer list [-Wc++11-narrowing]
                           SkFloatToScalar(vertOffset.height)};
                           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../../gfx/skia/include/core/SkScalar.h:111:37: note: expanded from macro 'SkFloatToScalar'
    #define SkFloatToScalar(n)      (n)
                                    ^~~
../../../gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:811:28: note: override this message by inserting an explicit cast
                           SkFloatToScalar(vertOffset.height)};
                           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                           static_cast<SkScalar>(            )
../../../gfx/skia/include/core/SkScalar.h:111:37: note: expanded from macro 'SkFloatToScalar'
    #define SkFloatToScalar(n)      (n)
                                    ^~~
../../../gfx/skia/src/ports/SkFontHost_mac_coretext.cpp:1223:16: warning: unused variable 'isA8' [-Wunused-variable]
    const bool isA8 = !isLCD && !isBW;
               ^
1 warning and 2 errors generated.

In the directory  /Users/gps/src/services-central/obj-ff-dbg/gfx/skia
The following command failed to execute properly:
/usr/local/bin/ccache /usr/local/llvm/bin/clang++ -o SkFontHost_mac_coretext.o -c -fvisibility=hidden -DSK_A32_SHIFT=24 -DSK_R32_SHIFT=16 -DSK_G32_SHIFT=8 -DSK_B32_SHIFT=0 -DUSE_SKIA -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES -DSTATIC_EXPORTABLE_JS_API -I/Users/gps/src/services-central/gfx/skia/include/core -I/Users/gps/src/services-central/gfx/skia/include/config -I/Users/gps/src/services-central/gfx/skia/include/ports -I/Users/gps/src/services-central/gfx/skia/src/core -I/Users/gps/src/services-central/gfx/skia/include/images -I/Users/gps/src/services-central/gfx/skia/include/utils -I/Users/gps/src/services-central/gfx/skia/include/utils/mac -I/Users/gps/src/services-central/gfx/skia/include/utils/win -I/Users/gps/src/services-central/gfx/skia/include/views -I/Users/gps/src/services-central/gfx/skia/include/effects -I/Users/gps/src/services-central/gfx/skia -I. -I../../dist/include -I../../dist/include/nsprpub -I/Users/gps/src/services-central/obj-ff-dbg/dist/include/nspr -I/Users/gps/src/services-central/obj-ff-dbg/dist/include/nss -fPIC -Qunused-arguments -fno-rtti -Qunused-arguments -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -fcolor-diagnostics -isysroot /Applications/Xcode.app//Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk -fno-exceptions -fno-strict-aliasing -std=gnu++0x -ffunction-sections -fdata-sections -pthread -DNO_X11 -pipe -DDEBUG -D_DEBUG -DTRACING -g -O3 -fno-omit-frame-pointer -Qunused-arguments -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/SkFontHost_mac_coretext.pp /Users/gps/src/services-central/gfx/skia/src/ports/SkFontHost_mac_coretext.cpp
make[6]: *** [SkFontHost_mac_coretext.o] Error 1
make[5]: *** [libs] Error 2
make[4]: *** [libs_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2
Comment 35 User image Hubert Figuiere [:hub] 2012-05-29 11:29:08 PDT
same here.
Comment 36 User image Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-29 11:56:02 PDT
Looks like this isn't the first time. We can probably do exactly what happened last time with bug 719575 (s/SkFloatToScalar/SkScalar/)
Comment 37 User image Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-29 12:00:41 PDT
bah, that was already said... apologies for the bugspam
Comment 38 User image George Wright (:gw280) (needinfo me!) 2012-05-29 12:27:00 PDT
Comment on attachment 627984 [details] [diff] [review]
fix clang mac build

This looks good to me, so I'll land it to fix the build.
Comment 39 User image George Wright (:gw280) (needinfo me!) 2012-05-29 12:41:14 PDT
https://hg.mozilla.org/mozilla-central/rev/e8a025a7101b
Comment 40 User image Ralph Giles (:rillian) | needinfo me 2012-05-29 14:16:29 PDT
*** Bug 759411 has been marked as a duplicate of this bug. ***
Comment 41 User image Landry Breuil (:gaston) 2012-05-29 23:32:17 PDT
That skia update broke my builds on OpenBSD/gcc 4.2:

skia/src/core/SkMatrix.cpp:1723: error: extra ';'

The changeset only adds the ; in that file... sigh. If i guess it right, it should be yet another local patch to 'fix' it ?

Dunno what upstream had in their minds when adding it in one of theses changes: https://code.google.com/p/skia/source/list?path=/trunk/src/core/SkMatrix.cpp&start=2246
Comment 42 User image George Wright (:gw280) (needinfo me!) 2012-05-30 11:05:01 PDT
Created attachment 628391 [details] [diff] [review]
Bug 755869 - Update the patches directory

Review: :joedrew!
Comment 43 User image George Wright (:gw280) (needinfo me!) 2012-05-30 11:43:57 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/71ebeef47ada
Comment 44 User image Ed Morley [:emorley] 2012-05-31 06:32:31 PDT
> Bug 755869 - Update the patches directory

https://hg.mozilla.org/mozilla-central/rev/71ebeef47ada
Comment 45 User image Matt Brubeck (:mbrubeck) 2012-06-15 07:53:16 PDT
This change added 3 static initializers:
http://graphs.mozilla.org/graph.html#tests=[[81,63,6]]&sel=1338167620593.957,1338331013144.1003&displayrange=30&datatype=running

Should we file a bug against upstream Skia?
Comment 46 User image Mike Hommey [:glandium] 2012-06-15 08:02:01 PDT
(In reply to Matt Brubeck (:mbrubeck) from comment #45)
> This change added 3 static initializers:
> http://graphs.mozilla.org/graph.html#tests=[[81,63,6]]&sel=1338167620593.957,
> 1338331013144.1003&displayrange=30&datatype=running
> 
> Should we file a bug against upstream Skia?

Depends if these patches have been upstreamed.
Comment 47 User image Matt Brubeck (:mbrubeck) 2012-06-15 11:28:20 PDT
(In reply to Mike Hommey [:glandium] from comment #46)
> Depends if these patches have been upstreamed.

Most of the changes from this bug came *from* upstream:
https://hg.mozilla.org/mozilla-central/rev/5fb409f61b93

The other patches were mostly re-applying changes that had already been applied to the previous version of skia in mozilla-central.

Note You need to log in before you can comment on or make changes to this bug.