Closed Bug 756080 Opened 7 years ago Closed 4 years ago

The Bookmarks toolbar is set as visible automatically when resetting Firefox with at least 5 bookmarks toolbar items

Categories

(Firefox :: Migration, defect)

13 Branch
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ioana_damy, Unassigned)

References

Details

(Keywords: regression)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120516113045

STR:
1. Launch Firefox with a clean profile.
2. Bookmark 5 web pages and add them to the Bookmarks toolbar. Do not set the Bookmarks bar as visible.
3. Open the Troubleshooting Information page in the browser (about:support).
4. Click on the Reset Firefox button.
5. Click on the Reset button.

Firefox is restarted on the new profile. The Bookmarks toolbar is set as visible automatically.


The Bookmarks toolbar is set as visible automatically when resetting Firefox with at least 5 bookmarks toolbar items. Those items can be 5 new bookmarks/RSS subscriptions OR 3 new new bookmarks/RSS subscriptions and the 2 default bookmarks (Most Visited & Getting Started).
Can you please test other Firefox versions to see if:

A) This is affecting Aurora and Nightly?
B) This is a regression?
Anthony, this issue can't be verified on Aurora or Nightly because of bug 748047.
Component: Bookmarks & History → Migration
Depends on: 748047
QA Contact: bookmarks → migration
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #1)
...
> B) This is a regression?

It seems this issue is reproducing since bug 717070 was fixed (started reproducing from the 10th of March Nightly). It might have been introduced with the fix for bug 273874, but I can't verify this since the Firefox migrator seems to only be used by the Reset Firefox feature (available since the fix of bug 717070).
No longer depends on: 748047
Depends on: 748047
Can you please provide the first bad and last good changeset IDs so we can investigate further?
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #4)
> Can you please provide the first bad and last good changeset IDs so we can
> investigate further?

Last good nightly: 2012-03-09
First bad nightly: 2012-03-10

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-03-09&enddate=2012-03-10

As I specified in my previous comment, this issue might have been introduced with the implementation on the Firefox migrator: changeset https://hg.mozilla.org/mozilla-central/rev/c550ffd3ba74 from the 29th November 2011. Unfortunately, the Firefox migrator can only be accessed through the Reset Firefox button, which is only available from the first bad nightly above.
This is expected behaviour. In a new profile we automatically show the bookmark toolbar if there are >N bookmarks. Firefox refresh isn't supposed to be a lossless operation otherwise it wouldn't do anything.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.