Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 748047 - Reset-profile feature is broken
: Reset-profile feature is broken
: regression
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: Trunk
: All All
: -- major (vote)
: Firefox 15
Assigned To: Mano (::mano, needinfo? for any questions; not reading general bugmail)
: Matthew N. [:MattN]
: 757231 (view as bug list)
Depends on: 718608 737381 748569
Blocks: 756080
  Show dependency treegraph
Reported: 2012-04-23 12:14 PDT by Matthew N. [:MattN]
Modified: 2012-06-13 05:00 PDT (History)
16 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Matthew N. [:MattN] 2012-04-23 12:14:03 PDT
1) Create a new profile
2) Launch that profile when it is the default (ie. use profile manager)
3) Click the button to reset your profile from about:support

Expected result:
Migration UI is shown on startup and data from the profile in #1 is copied to the new profile.

Actual result:
"Invalid migrator key specified or source does not exist." in error console

Also, when working around that problem, you will hit "startMigration was asked to open auto-migrate from a non-existent source Firefox" since gProfileStartup is not set early enough to use in sourceExists.

Call stack (hand-made):
* migrate
** getMigrator
*** sourceExists
**** MigrationUtils.isStartupMigration

but gProfileStartup is only set in MU_showMigrationWizard which is called after getMigrator is called on startup.

Requesting tracking since this breaks the profile reset feature.
Comment 1 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-04-23 12:19:42 PDT
Comment 2 Matthew N. [:MattN] 2012-05-14 17:16:32 PDT
Mano, we really need this fixed on Aurora and Nightly because the feature is getting publicity and SUMO articles are written for it:
Comment 3 Justin Dolske [:Dolske] 2012-05-15 19:47:13 PDT

Yeah, we need to get this fixes asap, since we're already _well_ into this release cycle.
Comment 4 :Gavin Sharp [email:] 2012-05-16 13:01:25 PDT
The patch in bug 748569 fixes this.
Comment 5 Marco Bonardo [::mak] 2012-05-17 02:52:00 PDT
I'll try to do that review today
Comment 6 Matthew N. [:MattN] 2012-05-21 17:36:04 PDT
*** Bug 757231 has been marked as a duplicate of this bug. ***
Comment 7 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-05-29 12:12:25 PDT
Fixed by bug 748569.
Comment 8 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-01 16:24:30 PDT
[Triage Comment]
Updating status flag to 'fixed' as per comment 7
Comment 9 juan becerra [:juanb] 2012-06-12 13:20:50 PDT
qa+'ing for verification and removing qawanted
Comment 10 Ioana (away) 2012-06-13 05:00:21 PDT
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
BuildID: 20120612164001

Also verified on the 2012-06-11 Aurora and Nightly builds on Windows 7, Mac 10.7 and Ubuntu 11.10 32-bit.

Note You need to log in before you can comment on or make changes to this bug.