Last Comment Bug 756372 - Change |seeking| to prevent seeking in WebM livestream.
: Change |seeking| to prevent seeking in WebM livestream.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Paul Adenot (:padenot)
:
Mentors:
Depends on: 774084 795784 817124
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 23:01 PDT by Paul Adenot (:padenot)
Modified: 2012-12-02 22:19 PST (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0 : change seekable behavior for WebM. (9.04 KB, patch)
2012-05-17 23:06 PDT, Paul Adenot (:padenot)
kinetik: review+
Details | Diff | Splinter Review
Addressed nit. (8.25 KB, patch)
2012-05-18 10:08 PDT, Paul Adenot (:padenot)
no flags Details | Diff | Splinter Review

Description Paul Adenot (:padenot) 2012-05-17 23:01:21 PDT
Bug 657791 prevent us from seeking in webm files that have no Cues.

Despite that limitation, |seekable| returns |buffered| while playing a livestream, allowing the user to seek in the stream via the front-end, and displaying an infinite spinning throbber.

We should return an empty TimeRanges object for |Seekable| when playing a live stream, or playing a bounded media that is not served with range requests.
Comment 1 Paul Adenot (:padenot) 2012-05-17 23:06:39 PDT
Created attachment 625011 [details] [diff] [review]
Patch v0 : change seekable behavior for WebM.

This patch adds an virtual method in the ns*Readers to report if that backend is capable of seeking using only buffered ranges.

This method is then called in |nsBuiltinDecoder::GetSeekable| to get the behavior wanted.
Comment 2 Matthew Gregan [:kinetik] 2012-05-18 01:18:06 PDT
Comment on attachment 625011 [details] [diff] [review]
Patch v0 : change seekable behavior for WebM.

-nsresult nsRawReader::Seek(PRInt64 aTime, PRInt64 aStartTime, PRInt64 aEndTime, PRInt64 aCurrentTime)
+nsresult nsRawReader::Seek(PRInt65 aTime, PRInt64 aStartTime, PRInt64 aEndTime, PRInt64 aCurrentTime)

This looks like an accidental change.  r+ with that removed.
Comment 3 Paul Adenot (:padenot) 2012-05-18 10:08:00 PDT
Created attachment 625151 [details] [diff] [review]
Addressed nit.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-05-18 10:44:45 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1e18c991b40c

Is this something that should have a test?
Comment 5 Paul Adenot (:padenot) 2012-05-18 11:38:22 PDT
This is likely to be a more or less temporary patch waiting for Bug 657791. Does not worth a test, I believe.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-05-18 18:24:06 PDT
https://hg.mozilla.org/mozilla-central/rev/1e18c991b40c

Note You need to log in before you can comment on or make changes to this bug.