Last Comment Bug 756594 - add per-locale l10n status to tbpl (Firefox-l10n, Aurora-l10n ?)
: add per-locale l10n status to tbpl (Firefox-l10n, Aurora-l10n ?)
Status: RESOLVED INCOMPLETE
:
Product: Tree Management Graveyard
Classification: Graveyard
Component: TBPL (show other bugs)
: Trunk
: All All
: -- major
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 747457 895442
Blocks: 698910 700290 740142 762714 789366
  Show dependency treegraph
 
Reported: 2012-05-18 13:33 PDT by Aki Sasaki [:aki]
Modified: 2015-04-13 15:57 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Aki Sasaki [:aki] 2012-05-18 13:33:10 PDT
Hi,

I'm currently picturing this as separate pages (e.g. Firefox-l10n, Aurora-l10n).  We're repacking multiple locales per "build", but we're reporting status per locale so we can show them as individual statuses in TBPL.

So a potential page might look like:

user@domain date
    revision user comment     PLATFORM  ar be cs de es-ES fr gr ...

where each locale is green or red according to its status.


Details
=======

These builds are named BRANCH-PLATFORM-l10n_#

Right now, for nightlies, the branches are mozilla-central and mozilla-aurora; the only platform is android.  (Android releases also have this format; not sure if we're displaying those on tbpl?)

I'll be porting desktop l10n repacks to this same format in bug 740142.

The list of locales in each build are listed in the locales property:

"locales": "{\"ja-JP-mac\": \"Success\", \"ko\": \"Success\", \"it\": \"Success\", \"hu\": \"Success\", \"lt\": \"Success\", \"id\": \"Success\", \"nb-NO\": \"Success\", \"ja\": \"Success\", \"he\": \"Failed\"}",

When a locale fails, I create a LOCALE_failure property with a short error message:

"he_failure": "he failed in make installers-he!  Can't create a snippet for he without an upload url.",

The log url is the same for each locale; we should link to it from each locale.

"log_url": "http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-central-l10n/mozilla-central-android-l10n_3-unknown-bm12-build1-build3.txt.gz",

In http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-central-l10n/mozilla-central-android-l10n_3-unknown-bm12-build1-build3.txt.gz , the compare-locales output for each locale is sandwiched by the comments

04:03:04     INFO - *** BEGIN compare-locales he
04:03:05     INFO - *** END compare-locales he

(the timestamp will change, but the *** BEGIN compare-locales LOCALE and *** END compare-locales LOCALE should remain constant)


I'm in control of the above output and property names etc; if changing those makes this request easier, I'm open.

I'm also happy to clarify if this bug request isn't clear.
Comment 1 Aki Sasaki [:aki] 2012-06-07 16:40:58 PDT
Increasing severity since we missed breakage in mozilla-central for a week and a half because of this.
Comment 2 Ed Morley [:emorley] 2013-02-20 16:24:57 PST
(In reply to Aki Sasaki [:aki] from comment #1)
> Increasing severity since we missed breakage in mozilla-central for a week
> and a half because of this.

We very likely won't be fixing this before the TBPL rewrite (https://wiki.mozilla.org/Auto-tools/Projects/TBPL2).
Comment 3 Aki Sasaki [:aki] 2013-02-20 16:34:27 PST
(In reply to Ed Morley [:edmorley UTC+0] from comment #2)
> (In reply to Aki Sasaki [:aki] from comment #1)
> > Increasing severity since we missed breakage in mozilla-central for a week
> > and a half because of this.
> 
> We very likely won't be fixing this before the TBPL rewrite
> (https://wiki.mozilla.org/Auto-tools/Projects/TBPL2).

Can I add multiple repo support as a want/need there?
Or is that a given with the db-driven structure?
Comment 4 Ed Morley [:emorley] 2013-02-20 16:45:20 PST
Multi-repo support is one of our core requirements for the rewrite, since it's needed for both L10N as well as things like B2G, thunderbird etc :-D
Comment 5 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2013-03-05 08:32:06 PST
per meeting w/axel, I think this is now a DUP of bug#698910. 

If there's a reason to keep this separate, please do reopen, with additional info.

*** This bug has been marked as a duplicate of bug 698910 ***
Comment 6 Aki Sasaki [:aki] 2013-07-19 15:15:04 PDT
Not a dup, as the report doesn't cover mobile.
Comment 7 Ed Morley [:emorley] 2015-04-08 04:49:07 PDT
TBPL has been EOLed (bug 1054977).

Note You need to log in before you can comment on or make changes to this bug.