xulrunner won't start on linux (and probably mac)

RESOLVED FIXED in mozilla17

Status

Toolkit Graveyard
XULRunner
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla17
All
Linux
Dependency tree / graph

Details

Attachments

(3 attachments)

(Assignee)

Description

5 years ago
(I think this also affects mac)

Bug 743560 moved run-mozilla.sh to the SDK. But xulrunner is still the script that calls run-mozilla.sh to call xulrunner-bin. This makes running xulrunner application.ini fail. (although, using the stub works).

We should either ship run-mozilla.sh again with xulrunner (easy) or switch xulrunner to the standalone glue (less easy, but all other apps have been switched already, so it's mostly copy/paste)
(Assignee)

Updated

5 years ago
Summary: xulrunner won't start → xulrunner won't start on linux (and probably mac)
(Assignee)

Updated

5 years ago
status-firefox13: --- → unaffected
status-firefox14: --- → affected
(Assignee)

Comment 1

5 years ago
Created attachment 629708 [details] [diff] [review]
Remove NSPR usage from nsXULRunnerApp.cpp
Attachment #629708 - Flags: review?(benjamin)
(Assignee)

Updated

5 years ago
Assignee: nobody → mh+mozilla
(Assignee)

Comment 2

5 years ago
Created attachment 629710 [details] [diff] [review]
Use XPCOM standalone glue in nsXULRunnerApp.cpp
Attachment #629710 - Flags: review?(benjamin)

Updated

5 years ago
Attachment #629708 - Flags: review?(benjamin) → review+

Comment 3

5 years ago
Comment on attachment 629710 [details] [diff] [review]
Use XPCOM standalone glue in nsXULRunnerApp.cpp

I don't think we need/want AutoXPCOMGlue, because XPCOMGlueShutdown is pretty much a joke that should be removed. r=me with that removed
Attachment #629710 - Flags: review?(benjamin) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4b6d2c6c1bae
Target Milestone: --- → mozilla16
(Assignee)

Comment 5

5 years ago
err, there were 2 parts. Here is the second:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d8764ae15bf1
status-firefox15: --- → affected

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/4b6d2c6c1bae
https://hg.mozilla.org/mozilla-central/rev/d8764ae15bf1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

5 years ago
Comment on attachment 629708 [details] [diff] [review]
Remove NSPR usage from nsXULRunnerApp.cpp

[Approval Request Comment]
Bug caused by bug 743560
User impact if declined: xulrunner doesn't work on linux (and maybe mac)
Risk to taking this patch (and alternatives if risky): No code change that affects Firefox. Only affects xulrunner.
Attachment #629708 - Flags: approval-mozilla-beta?
Attachment #629708 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

5 years ago
Comment on attachment 629710 [details] [diff] [review]
Use XPCOM standalone glue in nsXULRunnerApp.cpp

[Approval Request Comment]
See comment 7.
Attachment #629710 - Flags: approval-mozilla-beta?
Attachment #629710 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #629708 - Flags: approval-mozilla-beta?
Attachment #629708 - Flags: approval-mozilla-beta+
Attachment #629708 - Flags: approval-mozilla-aurora?
Attachment #629708 - Flags: approval-mozilla-aurora+

Updated

5 years ago
Attachment #629710 - Flags: approval-mozilla-beta?
Attachment #629710 - Flags: approval-mozilla-beta+
Attachment #629710 - Flags: approval-mozilla-aurora?
Attachment #629710 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/2da5a0ff4bd5
http://hg.mozilla.org/releases/mozilla-aurora/rev/62b82be13ebd
http://hg.mozilla.org/releases/mozilla-beta/rev/db2d1dd99271
http://hg.mozilla.org/releases/mozilla-beta/rev/f11c642254b2
status-firefox14: affected → fixed
status-firefox15: affected → fixed

Updated

5 years ago
Depends on: 764237
(Assignee)

Comment 10

5 years ago
Gah, it appears the patch was not enough: the script hasn't been modified and still tries to run run-mozilla.sh. The xulrunner script needs to go, and xulrunner-bin needs to be renamed as xulrunner.
Status: RESOLVED → REOPENED
status-firefox14: fixed → affected
status-firefox15: fixed → affected
status-firefox16: --- → affected
Resolution: FIXED → ---
(Assignee)

Comment 11

5 years ago
Created attachment 644666 [details] [diff] [review]
Install the xulrunner binary as xulrunner instead of xulrunner-bin, and get rid of the xulrunner wrapper script
Attachment #644666 - Flags: review?(benjamin)

Updated

5 years ago
Attachment #644666 - Flags: review?(benjamin) → review+
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/43a69b4981f5
Push backed out for Windows mochitest crashes:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=eecd3aa199e6

https://hg.mozilla.org/integration/mozilla-inbound/rev/1abfd50c8be6
(Assignee)

Comment 14

5 years ago
Relanded, as it was innocent
https://hg.mozilla.org/integration/mozilla-inbound/rev/c8f38098799a
https://hg.mozilla.org/mozilla-central/rev/c8f38098799a
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox16: affected → ---

Comment 16

5 years ago
Any reason why "status-firefox16: affected" has been removed? For me, xulrunner 16 is clearly affected in the same way as xulrunner 14 and 15 are:

$ xulrunner-16.0
Cannot find XULRunner runtime directory. Exiting.
(Assignee)

Updated

5 years ago
status-firefox16: --- → affected
(Assignee)

Comment 17

5 years ago
Comment on attachment 644666 [details] [diff] [review]
Install the xulrunner binary as xulrunner instead of xulrunner-bin, and get rid of the xulrunner wrapper script

[Approval Request Comment]
Bug caused by bug 743560 ; previous fix was incomplete
User impact if declined: xulrunner doesn't work on linux (and maybe mac)
Risk to taking this patch (and alternatives if risky): No code change that affects Firefox. Only affects xulrunner.
Attachment #644666 - Flags: approval-mozilla-beta?
Attachment #644666 - Flags: approval-mozilla-aurora?

Comment 18

5 years ago
(In reply to Axel Beckert from comment #16)
> Any reason why "status-firefox16: affected" has been removed? For me,
> xulrunner 16 is clearly affected in the same way as xulrunner 14 and 15 are:
Because the first patches landed on 16.0, but not the latest one.
Target Milestone: mozilla16 → mozilla17

Updated

5 years ago
Attachment #644666 - Flags: approval-mozilla-beta?
Attachment #644666 - Flags: approval-mozilla-beta+
Attachment #644666 - Flags: approval-mozilla-aurora?
Attachment #644666 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 19

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/fa4cb266be04
http://hg.mozilla.org/releases/mozilla-beta/rev/de001727ae4e
status-firefox15: affected → fixed
status-firefox16: affected → fixed
(Assignee)

Comment 20

5 years ago
Comment on attachment 644666 [details] [diff] [review]
Install the xulrunner binary as xulrunner instead of xulrunner-bin, and get rid of the xulrunner wrapper script

The released xulrunner is broken on (at least) linux. The patch only changes xulrunner code, is it possible (and desirable) to do a xulrunner-only point release?
Attachment #644666 - Flags: approval-mozilla-release?
Comment on attachment 644666 [details] [diff] [review]
Install the xulrunner binary as xulrunner instead of xulrunner-bin, and get rid of the xulrunner wrapper script

Checked with RelEng and it's not possible to rebuild xulrunner without building Firefox as well so this would be too much of a PITA to do when we'll have a new beta out this week with this patch in it and a new release of xulrunner in ~2 weeks.
Attachment #644666 - Flags: approval-mozilla-release? → approval-mozilla-release-
Depends on: 931841
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.