Last Comment Bug 756821 - Port |Bug 305089: Don't mark as scam any mail composed by user (Drafts, Templates, Sent, Outbox folders)| and non-IPv6 parts of |Bug 362434: Add IPv6 support to phishingDetector.js|
: Port |Bug 305089: Don't mark as scam any mail composed by user (Drafts, Templ...
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.10
Assigned To: Ian Neal
:
Mentors:
Depends on:
Blocks: 80855
  Show dependency treegraph
 
Reported: 2012-05-19 15:10 PDT by Ian Neal
Modified: 2012-05-21 13:23 PDT (History)
1 user (show)
iann_bugzilla: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
wontfix
fixed
fixed
fixed


Attachments
Ported parts (5.85 KB, patch)
2012-05-19 15:10 PDT, Ian Neal
neil: review+
Details | Diff | Splinter Review
Updated for review comments [Checked in: Comment 3, 4 & 5] (6.55 KB, patch)
2012-05-20 16:40 PDT, Ian Neal
iann_bugzilla: review+
bugspam.Callek: approval‑comm‑aurora+
bugspam.Callek: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Ian Neal 2012-05-19 15:10:01 PDT
Created attachment 625442 [details] [diff] [review]
Ported parts

Port the following from TB to SM:
Bug 305089: Don't mark as scam any mail composed by user (Drafts, Templates, Sent, Outbox folders)
and the relevant parts of:
Bug 436044 - Convert some more nsMsgFolderFlags users over to the id
Bug 506577: convert users of IsSpecialFolder(folder, ...) over to use folder.isSpecialFolder(...)
The non-IPv6 parts of:
Bug 362434: Add IPv6 support to phishingDetector.js

The IPv6 parts are covered in bug 80855
Comment 1 neil@parkwaycc.co.uk 2012-05-20 10:50:53 PDT
Comment on attachment 625442 [details] [diff] [review]
Ported parts

I assume we're going to get the improved IP address detector at some point?

>+    var unobscuredHostName = hostNameIsIPAddress(hrefURL.host);
Might want to rename unobscuredHostName to ipAddress

>-      isPhishingURL = confirmSuspiciousURL(phishingType, unobscuredHostName.value);
>+      isPhishingURL = confirmSuspiciousURL(phishingType, unobscuredHostName);
You're passing in the IP address even when it's not that phishing type, and therefore it is empty. I'm not sure passing the detected IP address is useful even when it exists, you should probably always pass the original host.

>+// returns the unobscured host (if there is one), otherwise false
Might want to return null on failure
Comment 2 Ian Neal 2012-05-20 16:40:10 PDT
Created attachment 625525 [details] [diff] [review]
Updated for review comments [Checked in: Comment 3, 4 & 5]

Carrying forward r=
Comment 3 Ian Neal 2012-05-20 16:48:03 PDT
Comment on attachment 625525 [details] [diff] [review]
Updated for review comments [Checked in: Comment 3, 4 & 5]

http://hg.mozilla.org/comm-central/rev/58044311b637

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Less robust checking of scam emails
Testing completed (on m-c, etc.): Landed on trunk
Risk to taking this patch (and alternatives if risky): Low risk
String changes made by this patch: None
Comment 4 Philip Chee 2012-05-21 02:45:24 PDT
Pushed to comm-beta.
http://hg.mozilla.org/releases/comm-beta/rev/f7430f8d47df
Comment 5 Ian Neal 2012-05-21 13:23:19 PDT
Comment on attachment 625525 [details] [diff] [review]
Updated for review comments [Checked in: Comment 3, 4 & 5]

http://hg.mozilla.org/releases/comm-aurora/rev/11549db5edf6

Note You need to log in before you can comment on or make changes to this bug.