MacOS 9 - window.alert() uses bad width, chrome, title, icon, and font

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
P4
minor
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: Peter Trudelle)

Tracking

(Depends on: 1 bug, {helpwanted})

Trunk
Future
PowerPC
Mac System 9.x
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 2001041004, Mac OS 9.1

To reproduce:
*   Open the JavaScript console.
*   In the evaluation bar, enter:
    window.alert("This file is in use by the system software. It cannot be
    opened.")
*   Press Enter.

What you should see:
*   An alert which is always 370 pixels wide, with a pink border, no title, the
    `note' icon, and text in the large system font.

What you see:
*   A dialog which can be any width up to 500 pixels, with a gray border, the
    title `Alert', the `caution' icon, and text in the small system font.

This bug may need to turn into a meta-bug for bugs in the XP Toolkit, XP Apps, 
and Themes components.
(Reporter)

Comment 1

17 years ago
Created attachment 30566 [details]
What you should see
(Reporter)

Comment 2

17 years ago
Created attachment 30567 [details]
What you currently see
(Reporter)

Updated

17 years ago
Depends on: 79274
(Reporter)

Updated

17 years ago
Depends on: 79623
(Reporter)

Updated

17 years ago
Blocks: 57591
Depends on: 81178
Keywords: meta

Updated

17 years ago
No longer blocks: 57591

Comment 3

17 years ago
It would seem to me that the variable width would be desirable since the alert
box is variable on Windows. In fact, I've seen many cases were web developers
insert \n to set the appropriate line breaks. I'm not sure what the maximum
width is in windows, but I know from looking at this with Netscape 4.x that it's
more than the mac. I'm just pointing out that this is a portability issue. I'd
think you'd want to allow the same amount of text space in the alert box as on
Windows. The rest of the bug is probably still valid, but since I almost never
use a Mac, I don't know how much this would matter to Mac users.
(Reporter)

Updated

17 years ago
Depends on: 95649

Comment 4

17 years ago
ok, so the deal is we don't look like a regular mac app. Ooops. At any rate, the
first thing I would want fixed is native widgets.

Marking p4, minor, and future.
Severity: normal → minor
Status: NEW → ASSIGNED
Priority: -- → P4
Target Milestone: --- → Future

Comment 5

17 years ago
-> default assignee
Assignee: pchen → trudelle
Status: ASSIGNED → NEW
Target Milestone: Future → ---
(Assignee)

Comment 6

17 years ago
->future/helpwanted, removing meta
Keywords: meta → helpwanted
Target Milestone: --- → Future

Comment 7

16 years ago
Mozilla CFM build is dead.
http://groups.google.com/groups?threadm=avkj4k%24ihs2%40ripley.netscape.com
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Summary: window.alert() uses bad width, chrome, title, icon, and font → MacOS 9 - window.alert() uses bad width, chrome, title, icon, and font
QA Contact: sairuh → nobody
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.