support per-window private browsing when available

RESOLVED DUPLICATE of bug 808215

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 808215
7 years ago
6 years ago

People

(Reporter: mhanson, Unassigned)

Tracking

15 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
On entering private browsing mode, all social features should automatically be disabled.

When private browsing mode is deactivated, the user's social browsing context should be restored to how it was.

Doing this correctly when we have per-window Private Browsing may require some additional thought; see https://bugzilla.mozilla.org/show_bug.cgi?id=463027
Moving this to a future when we have the per-window private browsing.
Depends on: 463027
Summary: Private browsing should disable social features → support per-window private browsing when available
note: we already disable social browsing when in private mode.

Comment 3

7 years ago
Is this something which will be implemented in mozilla-central?  If so, can you please ask me for review on the relevant code?
Severity: normal → enhancement

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 808215
You need to log in before you can comment on or make changes to this bug.