image not shown on linux, works on windows NT

VERIFIED DUPLICATE of bug 74313

Status

()

--
major
VERIFIED DUPLICATE of bug 74313
18 years ago
18 years ago

People

(Reporter: f300v10, Assigned: pavlov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib] [linux scaling], URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; 0.8.1) Gecko/20010412
BuildID:    2001041205

The map jpg image has not been visible on Linux builds since libpOrn landed. 
The same image is displayed correctly on windows builds with libp0rn. 

Reproducible: Always
Steps to Reproduce:
1.Go to URL
2.Image is not displayed
3.

Actual Results:  The map image is not displayed.

Expected Results:  The image should be displayed.

If you right click on the missing image, and select view image from the menu,
the image is correctly displayed by itself. The same page works fine on the same
days windows build.
(Reporter)

Comment 1

18 years ago
I played around with the <img> tag of the offending image, and found that if the
width and height (which are originaly correctly declared at 720 X 478)
properties are removed, the image is still not visible, but becomes visible if
clicked on.  Clicking on the image with the width and height declared has no effect.

Comment 2

18 years ago
I am seeing this linux build 2001041205, changing to new [imglib]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [imglib]

Comment 3

18 years ago
I see this as well, on http://www.arlut.utexas.edu/.  There is supposed
to be a picture of our laboratory on this page, but there's just a blank
space.  Right-clicking on the rectangle where the picture should be
and doing a 'view image' brings it up okay on its own.
Probably the same bug as at http://movies.netflix.com/MovieDisplay?movieid=60002325&

In the blank area on the upper left there is supposed to be an image.

I'm also using Linux, build 2001041214
(Assignee)

Updated

18 years ago
Whiteboard: [imglib] → [imglib] [linux scaling]

Comment 5

18 years ago
I'm seeing the same problem (indeed, in great
proliferation) when remote-displaying from a Solaris
box to a Linux box (which does not have XIE).
Completely consistant.

Comment 6

18 years ago
I get this when running straight on Solaris, right on the local X server.
Images will frequently not appear, but I can cause them to appear simply by 
dragging the mouse over them (as if I was trying to select them for C&P).

Does this bug display such behavior?
Can we get this bug nominated for 0.9? I know it's late, but it seems to me that
it would be a pretty bad move to release a milestone which has a regression of
this magnitude, one that makes running the program on one of its target
platforms pretty pointless.
(Assignee)

Comment 8

18 years ago
there is a patch to do image scaling without xie or gdkpixbuf.. it will get in 
in the next day or two (for 0.9)

Comment 9

18 years ago
Great!  Feel like accepting the bug, then?  :)

Comment 10

18 years ago
*** Bug 76583 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
isn't this bug 74313 ?

Comment 12

18 years ago
This is happening on OpenVMS too (X display on local workstation). 
You have to fix this one for 0.9!!!!
(Reporter)

Comment 13

18 years ago
Asa, I believe this is the same as bug 74313.  I didn't think the image I
reported this on was being scalled, but it is.
Scott, marking duplicate of 74313.  Please reopen if that gets fixed and the
problem is not gone.

*** This bug has been marked as a duplicate of 74313 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 15

18 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.