Last Comment Bug 757909 - add in-tree mozconfigs for android/armv6 and android/x86
: add in-tree mozconfigs for android/armv6 and android/x86
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: mozilla15
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
Mentors:
Depends on: 751265
Blocks: 723946 750366
  Show dependency treegraph
 
Reported: 2012-05-23 10:52 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2012-07-23 12:56 PDT (History)
6 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mozconfigs for android-armv6 and android-x86 (14.53 KB, patch)
2012-05-23 11:06 PDT, Ted Mielczarek [:ted.mielczarek]
mh+mozilla: review-
catlee: review+
Details | Diff | Splinter Review
mozconfigs for android-armv6 and android-x86 (11.48 KB, patch)
2012-05-24 11:02 PDT, Ted Mielczarek [:ted.mielczarek]
mh+mozilla: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2012-05-23 10:52:16 PDT
We should have mozconfigs in-tree for these to make things easy.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-05-23 11:06:21 PDT
Created attachment 626508 [details] [diff] [review]
mozconfigs for android-armv6 and android-x86

This patch just copies the existing android mozconfigs and tweaks them. I haven't tried the armv6 one, but it ought to work. (Should be able to push it to try and see.) I've built with the x86 one locally (with a few well-placed symlinks to get /tools in order), but it fails on try because of bug 756816.

r?catlee on the directory layout, r?glandium on the mozconfig contents.
Comment 2 Mike Hommey [:glandium] 2012-05-23 11:10:38 PDT
Comment on attachment 626508 [details] [diff] [review]
mozconfigs for android-armv6 and android-x86

Review of attachment 626508 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/config/mozconfigs/android/debug
@@ +5,5 @@
>  # Build Fennec
>  ac_add_options --enable-application=mobile/android
>  
>  # Android
>  ac_add_options --target=arm-linux-androideabi

Probably makes no difference, but I've always been using i686-linux-android.

@@ +11,5 @@
>  ac_add_options --with-endian=little
>  ac_add_options --with-android-ndk="/tools/android-ndk-r5c"
>  ac_add_options --with-android-sdk="/tools/android-sdk-r15/platforms/android-14"
>  ac_add_options --with-android-tools="/tools/android-sdk-r15/tools"
>  ac_add_options --with-android-toolchain=/tools/android-ndk-r5c/toolchains/arm-linux-androideabi-4.4.3/prebuilt/linux-x86

You should start from the new android mozconfigs (after bug 751265). Most of this is unneeded.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-05-23 11:25:40 PDT
(In reply to Mike Hommey [:glandium] from comment #2)
> Comment on attachment 626508 [details] [diff] [review]
> mozconfigs for android-armv6 and android-x86
> 
> Review of attachment 626508 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: mobile/android/config/mozconfigs/android/debug
> @@ +5,5 @@
> >  # Build Fennec
> >  ac_add_options --enable-application=mobile/android
> >  
> >  # Android
> >  ac_add_options --target=arm-linux-androideabi
> 
> Probably makes no difference, but I've always been using i686-linux-android.

Presumably you meant to make that comment on the x86 mozconfig, not the armv6 one?

> You should start from the new android mozconfigs (after bug 751265). Most of
> this is unneeded.

Ok, thanks.
Comment 4 Mike Hommey [:glandium] 2012-05-23 11:42:57 PDT
(In reply to Ted Mielczarek [:ted] from comment #3)
> Presumably you meant to make that comment on the x86 mozconfig, not the
> armv6 one?

indeed, although i think i really did, and i wouldn't be surprised that splinter review was just confused by the file copies.
Comment 5 Chris AtLee [:catlee] 2012-05-24 06:32:26 PDT
Comment on attachment 626508 [details] [diff] [review]
mozconfigs for android-armv6 and android-x86

Review of attachment 626508 [details] [diff] [review]:
-----------------------------------------------------------------

directory structure looks fine
Comment 6 Ted Mielczarek [:ted.mielczarek] 2012-05-24 11:02:38 PDT
Created attachment 626886 [details] [diff] [review]
mozconfigs for android-armv6 and android-x86

Rebased on top of bug 751265.
Comment 7 Mike Hommey [:glandium] 2012-05-24 22:51:56 PDT
Comment on attachment 626886 [details] [diff] [review]
mozconfigs for android-armv6 and android-x86

Review of attachment 626886 [details] [diff] [review]:
-----------------------------------------------------------------

Please remove that extra line you add to mobile/android/config/mozconfigs/android-x86/nightly.

(FWIW, Splinter review *is* confused by the copied files)
Comment 8 Ted Mielczarek [:ted.mielczarek] 2012-05-25 05:25:14 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ad71b887061f
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-05-26 05:10:24 PDT
https://hg.mozilla.org/mozilla-central/rev/ad71b887061f
Comment 10 Brad Lassey [:blassey] (use needinfo?) 2012-07-23 09:01:32 PDT
Comment on attachment 626886 [details] [diff] [review]
mozconfigs for android-armv6 and android-x86

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: can't build ARMv6 for Fx15
Testing completed (on m-c, etc.): landed on m-c when it was Fx16
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Comment 11 Ted Mielczarek [:ted.mielczarek] 2012-07-23 09:17:14 PDT
There's no risk to these patches, they're mozconfigs for alternate build configurations. They have no impact on the existing build configurations.
Comment 12 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-23 12:56:08 PDT
Comment on attachment 626886 [details] [diff] [review]
mozconfigs for android-armv6 and android-x86

no risk, mozconfigs only - approving.

Note You need to log in before you can comment on or make changes to this bug.