reports/list should only populate tabs when clicked

VERIFIED FIXED in 60

Status

VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: jberkus, Assigned: peterbe)

Tracking

({perf})

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

(Reporter)

Description

7 years ago
Right now, the reports/list interface has 8 tabs, and we'll be adding more in the future.  Each of those tabs involves at least one, and possibly several, database calls, which is wasted system resources and slowed response time if the user only wants to look at one tab.

We shouldn't load the data until the user clicks each tab.

Comment 1

5 years ago
Signature summary does load on demand. Nothing else does. One long page rendered by CSS.

We could do better on this.
Keywords: perf
This has been on my to-do list for the longest time (bad me), taking this one.
Assignee: nobody → schalk.neethling.bugs
(Assignee)

Comment 3

5 years ago
We talked about this on IRC. When I started refactoring how the Reports tab worked and make that load async I started quickly treading into this bug. 

I have a partial solution already. (funny because it's using "partial views").
Assignee: schalk.neethling.bugs → peterbe
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Blocks: 912132

Updated

5 years ago
Blocks: 893238
(Assignee)

Updated

5 years ago
Whiteboard: [qa+
Target Milestone: Future → 59
(Assignee)

Comment 4

5 years ago
Steps to "reproduce" (in quotes because this is an optimization thing):

1. Click on Top Crashers
2. Click on some signatures
3. The page should load faster
4. Signature summary should start loading immediately
5. Within a couple of seconds, without having to click anything, the count on "Comments" and "Bugzilla" tabs should update
6. Clicking any of the other tabs after a couple of seconds waiting, should load the tab immediately. 

If viewing the report list NOT signed in there should not be a URLs tab.

Comment 5

5 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/90d5c90b9fc35ddafb556bfdcabc82242a996cde
fixes bug 758054 - reportslist should only populate tabs when clicked, r=espressive

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: [qa+ → [qa+]
Target Milestone: 59 → 60
QA verified on stage - nicely done peterbe, the update is noticeably faster (I don't have before/after metrics). 

Verified with steps to test in comment 4 plus using the web console to watch the requests complete.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.