Last Comment Bug 758097 - WARNING: NS_ENSURE_TRUE(rv) failed: file /Volumes/mac/moz/b2ggecko/hal/gonk/GonkSwitch.cpp, line 131
: WARNING: NS_ENSURE_TRUE(rv) failed: file /Volumes/mac/moz/b2ggecko/hal/gonk/G...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: x86 Gonk (Firefox OS)
: -- normal (vote)
: mozilla15
Assigned To: Cervantes Yu [:cyu] [:cervantes]
:
:
Mentors:
: 759385 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 19:14 PDT by Gregor Wagner [:gwagner]
Modified: 2012-05-29 11:28 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't use NS_ENSURE_TRUE() for return value that will be false (852 bytes, patch)
2012-05-24 04:47 PDT, Cervantes Yu [:cyu] [:cervantes]
mwu.code: review+
Details | Diff | Splinter Review

Description Gregor Wagner [:gwagner] 2012-05-23 19:14:05 PDT
Gecko in debug build on device during startup.
Multiple instances of:
WARNING: NS_ENSURE_TRUE(rv) failed: file /Volumes/mac/moz/b2ggecko/hal/gonk/GonkSwitch.cpp, line 131
Comment 1 Cervantes Yu [:cyu] [:cervantes] 2012-05-24 04:47:19 PDT
Created attachment 626758 [details] [diff] [review]
Don't use NS_ENSURE_TRUE() for return value that will be false

SwitchEventObserver::GetEventInfo() could receive events that are not of interest and return false. Fix the warning in debug build by not using NS_ENSURE_TRUE() but instead checking it directly.
Comment 2 Kan-Ru Chen [:kanru] (UTC+8) 2012-05-25 00:57:41 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/13236f855e37
Comment 3 Ed Morley [:emorley] 2012-05-25 08:21:14 PDT
https://hg.mozilla.org/mozilla-central/rev/13236f855e37
Comment 4 Gregor Wagner [:gwagner] 2012-05-29 11:28:25 PDT
*** Bug 759385 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.