Last Comment Bug 758206 - Add a new telemetry histogram for the reason preload is activated
: Add a new telemetry histogram for the reason preload is activated
Status: VERIFIED FIXED
[qa!]
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: 12 Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Brian R. Bondy [:bbondy]
:
: Jim Mathies [:jimm]
Mentors:
Depends on:
Blocks: 692255 727864
  Show dependency treegraph
 
Reported: 2012-05-24 07:08 PDT by Brian R. Bondy [:bbondy]
Modified: 2012-08-27 13:22 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1. (3.72 KB, patch)
2012-05-24 07:16 PDT, Brian R. Bondy [:bbondy]
taras.mozilla: review+
Details | Diff | Splinter Review
Patch v2 - Base patch for adding telemetry for preload (3.72 KB, patch)
2012-05-24 10:16 PDT, Brian R. Bondy [:bbondy]
netzen: review+
Details | Diff | Splinter Review
Patch v1 - Better prefetch cleared detection for telemetry (4.08 KB, patch)
2012-05-25 08:10 PDT, Brian R. Bondy [:bbondy]
taras.mozilla: review+
Details | Diff | Splinter Review

Description User image Brian R. Bondy [:bbondy] 2012-05-24 07:08:31 PDT
We should add a new telemetry histogram in Windows for the reason preload is being used.  Values should be 0 for none, 1 for preload because service disabled prefetch, and 2 because ioCounters.ReadOperationCount is 0.
Comment 1 User image Brian R. Bondy [:bbondy] 2012-05-24 07:16:50 PDT
Created attachment 626792 [details] [diff] [review]
Patch v1.
Comment 2 User image (dormant account) 2012-05-24 08:27:06 PDT
Comment on attachment 626792 [details] [diff] [review]
Patch v1.

thanks
Comment 3 User image Brian R. Bondy [:bbondy] 2012-05-24 09:51:30 PDT
I just noticed when I did a full build that I was getting a compiling error. 
I think I need to update the definition of the histogram from 
> ...0, 2, 3...

to:
> 1, 2, 

Please confirm and I'll attach a new patch and carry forward the r+.
Comment 4 User image Brian R. Bondy [:bbondy] 2012-05-24 10:16:10 PDT
Created attachment 626862 [details] [diff] [review]
Patch v2 - Base patch for adding telemetry for preload

Updated to 1,2,3 as per IRC, carrying forward r+.
Comment 5 User image Brian R. Bondy [:bbondy] 2012-05-25 08:10:26 PDT
Created attachment 627236 [details] [diff] [review]
Patch v1 - Better prefetch cleared detection for telemetry

This patch will help us get better telemetry data. 
It will more deterministically detect when we should mark the prefetch cleared flag that we use in telemetry.
Comment 6 User image Brian R. Bondy [:bbondy] 2012-05-25 08:12:16 PDT
This patch will also improve the message in the log for already cleared prefetch file (it won't say access denied anymore for those files)
Comment 7 User image Brian R. Bondy [:bbondy] 2012-05-25 09:48:06 PDT
Thanks for the quick reviews :)
Comment 9 User image Jason Smith [:jsmith] 2012-06-07 23:12:44 PDT
Checking the telemetry histogram for STARTUP_USING_PRELOAD, I see that the histogram has been populated with 44815 submissions with the following distribution:

- 0: 56.95% (none)
- 1: 23.16% (preload since service disabled prefetch)
- 2: 19.88% (ioCounters.ReadOperationCount = 0)

I believe this verifies if we're getting data, correct?

One clarification question - What exactly is this distribution telling us? Trying to understand how to interpret this histogram.
Comment 10 User image Brian R. Bondy [:bbondy] 2012-06-08 06:30:04 PDT
> I believe this verifies if we're getting data, correct?

Correct.


> One clarification question - What exactly is this distribution telling us? 
> Trying to understand how to interpret this histogram.

1 tells us that only 23% of the users that have telemetry enabled have a fully cleared prefetch.  Keep in mind that x64 builds don't have a service to clear prefetch with and XP users won't clear on update.  It jumps to 40% on Aurora by the way.
Comment 11 User image Jason Smith [:jsmith] 2012-06-08 08:38:15 PDT
(In reply to Brian R. Bondy [:bbondy] from comment #10)
> 1 tells us that only 23% of the users that have telemetry enabled have a
> fully cleared prefetch.  Keep in mind that x64 builds don't have a service
> to clear prefetch with and XP users won't clear on update.  It jumps to 40%
> on Aurora by the way.

Although Aurora has a much smaller sample set (219) and I'm not sure this makes sense to see this on Aurora, given that this patch landed on 5/27, but there's data in this pool from 5/17 and on.

The nightly pool has a similar issue, as I'm seeing submissions included in here from 5/9 and on. Is something not right here?
Comment 12 User image Jason Smith [:jsmith] 2012-06-08 08:39:57 PDT
Or maybe I'm interpreting the graph for "submissions by date" incorrectly.
Comment 13 User image Jason Smith [:jsmith] 2012-06-08 08:42:23 PDT
(In reply to Jason Smith [:jsmith] from comment #12)
> Or maybe I'm interpreting the graph for "submissions by date" incorrectly.

Actually, I get the feeling this is a problem in that particular graph, cause the graph below that by platform ID appears to be as one would expect (6/1 and on).
Comment 14 User image Jason Smith [:jsmith] 2012-06-08 08:50:45 PDT
(In reply to Jason Smith [:jsmith] from comment #13)
> (In reply to Jason Smith [:jsmith] from comment #12)
> > Or maybe I'm interpreting the graph for "submissions by date" incorrectly.
> 
> Actually, I get the feeling this is a problem in that particular graph,
> cause the graph below that by platform ID appears to be as one would expect
> (6/1 and on).

Confirmed this is a problem with the actual graph.

Note You need to log in before you can comment on or make changes to this bug.