Last Comment Bug 758357 - Only show prompt after 50mb of quota was reached
: Only show prompt after 50mb of quota was reached
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
Mentors:
Depends on: 786769 770085
Blocks: 742822 726378
  Show dependency treegraph
 
Reported: 2012-05-24 13:38 PDT by (dormant account)
Modified: 2012-10-02 11:48 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (72.03 KB, patch)
2012-06-30 06:17 PDT, Ben Turner (not reading bugmail, use the needinfo flag!)
no flags Details | Diff | Splinter Review
Patch (26.51 KB, patch)
2012-06-30 06:19 PDT, Ben Turner (not reading bugmail, use the needinfo flag!)
jonas: review+
khuey: review-
Details | Diff | Splinter Review
patch (975 bytes, patch)
2012-07-02 13:45 PDT, Gregor Wagner [:gwagner]
fabrice: review+
Details | Diff | Splinter Review

Description (dormant account) 2012-05-24 13:38:01 PDT
bug 742822 will make indexeddb less persistent. We should proactively get rid of the prompt so web developers can start using indexeddb(and drop dom storage) while we wrap up the quota code.
Comment 1 Jonas Sicking (:sicking) PTO Until July 5th 2012-05-24 16:54:48 PDT
We should definitely keep this option in mind in order to enable unprefixing IndexedDB. Ideally we would implement the new storage policy of not storing things permanently, but if this is the only thing standing between us and unprefixing, then this seems like a viable short-term fix.
Comment 2 Jan Varga [:janv] 2012-06-07 23:37:36 PDT
Jonas, should I fix this bug first ?
Comment 3 Jan Varga [:janv] 2012-06-10 02:40:20 PDT
Jonas agreed on IRC
Comment 4 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-06-30 06:17:08 PDT
Created attachment 638104 [details] [diff] [review]
Patch

This keeps it at 50mb like we agreed, and it fixes the UI to be sane (it does nearly the same thing as the fullscreen permission UI). Seems like a fair compromise.
Comment 5 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-06-30 06:19:05 PDT
Created attachment 638105 [details] [diff] [review]
Patch

Clearly that was not the right patch.
Comment 6 Jonas Sicking (:sicking) PTO Until July 5th 2012-06-30 10:58:48 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d295ed03d7f
Comment 7 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-30 16:35:06 PDT
Comment on attachment 638105 [details] [diff] [review]
Patch

Review of attachment 638105 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/indexedDB/test/helpers.js
@@ +64,1 @@
>    });

This was commented out for a reason.  It's causing massive orange on tinderbox.
Comment 8 Jonas Sicking (:sicking) PTO Until July 5th 2012-06-30 17:08:41 PDT
I also had to check in this followup:

https://hg.mozilla.org/integration/mozilla-inbound/rev/6763477075a4
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-06-30 18:53:02 PDT
Jonas checked in a follow-up patch to avoid oranges, and it broke things again. (Irony++)
https://hg.mozilla.org/integration/mozilla-inbound/rev/a8bfe5a447e7

Follow-up backed out:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3b30ca51a2a1
Comment 10 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-07-01 02:08:45 PDT
Looks like a8bfe5a447e7 was almost correct, you just need to make sure you call SimpleTest.finish().
Comment 11 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-07-01 02:13:30 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #7)
> This was commented out for a reason.  It's causing massive orange on
> tinderbox.

Somehow I missed that change. Did you look into the reason this causes problems?
Comment 12 Ryan VanderMeulen [:RyanVM] 2012-07-01 06:40:12 PDT
OK, I've pushed a8bfe5a447e7 with SimpleTest.finish() added per comment 10. If this doesn't clear things up, I'm going to back out the entire set of patches for this bug.
https://hg.mozilla.org/integration/mozilla-inbound/rev/540cd3aabdd4
Comment 13 Ryan VanderMeulen [:RyanVM] 2012-07-01 08:22:57 PDT
(In reply to Ryan VanderMeulen from comment #12)
> OK, I've pushed a8bfe5a447e7 with SimpleTest.finish() added per comment 10.
> If this doesn't clear things up, I'm going to back out the entire set of
> patches for this bug.
> https://hg.mozilla.org/integration/mozilla-inbound/rev/540cd3aabdd4

Looking much better on TBPL.
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=540cd3aabdd4
Comment 14 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-07-01 08:24:54 PDT
(In reply to ben turner [:bent] from comment #11)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #7)
> > This was commented out for a reason.  It's causing massive orange on
> > tinderbox.
> 
> Somehow I missed that change. Did you look into the reason this causes
> problems?

I haven't had time to investigate it yet.
Comment 17 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-07-01 23:29:41 PDT
Sigh. B2G will need to stop setting the "indexedDB" permission for gaia apps. It will still need to set the "indexedDB-unlimited" permission.
Comment 18 Gregor Wagner [:gwagner] 2012-07-02 13:34:12 PDT
(In reply to ben turner [:bent] from comment #17)
> Sigh. B2G will need to stop setting the "indexedDB" permission for gaia
> apps. It will still need to set the "indexedDB-unlimited" permission.

So the solution is to synchronize this landing with removing the indexedDB permission in gaia?
Comment 19 Gregor Wagner [:gwagner] 2012-07-02 13:45:00 PDT
Created attachment 638477 [details] [diff] [review]
patch

Remove indexedDB permission for B2G
Comment 21 Jonas Sicking (:sicking) PTO Until July 5th 2012-07-03 19:56:35 PDT
Yes, flipping this in Gaia and Gecko at the same time should fix things.
Comment 22 Gregor Wagner [:gwagner] 2012-07-05 09:04:08 PDT
(In reply to Jonas Sicking (:sicking) from comment #21)
> Yes, flipping this in Gaia and Gecko at the same time should fix things.

And we are in a situation again where we will break indexeddb because we can't land this patch at the same time in Gaia and Gecko. People are using hg-inbound, hg-mc and the github-mc gecko tree....

So the whole patch here is backed out right?
Comment 23 Gregor Wagner [:gwagner] 2012-07-05 09:07:38 PDT
(In reply to Gregor Wagner [:gwagner] from comment #22)
> (In reply to Jonas Sicking (:sicking) from comment #21)
> > Yes, flipping this in Gaia and Gecko at the same time should fix things.
> 
> And we are in a situation again where we will break indexeddb because we
> can't land this patch at the same time in Gaia and Gecko. People are using
> hg-inbound, hg-mc and the github-mc gecko tree....
> 

Ah it shouldn't be a problem because the permission is set in gecko. It's too early for me.

Note You need to log in before you can comment on or make changes to this bug.