Closed Bug 758476 Opened 8 years ago Closed 5 years ago

Intermittent test_play_twice.html | Test timed out.

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox34 --- wontfix
firefox35 --- wontfix
firefox36 --- fixed
firefox-esr31 --- wontfix

People

(Reporter: philor, Assigned: jwwang)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #558812 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=12046125&tree=Mozilla-Inbound
Rev3 MacOSX Leopard 10.5.8 mozilla-inbound opt test mochitests-1/5 on 2012-05-24 17:47:28 PDT for push 2ee09416b1d7
slave: talos-r3-leopard-034

82676 INFO TEST-PASS | /tests/content/media/test/test_play_twice.html | [finished bug533822.ogg-6] Length of array should match number of running tests - 1 should equal 1
82677 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_play_twice.html | Test timed out.
args: ['arch', '-arch', 'i386', '/usr/sbin/screencapture', '-C', '-x', '-t', 'png', '/var/folders/Xr/Xr--yJnSEY0U11ET5NZuMU+++TM/-Tmp-/mozilla-test-fail_YIGqC_']
(screenshot)
82678 INFO TEST-END | /tests/content/media/test/test_play_twice.html | finished in 327460ms
Whiteboard: [orange]
Disabled on Android.
https://hg.mozilla.org/integration/b2g-inbound/rev/213937a65046
Whiteboard: [test disabled on Android][leave open]
Try: https://tbpl.mozilla.org/?tree=Try&rev=bf810c6d6432
No failures in test_play_twice.html.
Looks like the status is good enough to enable it on B2G and Android again.
Assignee: nobody → jwwang
Status: NEW → ASSIGNED
Attachment #8516416 - Flags: review?(cajbir.bugzilla)
Comment on attachment 8516416 [details] [diff] [review]
758476_fix_test_play_twice_html.patch

To ease reviewing can you tell me what the problem was and how you fixed it? Or point me to where you outline that. Re-request review when done.
Attachment #8516416 - Flags: review?(cajbir.bugzilla)
Comment on attachment 8516416 [details] [diff] [review]
758476_fix_test_play_twice_html.patch

Review of attachment 8516416 [details] [diff] [review]:
-----------------------------------------------------------------

I am not sure about the root cause. Maybe it is already fixed in other test cases. I try to release decoder resources when finishing each test file to ensure we don't time out in waiting for HW decoder resources on B2G. The Try results looks good though.

::: dom/media/test/test_play_twice.html
@@ +29,5 @@
>      ok(false, test.name + " should not fire 'load' event");
>    }}(test, v);
> +
> +  function finish(v) {
> +    removeNodeAndSource(v);

Release decoder resources to ensure we don't time out in waiting for HW decoder resource.

@@ +33,5 @@
> +    removeNodeAndSource(v);
> +    manager.finished(v.token);
> +  }
> +
> +  function mayFinish(v) {

Finish the test when we got 'ended' and 'suspend' events.
Attachment #8516416 - Flags: review?(cajbir.bugzilla)
Attachment #8516416 - Flags: review?(cajbir.bugzilla) → review+
Keywords: checkin-needed
Whiteboard: [test disabled on Android][leave open] → [test disabled on Android]
https://hg.mozilla.org/mozilla-central/rev/e18a87bf1bfe
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Not going to chance uplifting this one without a clear idea of what fixed it. Will let it ride the trains.
Whiteboard: [test disabled on Android]
You need to log in before you can comment on or make changes to this bug.