Last Comment Bug 758543 - IonMonkey: Differential Testing: Missing ReferenceError with __proto__ and ion
: IonMonkey: Differential Testing: Missing ReferenceError with __proto__ and ion
Status: RESOLVED FIXED
[fuzzblocker]
: regression, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86_64 Linux
: -- critical (vote)
: ---
Assigned To: David Anderson [:dvander]
:
: Jason Orendorff [:jorendorff]
Mentors:
: 758394 (view as bug list)
Depends on:
Blocks: langfuzz IonFuzz
  Show dependency treegraph
 
Reported: 2012-05-25 01:45 PDT by Christian Holler (:decoder)
Modified: 2012-05-30 07:58 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.46 KB, patch)
2012-05-25 15:30 PDT, David Anderson [:dvander]
sstangl: review+
Details | Diff | Splinter Review

Description Christian Holler (:decoder) 2012-05-25 01:45:33 PDT
The following testcase shows different behavior with options --ion -n -m --ion-eager vs. --no-ion on ionmonkey revision c05b873dad48:


y = this.watch("x", function() {
  var result = x * obj;
});
var save__proto__ = __proto__;
__proto__ = save__proto__;
evaluate("{ function x() {} }");
evaluate("var x = {};");


$ debug64/js --ion -n -m --ion-eager test.js
<no output or error>


$ debug64/js --no-ion test.js
test.js:2: ReferenceError: obj is not defined
Comment 1 David Anderson [:dvander] 2012-05-25 15:30:10 PDT
Created attachment 627388 [details] [diff] [review]
fix

Two bugs, one is that we emitted an inlined setprop even if the object was watched. Second, DefVar wasn't using the right attrs.
Comment 2 David Anderson [:dvander] 2012-05-25 15:32:07 PDT
*** Bug 758394 has been marked as a duplicate of this bug. ***
Comment 3 Christian Holler (:decoder) 2012-05-27 14:48:33 PDT
This bug shows up in quite a few different forms during differential testing, so it'd be good to land this before starting any further testing of this type.
Comment 4 David Anderson [:dvander] 2012-05-30 07:58:55 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/d0e27348e778

Note You need to log in before you can comment on or make changes to this bug.