Last Comment Bug 758595 - don't include CodeResources file in builds that aren't getting signed
: don't include CodeResources file in builds that aren't getting signed
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Ben Hearsum (:bhearsum)
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 761525
  Show dependency treegraph
 
Reported: 2012-05-25 06:24 PDT by Ben Hearsum (:bhearsum)
Modified: 2012-06-11 13:14 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
don't include CodeResources when MOZ_SIGNING isn't set (1.50 KB, patch)
2012-05-28 14:09 PDT, Ben Hearsum (:bhearsum)
ted: review+
bhearsum: checkin+
Details | Diff | Splinter Review

Description Ben Hearsum (:bhearsum) 2012-05-25 06:24:19 PDT
As of bug 732176 we're shipping a Contents/_CodeSignature/CodeResources in every mac build. 
It'd be good to stop doing this for builds that don't have a MOZ_SIGN_CMD, since we know we won't be signing them.
Comment 1 Ben Hearsum (:bhearsum) 2012-05-28 09:00:18 PDT
Unfortunately, we don't have any existing variables (that I can find) that will let us accomplish this....maybe we can create a new one in configure.in based on the value of MOZ_SIGN_CMD.
Comment 2 Ben Hearsum (:bhearsum) 2012-05-28 09:11:51 PDT
wip on https://github.com/bhearsum/mozilla-central/tree/no-coderesources-unsigned
Comment 3 Ben Hearsum (:bhearsum) 2012-05-28 14:09:02 PDT
Created attachment 627785 [details] [diff] [review]
don't include CodeResources when MOZ_SIGNING isn't set

I did my best to test this on try by adding a "export MOZ_SIGN_CMD=" at the top of the configure.in hunk. That ended up causing signing errors, because MOZ_SIGN_CMD was set during "make package" but CodeResources was missing. To me, that indicates success :).
Comment 4 Ben Hearsum (:bhearsum) 2012-06-01 13:00:08 PDT
We need to port this to Thunderbird, too.
Comment 5 Ben Hearsum (:bhearsum) 2012-06-11 08:14:07 PDT
Comment on attachment 627785 [details] [diff] [review]
don't include CodeResources when MOZ_SIGNING isn't set

http://hg.mozilla.org/mozilla-central/rev/0f2b57130b26
Comment 6 Ben Hearsum (:bhearsum) 2012-06-11 13:14:07 PDT
Landed cleanly.

Note You need to log in before you can comment on or make changes to this bug.