Status

P1
normal
RESOLVED DUPLICATE of bug 842641
7 years ago
5 years ago

People

(Reporter: kats, Unassigned)

Tracking

Trunk
Other
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: mxr-parity)

Go to some DXR result with a line number, e.g. http://dxr.lanedo.com/mozilla-central/widget/nsGUIEvent.h.html#l525 and then click on the "hg blame" link in the top right corner. With MXR this would take you to the same line in the annotated view, but with the DXR it drops the line number when going to the annotated page.

Comment 1

7 years ago
This is a big MXR parity issue in my own usage as well (I thought I had fixed this).  Looks easy to fix.
Priority: -- → P1

Comment 2

7 years ago
This is a bit tricky, the hg annotate links in MXR are generated in the search results, so are specific to the returned line of code, whereas in DXR the link is global to the whole file and hardcoded in the generated HTML.

I guess we can set up some JS to create the correct link from the anchor name present in the url, but one could easily scroll out of "context" and forget about the line that brought him to that file in the first place
Whiteboard: mxr-parity
DXR doesn't even have blame any more.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: DXR blame links should jump to line number → Revive DXR blame
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 842641
You need to log in before you can comment on or make changes to this bug.