Last Comment Bug 758773 - m-i build broken on Mac
: m-i build broken on Mac
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 758858 746794 758010
  Show dependency treegraph
 
Reported: 2012-05-25 13:50 PDT by Hubert Figuiere [:hub]
Modified: 2012-05-26 01:14 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Hubert Figuiere [:hub] 2012-05-25 13:50:25 PDT
When building inbound on MacOS 10.7, I get the following build failure:

Undefined symbols for architecture x86_64:
  "_moz_xmalloc", referenced from:
      google_breakpad::UTF16ToUTF8(std::vector<unsigned short, std::allocator<unsigned short> > const&, bool) in string_conversion.o
      __gnu_cxx::new_allocator<unsigned short>::allocate(unsigned long, void const*) in string_conversion.o
      __gnu_cxx::new_allocator<fat_arch>::allocate(unsigned long, void const*) in macho_reader.o
      __gnu_cxx::new_allocator<std::_Rb_tree_node<std::pair<std::string const, google_breakpad::mach_o::Section> > >::allocate(unsigned long, void const*) in macho_reader.o
      MacStringUtils::ConvertToString(__CFString const*) in string_utilities.o
  "_moz_free", referenced from:
      google_breakpad::scoped_ptr<unsigned short>::reset(unsigned short*) in string_conversion.o
      google_breakpad::scoped_array<unsigned char>::~scoped_array() in string_conversion.o
      google_breakpad::scoped_ptr<unsigned short>::~scoped_ptr() in string_conversion.o
      __gnu_cxx::new_allocator<unsigned short>::deallocate(unsigned short*, unsigned long) in string_conversion.o
      google_breakpad::mach_o::FatReader::Reporter::~Reporter() in macho_reader.o
      google_breakpad::mach_o::Reader::Reporter::~Reporter() in macho_reader.o
      __gnu_cxx::new_allocator<std::_Rb_tree_node<std::pair<std::string const, google_breakpad::mach_o::Section> > >::deallocate(std::_Rb_tree_node<std::pair<std::string const, google_breakpad::mach_o::Section> >*, unsigned long) in macho_reader.o
      ...
  "mozalloc_abort(char const*)", referenced from:
      std::__throw_length_error(char const*) in string_conversion.o
      std::__throw_bad_alloc() in string_conversion.o
      std::__throw_length_error(char const*) in macho_reader.o
      std::__throw_bad_alloc() in macho_reader.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)


I am at changeset 963bdd1cd1d7
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-05-25 14:26:44 PDT
Fallout from something, but I don't know what.
Comment 2 Hubert Figuiere [:hub] 2012-05-25 14:30:05 PDT
running a hg bisect now.
Comment 3 Mike Hommey [:glandium] 2012-05-25 14:30:15 PDT
Probably bug 746794, already backed out for other reasons (bug 758648)

It would be interesting to know what failed to build (you only pasted the error).
Comment 4 Mike Hommey [:glandium] 2012-05-25 14:30:40 PDT
Note it's backed out on m-c, not m-i (yet).
Comment 5 Hubert Figuiere [:hub] 2012-05-25 14:35:02 PDT
(In reply to Mike Hommey [:glandium] from comment #3)
> Probably bug 746794, already backed out for other reasons (bug 758648)
> 
> It would be interesting to know what failed to build (you only pasted the
> error).

google_breakpad. The build output is somewhat confusing...

Here is the tail:

clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[5]: *** [crashreporter] Error 1
make[4]: *** [libs] Error 2
make[3]: *** [crashreporter_libs] Error 2
make[2]: *** [libs_tier_platform] Error 2
make[1]: *** [tier_platform] Error 2
make: *** [default] Error 2
Comment 6 Mike Hommey [:glandium] 2012-05-25 14:42:37 PDT
So, this would be a Xcode 4.x issue, I guess, since it built fine on buildbots.
Comment 7 Hubert Figuiere [:hub] 2012-05-25 14:44:53 PDT
I don't have Xcode 4. But I have the Lion command line tools and this is being compiled using clang that ship with that package.
Comment 8 Hubert Figuiere [:hub] 2012-05-25 16:58:03 PDT
The first bad revision is:
changeset:   94923:81c2e2ea2dbf
user:        Mike Hommey <mh+mozilla@glandium.org>
date:        Fri May 25 08:31:33 2012 +0200
summary:     Bug 746794 - Always use the STL wrappers when #pragma visibility is supported. r=ted


Sounds about right just reading the commit log.
Comment 9 Hubert Figuiere [:hub] 2012-05-25 17:31:21 PDT
With the latest merge from m-c it works. As said in comment 4

Note You need to log in before you can comment on or make changes to this bug.