Closed Bug 758899 Opened 8 years ago Closed 8 years ago

Cisco ACS GUI is extremely slow making it unusable

Categories

(Core :: Networking: HTTP, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 760608

People

(Reporter: wgianopoulos, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 obsolete file)

Since the 4/26 nightly builds the Cisco ACS GUI is completely unusable due to it responding extremely slowly.  This dos not occur with other browsers or earlier versions of Firefox.
Severity: normal → major
Hardware: x86_64 → x86
Can you test in the Firefox safemode ?
This will be difficult to resolve without testcase
I am actually on finding a regression bug using hg bisect.
OK somehow the regression range I posted earlier just going back to that post is wrong.  Not sure how i screwed up on that.

What I think I isolated this to was:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=75c7378c87b6&tochange=83ef3c9a64b5

Trying to isolate past that was unsuccessful I think I need to redo the bisect doing clobber builds, unfortunately. ;-(
Also, I should explain that what i mean by unusable is that unaffected version display pages with inn 3-4 seconds.  Effected builds take 3-4 minutes plus.

Putting this in the plugins component is a guess because the interface is Java heavy, but I ma not entirely convinced this is not a more generic SSL issue.
OK.  please ignore comments 1 and 4.  The correct regression range is:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=75c7378c87b6&tochange=cc5254f9825f

Re-doing the bisect.  I also updated mozilla-build, so that I have a version of hg bisect that supports --extend to make the bisect easier.
Hg bisect returned:

The first bad revision is:
changeset:   92418:c773ee0f0245
user:        Patrick McManus <mcmanus@ducksong.com>
date:        Wed Apr 25 08:54:42 2012 -0400
summary:     bug 729133 - internal necko speculative connections r=honzab

This is likely a duplicate of Bug 760608.
Blocks: 729133
Component: Plug-ins → Networking: HTTP
QA Contact: plugins → networking.http
Summary: Cisco ACS GUI is unusable → Cisco ACS GUI is extremely slow making it unusable
Attached patch workaround (obsolete) — Splinter Review
The point of posting this is I think it would be preferable to do this for Aurora rather than backing out bug 729133 completely.
This should also fix bug 760608 and bug 760912.
I'll post a real patch for this on monday.
The patch from bug 760608 attachment 629957 [details] [diff] [review] fixes this issue.
Attachment #629668 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 760608
You need to log in before you can comment on or make changes to this bug.