Closed Bug 760912 Opened 8 years ago Closed 8 years ago

Connection is very slow for https site open from nsIProcess run

Categories

(Core :: Networking: HTTP, defect)

15 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 760608

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/9274e6b53af4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120602134306

Connection is very slow for https site open from nsIProcess run.
Browser tab indicates "Connecting ..". for a while.

Maybe this is duplication of Bug 760608.


Steps to Reproduce:

1. Start Browser with new profile
2. Open Error Console(Ctrl+Shift+J)
3. Evaluate the following code (You should modify PATH and select profile when dialog is opened)

    var PATH = "L:\\trunk\\2012\\04\\firefox inbound 25-Apr-2012 0611\\firefox.exe";
    var appfile = Components.classes["@mozilla.org/file/local;1"]
                  .createInstance(Components.interfaces.nsILocalFile);
    appfile.initWithPath(PATH);
    var args = ["-url","https://bugzilla.mozilla.org/attachment.cgi?id=609181","-no-remote","-P"];
    var process = Components.classes['@mozilla.org/process/util;1']
                  .createInstance(Components.interfaces.nsIProcess);
    process.init(appfile);
    process.run(false, args, args.length, {});

4. Repeat Step3 if necessary

Actual Results:  
  Browser tab indicates "Connecting ..". for a while.

Expected Results:  
  Browser should load the https url immediately.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/d470016df45d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120425 Firefox/15.0a1 ID:20120425122041
Bad:
http://hg.mozilla.org/mozilla-central/rev/b893f852fe7b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120425 Firefox/15.0a1 ID:20120425202340
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d470016df45d&tochange=b893f852fe7b

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c1e2504f48fd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120425 Firefox/15.0a1 ID:20120425050423
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/dc7ccdd73610
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120425 Firefox/15.0a1 ID:20120425061222
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c1e2504f48fd&tochange=dc7ccdd73610

Suspected: bug 729133
(In reply to Alice0775 White from comment #0)
> Maybe this is duplication of Bug 760608.

Looks like.
WORKAROUND 
In a profile to apply by step 3, set network.http.spdy.enabled to false
(In reply to Alice0775 White from comment #2)
> WORKAROUND 
> In a profile to apply by step 3, set network.http.spdy.enabled to false

This WORKAROUND does NOT correct the issue I reported in bug 758899.

The workaround patch I posted on that bug does fix the issue for me.
The patch from bug 760608 attachment 629957 [details] [diff] [review] should fix this issue.
I have builds that include that patch available at http://www.wg9s.com/mozilla/firefox/  can you verify that these fix the issue?
No longer blocks: 760608
Depends on: 760608
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 760608
You need to log in before you can comment on or make changes to this bug.