Closed Bug 75898 Opened 24 years ago Closed 22 years ago

Shortcut for Message (Command-M) collides with Minimize (OS-reserved)

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

PowerPC
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.0

People

(Reporter: hsivonen, Assigned: Brade)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [keybnd][ADT1])

Attachments

(1 file, 3 obsolete files)

Mac OS X reserves the key combination command-M for minimizing the frontmost
window. In Mozilla this key combination is used as a shortcut for Message.
Blocks: 73812
=>  To Mac keyboard team.
Assignee: aaronl → brade
Priority: -- → P3
Target Milestone: --- → mozilla0.9.2
Whiteboard: [keybnd]
over to mail team to decide what to do
Assignee: brade → ducarroz
Priority: P3 → --
Target Milestone: mozilla0.9.2 → ---
reassign to jglick
Assignee: ducarroz → jglick
Whiteboard: [keybnd] → [keybnd] OSX
From bug 29086, I came across this list of keybindings.

http://www.mozilla.org/projects/ui/accessibility/mozkeyintro.html#xref

Here you will find a discussion about MacOS X's use of Cmd-M & Cmd-H. My $0.02
about this is that when Apple decides they want a keystroke, you're really not
going to change their minds. It's been quite some time since Apple grabbed a
keystroke for their own use across the entire UI, and they don't do it
haphazardly. From what I've read about the Dock thru the various rumor sites, it
sounds like Apple is going to make it better and more tweakable over time, not
disgard it as some in the Mac community might want. If app developers follow
Apple's rules, and these keys really do the same thing across all apps, then
they are truly useful for the entire OS X community.

I'd suggest we change New Message on OS X to Cmd-shift-M. We should consider
changing this on OS 9 as well for parity.

- Adam
Netscape is worrying about people who are using 6.x as an upgrade to 4.x.
The problem is this has implications far beyond a single change of one item, 
leading to possible a redesign of the 'New...' section in turn breaking the 
most commonly used keyboard shortcuts in 4.x.
4.x philosophy is geared towards having consistent keyboard shortcuts for the 
same new items, regardless of which component you're in, and accel-M was one of 
these very often used ones. People around the development team referred to them 
as being in "muscle memory".
Of course, I'm all for consistency. But if all (or all well-behaved) apps use
Cmd-M to minimize the frontmost window, that's a useful feature.

We can't expect any OS to stop evolving. We have to be flexible when the OS
grabs a particular keystroke to do a global action. That's really just life, and
I'm sure it's something that the OS X community is willing to live with. I'm
sure that if MS decided to grab some global keystroke to do an action,
application developers would simply change their conflicting keystrokes. It's
happened before, and it'll happen again.

- Adam
<OT>Usually ms just adds new keys to the keyboard (or buttons to the 
mouse...) and specifies how they behave.  I can't recall a key that ms has 
commandeered in ages.
Reassigning to German since this has implications across the whole product.
Assignee: jglick → german
Just to add my $.02 - Command-M has been new message in Netscape mail since 
Netscape had mail capability (95?).  I have no problem with ignoring Apple's 
recommendation of it be minimize under OS X as there is no equivalent under OS 9.  
That and I expect most people would rather have a shortcut for new message rather 
than minimize unless they spend a lot of time looking at pr0n they want to be 
able to quickly hide when the boss appears :-)
And so what's wrong with that? ;)

Seriously, I think that if application developers embrace Cmd-M as minimize and
it becomes the norm across apps, it would be a very useful keyboard shortcut for
users. Moz will be a second-class citizen if it ignores HIG.

We can have our cake & eat it too. There are other unused keystrokes that can be
used besides Cmd-M in Moz.

- Adam
OTOH, some people don't use the Mail&News component at all. If such a person
gets used to command-M in other apps, (s)he will be greatly annoyed if a mail
window shows up in Mozilla.

(I don't use Mozilla Mail&News and I'm quite annoyed when I accidentally click a
mailto link and a message window shows up.)
[OSX+] now is used to indicate stop ship bugs - this isn't
Whiteboard: [keybnd] OSX → [keybnd] [OSX-]
*** Bug 103033 has been marked as a duplicate of this bug. ***
According to HIG, the four reserved key-combinations for OS X are: cmd-H, cmd-Q,
cmd-M, and cmd-N.  Handling of cmd-N and cmd-Q are more important for Cocoa
apps, of course.

So, they're taking 4 and leaving a few hundred other combinations available. 
Yeah, that's inconvienient, but I think the sooner we get over it the better,
and the more OS-X like Mozilla will be.  BBedit grabs cmd-h and it's a real pain
in the ass when I'm trying to organize my apps (for example).  The only way to
hide it is with the menu, and besides being inconvienient, it's an accessbility
issue.

Now, Apple didn't go and change cmd-n to cmd-shift-n in the current OS9 Finder
and Mozilla should follow suit.  This change should be OS X only, leaving the OS
9 users without any surprises.  Switching to a new operating system is the
perfect time to get these changes in - the longer this is held off, and I'll bet
money Mozilla will conform eventually, the harder it will be on the users, and
the larger the installed base will be.

Cmd-shift-M gets my vote because it's "create me a new blank mail composer" and
"create me a new blank webpage composer" already gets cmd-shift-n.  Of course,
ctrl-M is available and cross-platform, but un mac-like.  But since we're
already decided to do things like a mac, it shouldn't stop half-way.

The muscle-memory arguement is valid, but muscle-memory can re-learn.  The
switch to OSX is making us all re-learn alot of habits, but we hope in the end
we'll be better for it.  Folks who disagree can run OS9 until the 32-bit clock
runs out, and keep their cmd-m.
Is this one in limbo?

Brade, do you have any interest in taking it?
reassigning.
Assignee: german → aaronl
Whiteboard: [keybnd] [OSX-] → [keybnd]
Ok, I'm starting to come around to this now that I live almost full time in OS X
and have finally learned that command-M no longer is Make Alias (even the Finder
had to change :-).  I know we have platform specific XUL, this should be as
simple as having a Mac OS X specific set of keybindings.
Marking nsbeta1

The solution agreed upon at the macdev meeting:
Command+shift+M should bring up compose message on OS X
Command+M or Command+shift+M should bring up compose message on OS 9
Assignee: aaronl → brade
Keywords: nsbeta1
sdagley--please add plus to nsbeta1 (I'm told you can do this for mac bugs)
Status: NEW → ASSIGNED
Keywords: mozilla1.0
OS: MacOS X → All
Target Milestone: --- → mozilla1.0
Attached patch add new overlay; patch 1 (obsolete) — Splinter Review
Keywords: nsbeta1nsbeta1+
adding mcarlson since this fix adds a keybinding and will need her approval
l10n approved. Please check this in this week.
thanks
Please update this bug with an [adt1] - [adt3] impact rating (or take it off the
list if it doesn't even rate adt3.)  Thanks!
Whiteboard: [keybnd] → [keybnd][ADT1]
For the record, I don't believe that Aaron's suggestion (comment 18) was from a
macdev meeting.  My recollection is been that macdev people think OS9 and OSX
should be consistent (for example, so running the OS9 build on OSX will work the
same).  Lori Kaplan, Steve Dagley, Mike Pinkerton, and I have all agreed with
this decision.

reviews please?
Comment on attachment 77469 [details] [diff] [review]
add new overlay; patch 1

r=akkana on the code, assuming that everyone agrees that the right thing to do
is change the binding for all macs, not just os X (not what aaron said, but
what Kathy said macdev agreed to).
Attachment #77469 - Flags: review+
for the windows and linux version of the new overlay, why do we need to include 
the dtd?

+<!DOCTYPE window SYSTEM "chrome://messenger/locale/mailOverlay.dtd">
Attachment #77469 - Attachment is obsolete: true
Comment on attachment 77712 [details] [diff] [review]
patch 2 (removing dtd in win/linux)

r=akkana
Attachment #77712 - Flags: review+
what about the new message (Ctrl-M) in addressbook?  does this patch address 
that?
addressbook fix is to include the platform overlay in the file addressbook uses


note:  commercial changes will probably be required; that will need a bugscape
bug.
Attachment #77712 - Attachment is obsolete: true
Comment on attachment 77734 [details] [diff] [review]
patch 3 (includes addressbook fix)

sr=sspitzer
Attachment #77734 - Flags: superreview+
Keywords: adt1.0.0
Comment on attachment 77734 [details] [diff] [review]
patch 3 (includes addressbook fix)

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #77734 - Flags: approval+
Comment on attachment 77734 [details] [diff] [review]
patch 3 (includes addressbook fix)

r=akkana
Attachment #77734 - Flags: review+
adt1.0.0+ (on ADT's behalf) approval for checkin into 1.0.
Keywords: adt1.0.0adt1.0.0+
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
this fix was checked in earlier today
even though bug 74244 works for history, this issue for mail compose is still a
problem.

tested using comm 200.04.09.08 bits on mac 10.1.3 and 9.1 (emulated). actual
results:

* cmd+M still brings up mail compose
* shift+cmd+M does nothing
* in the menu, File > New > Message still lists Command+M for the shortcut
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
looks like the windows version got into content/messenger/platformMailOverlay.xul:

<!-- windows version of platformMailOverlay.xul -->

<overlay id="platformMailOverlay"
         xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

</overlay>
Attached patch build magic fixSplinter Review
Thanks to sfraser for helping me figure out this one.  We want to force the
platform overlay so include +
Attachment #77734 - Attachment is obsolete: true
reviews please?
Comment on attachment 78413 [details] [diff] [review]
build magic fix

r=pink.

works for me with my 4/10/02 branch build (i guess because the mac version of
the file is newer in my tree). however, cmd-m to minimize the window doesn't
work at all.
Attachment #78413 - Flags: review+
Keywords: approval
Whiteboard: [keybnd][ADT1] → [keybnd][ADT1] [Need a=]
Comment on attachment 78413 [details] [diff] [review]
build magic fix

sr=sfraser
Attachment #78413 - Flags: superreview+
the build magic has landed on the trunk; waiting for a= to land on branch
Status: REOPENED → ASSIGNED
Comment on attachment 78413 [details] [diff] [review]
build magic fix

a=asa (on behalf of drivers) for checkin to the 1.0 branch
Attachment #78413 - Flags: approval+
This fix is now checked into both trunk and mozilla 1.0 branch.
I am going to open a new bug on the issue of cmd-M not doing minimize due to
keyword messiness and process.

QA--please verify on both trunk and branch
Status: ASSIGNED → RESOLVED
Closed: 23 years ago22 years ago
Resolution: --- → FIXED
Whiteboard: [keybnd][ADT1] [Need a=] → [keybnd][ADT1]
vrfy'd fixed using 2002.04.16 commercial branch and trunk bits on mac 10.1.3.

cmd+shift+M now brings up mail compose.

cmd+M doesn't minimize, but that's covered by bug 137523.
Status: RESOLVED → VERIFIED
Ian Kennedy filed bug 139212 on Mac OS 9 saying that Ctrl+M no longer works for
opening a message.
adding branch verification keyword.  This bug has been verified in a comment,
just moving that to the keyword field.
Keywords: verified1.0.0
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: