nsIMsgPluggableStore.discoverSubFolders should not raise NS_MSG_FOLDER_EXISTS exception.

RESOLVED FIXED in Thunderbird 15.0

Status

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: hiro, Assigned: hiro)

Tracking

Trunk
Thunderbird 15.0
Dependency tree / graph
Bug Flags:
in-testsuite +

Thunderbird Tracking Flags

(thunderbird13+ fixed, thunderbird14+ fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Assignee

Description

7 years ago
Posted patch Fix (obsolete) — Splinter Review
The method traverses all sub folders so that NS_MSG_FOLDER_EXISTS is not proper for this method.
Attachment #627836 - Flags: review?(dbienvenu)
Assignee

Updated

7 years ago
Blocks: 752423
Assignee

Comment 1

7 years ago
Posted patch Fix (obsolete) — Splinter Review
The previous patch has an incorrect fix in nsMsgMaildirStore.cpp. Sorry for my careless.
Assignee: nobody → hiikezoe
Attachment #627836 - Attachment is obsolete: true
Attachment #627836 - Flags: review?(dbienvenu)
Attachment #627842 - Flags: review?(dbienvenu)
Assignee

Comment 2

7 years ago
Posted patch FixSplinter Review
create_sub_folders had been accidentally removed in unit test. I am so sorry for my careless.
Attachment #627842 - Attachment is obsolete: true
Attachment #627842 - Flags: review?(dbienvenu)
Attachment #627855 - Flags: review?(dbienvenu)
Assignee

Updated

7 years ago
Blocks: 756316

Comment 3

7 years ago
Does this fix any known problems? There is a mention of this error code in bug 749574.
Assignee

Comment 4

7 years ago
(In reply to :aceman from comment #3)
> Does this fix any known problems? There is a mention of this error code in
> bug 749574.

Wow! Nice catch! As far as I can confirm, the fix for bug 756316 (and the fix for this bug) fixes bug 749574 too.

Updated

7 years ago
Blocks: 749574

Comment 5

7 years ago
Comment on attachment 627855 [details] [diff] [review]
Fix

Hiro, thx very much for the patch. I'm wondering why you didn't change AddSubFolders instead - you could certainly argue that it should not return NS_MSG_FOLDER_EXISTS. I think that would be cleaner, but I my build isn't finished so I haven't been able to try it.

Comment 6

7 years ago
Hiro, this is what I had in mind...with this change, the test works, like it does with initial version. I think I prefer this version, so I've r+'d it. If you're OK with it, we can land it. I'd like to get this into tb 13 which means landing it today, if possible.
Attachment #627988 - Flags: review+

Comment 7

7 years ago
I'd like to consider this for tb 13 final beta, since it fixes several issues users with localized builds have been seeing.

Comment 8

7 years ago
I've requested a try server build here - http://ftp.mozilla.org/pub/mozilla.org/thunderbird/try-builds/bienvenu@nventure.com-1da6acf730bf

I think this change is relatively safe, since discoverSubFolders shouldn't care about folders existing.
Comment on attachment 627988 [details] [diff] [review]
tweak AddSubFolders instead...

[Triage Comment]
Per discussion on irc, we're going to take the risk for this as it is hurting users in some cases, especially with localised folders.
Attachment #627988 - Flags: approval-comm-beta+
Attachment #627988 - Flags: approval-comm-aurora+

Comment 10

7 years ago
trunk - http://hg.mozilla.org/comm-central/rev/27498a828ee9 (forgot bug #)
aurora - http://hg.mozilla.org/releases/comm-aurora/rev/3c22e945104c
beta - http://hg.mozilla.org/releases/comm-beta/rev/c2e021ccbd53

first two commits omitted the bug # unfortunately
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 15.0
Comment on attachment 627855 [details] [diff] [review]
Fix

I believe this request is obsolete, clearing.
Attachment #627855 - Flags: review?(dbienvenu)
Duplicate of this bug: 752423

Updated

7 years ago
Duplicate of this bug: 752730
You need to log in before you can comment on or make changes to this bug.