Last Comment Bug 759346 - Ctrl+ช (The key is '+/=' key on ANSI keyboard layout) doesn't work as Ctrl++ but work as so on IE
: Ctrl+ช (The key is '+/=' key on ANSI keyboard layout) doesn't work as Ctrl++ ...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
: Jim Mathies [:jimm]
Mentors:
Depends on:
Blocks: 630810 756811
  Show dependency treegraph
 
Reported: 2012-05-29 08:24 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2012-06-16 18:28 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.24 KB, patch)
2012-05-29 09:18 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
jmathies: review+
Details | Diff | Splinter Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-05-29 08:24:20 PDT
https://bugzilla.mozilla.org/show_bug.cgi?id=756811#c16

>  Ekanan Ketunuti 2012-05-29 08:00:32 PDT
> 
> On Thai keyboard I use Ctrl and ช (+/= key in English) rather than Ctrl and Shift and ๅ. 
> 
> Since cset c9ce0e49040a I cannot use Ctrl and ช for zoom-in.

The key's virtual keycode is VK_OEM_PLUS. It's odd, the key cannot input '+' and '1' key can input '+' with Shift key. So, the key shouldn't be VK_OEM_PLUS. However, other applications checks the virtual keycode for kicking shortcut key handlers. So, we should add special case for it.

This is a regression of bug 630810, so, this must be fixed on Fx15.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-05-29 09:18:47 PDT
Created attachment 627987 [details] [diff] [review]
Patch

testing on tryserver:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1

This makes inconsistency between other platforms on some keyboard layout. However, it's better to emulate native application manners.
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-05-29 17:48:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/7f259a56c7c0
Comment 3 Ekanan Ketunuti 2012-05-29 17:50:05 PDT
Thank you for fixing this!
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-05-29 18:39:10 PDT
(In reply to Ekanan Ketunuti from comment #3)
> Thank you for fixing this!

Thank *you* for your reporting. That always helps us.
Comment 5 Ed Morley [:emorley] 2012-05-30 07:38:48 PDT
https://hg.mozilla.org/mozilla-central/rev/7f259a56c7c0

(In reply to Ekanan Ketunuti from comment #3)
> Thank you for fixing this!

The fix will be present in tomorrow's Nightly / Firefox 15 when it reaches aurora/beta/release :-)
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-01 15:45:46 PDT
This is fixed, and possibly uncommon, so untracking.

Note You need to log in before you can comment on or make changes to this bug.