Last Comment Bug 756811 - ctrl++ doesn't work even with Ctrl+Shift++ when keyboard layout is Russian or Thai
: ctrl++ doesn't work even with Ctrl+Shift++ when keyboard layout is Russian or...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 759346
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 12:23 PDT by Roman R.
Modified: 2012-06-16 18:28 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Roman R. 2012-05-19 12:23:35 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120519030527

Steps to reproduce:

1. Switch keyboard layout to a Russian one.
2. Pressed Ctrl and +


Actual results:

Nothing.


Expected results:

Zooming in.
Comment 1 Roman R. 2012-05-19 12:24:27 PDT
Ctrl+- and ctrl+0 work, though.
Comment 2 scientes 2012-05-19 12:55:19 PDT
what about ctrl-shift-and then the [=/+] key?

you use to have to hold shift to get a [+] but this was fixed, is this the cause?

if you pres the + key alone, do you get a "+", a "=" or something else?
Comment 3 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-05-19 21:13:12 PDT
Ctrl+Shift+= should work.

I know most users don't want to press Shift key for such case. l10n builds can avoid this issue only on the most major keyboard layout in the location. See bug 426501.

But it's odd, both English build and Russian build sets "=" as the alternative zoom in shortcut key. So, Ctrl+= should work as zoom-in.
Comment 4 Roman R. 2012-05-21 10:10:31 PDT
Ctrl+Shift+= doesn't work.

By the way, we had this problem a few years ago: bug 429898.
Comment 5 Roman R. 2012-05-21 10:11:09 PDT
This got broken quite recently, I believe.
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-25 14:35:28 PDT
Roman, can you try some previous Firefox versions to see when this started happening? Also, does this happen with any other locales?
Comment 7 scientes 2012-05-25 16:13:59 PDT
this is a great tool to find out when this problem started: http://harthur.github.com/mozregression/
Comment 8 scientes 2012-05-25 16:15:37 PDT
* http://mozilla.github.com/mozregression/
Comment 9 Roman R. 2012-05-25 17:21:33 PDT
I will try, Anthony.
Comment 10 Ekanan Ketunuti 2012-05-29 02:10:26 PDT
this happen with Thai locale too.
Comment 11 Ekanan Ketunuti 2012-05-29 02:16:16 PDT
last good nightly 2012-05-17
first bad nightly 2010-05-18
pushlog http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=762e95608da3&tochange=e794cef56df6

m-i build:
last good rev is 2c3647738e81
first bad rev is c9ce0e49040a
pushlog http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2c3647738e81&tochange=c9ce0e49040a
Comment 12 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-05-29 05:59:29 PDT
Ah, okay, I see the cause. Thanks for investigating the regression range.

This is a regression of bug 630810, only affects Fx15. So, this must be fixed.
Comment 13 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-05-29 06:12:19 PDT
Oops. Russian shouldn't be same bug. Roman R., are you exactly using the standard Russian keyboard layout which is installed by default? In other words, if your answer is YES, the Thai layout's problem is another bug. I need your confirmation.
Comment 14 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-05-29 06:35:04 PDT
Canceling my request for blocking 15. My investigation is wrong. And I cannot reproduce this bug on Thai layout too. That's strange.

Roman R. and Ekanan:

Are you using standard keyboard layout, I mean it's installed on Windows? Or are you using 3rd party keyboard layout include custom keyboard layout which is made by a tool?
Comment 15 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-05-29 06:45:16 PDT
Note that I tested:

* On Nightly (en-US) with Russian keyboard layout which is installed Windows7.
* On Nightly (en-US) with Thai keyboard layouts (both Kedmanee and Pattachote) which are installed Windows7.
* On Fx13 (ja-JP) with Russian keyboard layout.
* On Fx13 (ja-JP) with both Thai keyboard layouts.

Ctrl+Shift+= does work as Ctrl++ on Russian keyboard layout. The key is next to '-', the '-' key is next to '0'.

Ctrl+Shift+ๅ does work as Ctrl++ on Thai Kedmanee keyboard layout. The key is '1' in ANSI keyboard layout.

Ctrl+Shift+= does work as Ctrl++ on Thai Pattachote keyboard layout. The key is '1' in ANSI keyboard layout.
Comment 16 Ekanan Ketunuti 2012-05-29 08:00:32 PDT
> Are you using standard keyboard layout, I mean it's installed on Windows? 

Yes


> Ctrl+Shift+ๅ does work as Ctrl++ on Thai Kedmanee keyboard layout. The key
> is '1' in ANSI keyboard layout.


Ok, I misunderstood. sorry about that :(

On Thai keyboard I use Ctrl and ช (+/= key in English) rather than Ctrl and Shift and ๅ. 

Since cset c9ce0e49040a I cannot use Ctrl and ช for zoom-in.
Comment 17 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-05-29 08:18:34 PDT
(In reply to Ekanan Ketunuti from comment #16)
> Ok, I misunderstood. sorry about that :(
> 
> On Thai keyboard I use Ctrl and ช (+/= key in English) rather than Ctrl and
> Shift and ๅ. 
> 
> Since cset c9ce0e49040a I cannot use Ctrl and ช for zoom-in.

Thank you for your confirmation. *Currently*, the change is intentional. The key's native virtual keycode is OEM_PLUS. Before the changeset, Gecko cares it as '+' key always. But after it, Gecko checks whether '+' is inputtable by the key. I checked on IE9, the key combination works as Zoom-in, so, I think it must be fixed before Fx15 but other bug.

I'll file a new bug for the Thai keyboard layout case.
Comment 18 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-05-31 05:35:43 PDT
We need some replies from the reporter...
Comment 19 Roman R. 2012-06-16 17:05:41 PDT
I use a layout DLL created by a third party. HOWEVER, I must add that this bug is NOT present in 16.0a1 (2012-06-16).
Comment 20 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2012-06-16 18:28:02 PDT
Then, this must be fixed by bug 759346.

Note You need to log in before you can comment on or make changes to this bug.