Last Comment Bug 759457 - -moz-transform causes box-shadow quirks
: -moz-transform causes box-shadow quirks
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 15 Branch
: x86_64 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks: 757039
  Show dependency treegraph
 
Reported: 2012-05-29 12:18 PDT by Christopher Van Wiemeersch [:cvan]
Modified: 2013-11-13 02:20 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified


Attachments
-moz-transform and box-shadow not playing well (Nightly) (9.93 KB, image/png)
2012-05-29 12:18 PDT, Christopher Van Wiemeersch [:cvan]
no flags Details
-moz-transform and box-shadow playing well (Firefox 12.0) (10.55 KB, image/png)
2012-05-29 12:19 PDT, Christopher Van Wiemeersch [:cvan]
no flags Details
Test case (211 bytes, text/html)
2012-05-29 13:08 PDT, Christopher Van Wiemeersch [:cvan]
no flags Details
Don't fast path negative scales (976 bytes, patch)
2012-05-29 21:51 PDT, Jeff Muizelaar [:jrmuizel]
roc: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Christopher Van Wiemeersch [:cvan] 2012-05-29 12:18:16 PDT
Created attachment 628052 [details]
-moz-transform and box-shadow not playing well (Nightly)

User agent:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/15.0 Firefox/15.0a1

Test case:
http://jsfiddle.net/Wj64w/

Behaviour:
`-moz-transform: scalex(-1)` causes `box-shadow` styles to get clipped.
Comment 1 Christopher Van Wiemeersch [:cvan] 2012-05-29 12:19:35 PDT
Created attachment 628053 [details]
-moz-transform and box-shadow playing well (Firefox 12.0)
Comment 2 Christopher Van Wiemeersch [:cvan] 2012-05-29 13:08:38 PDT
Created attachment 628078 [details]
Test case
Comment 3 Frank Yan (:fryn) 2012-05-29 14:15:15 PDT
This regressed at a changeset that landed between May 22 and May 28, inclusive.
Comment 4 Frank Yan (:fryn) 2012-05-29 21:35:36 PDT
This was caused by the landing of the patch in bug 757039.
https://hg.mozilla.org/mozilla-central/rev/dc8bae2d72e7

If we back that out, we should consider backing that out of aurora too, since it got uplifted to that branch.
Comment 5 Frank Yan (:fryn) 2012-05-29 21:41:48 PDT
Ah, I misread the bug. It hasn't been uplifted to aurora yet. Scratch that last bit.
Comment 6 Jeff Muizelaar [:jrmuizel] 2012-05-29 21:51:59 PDT
Created attachment 628215 [details] [diff] [review]
Don't fast path negative scales

This should fix it
Comment 7 Frank Yan (:fryn) 2012-05-29 22:16:04 PDT
jrmuizel and roc, thanks for the quick fix and review! :)
Comment 8 Jeff Muizelaar [:jrmuizel] 2012-05-31 15:24:00 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6b480a66acbc
Comment 9 Jeff Muizelaar [:jrmuizel] 2012-05-31 20:44:17 PDT
Comment on attachment 628215 [details] [diff] [review]
Don't fast path negative scales

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 757039
User impact if declined: Buggy shadow drawing with css transforms
Testing completed (on m-c, etc.): This is basically a partial revert of 757039
Risk to taking this patch (and alternatives if risky): Reduces the risk of taking 757039 because the new code is triggered in fewer cases.
String or UUID changes made by this patch:
Comment 10 Ed Morley [:emorley] 2012-06-01 08:11:03 PDT
https://hg.mozilla.org/mozilla-central/rev/6b480a66acbc
Comment 11 Alex Keybl [:akeybl] 2012-06-04 08:56:45 PDT
Comment on attachment 628215 [details] [diff] [review]
Don't fast path negative scales

[Triage Comment]
Approved for Aurora 14. If this doesn't land in time for the merge this afternoon PT, please re-nominate for Beta approval.
Comment 12 Jeff Muizelaar [:jrmuizel] 2012-06-04 12:09:46 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/57b91ddc54fc
Comment 13 Vlad [QA] 2012-07-23 07:15:37 PDT
Hi guys.
I wanted to verify this bug and so I compared the test case between Firefox 15 beta 1 and Firefox 13 beta 6 and they are exactly the same.
Since is fixed in FX14 and 15, shouldn't the image be different in Firefox 13?

Thanks
Comment 14 Jeff Muizelaar [:jrmuizel] 2012-07-23 12:18:50 PDT
(In reply to Vlad [QA] from comment #13)
> Hi guys.
> I wanted to verify this bug and so I compared the test case between Firefox
> 15 beta 1 and Firefox 13 beta 6 and they are exactly the same.
> Since is fixed in FX14 and 15, shouldn't the image be different in Firefox
> 13?
> 
> Thanks

This was never released broken. It was broken and fixed before a release.
Comment 15 Vlad [QA] 2012-07-23 22:33:56 PDT
Considering comment 13 and 14, changing the flags to verified.

Note You need to log in before you can comment on or make changes to this bug.