Status

Tech Evangelism
Mobile
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: francois, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff] [country-all] [sitewait], URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 628162 [details]
Fennec Nightly screenshot

Web page or screen you were on when you saw the issue: 

http://firstlineofcode.blogspot.co.nz/2012/05/what-firefox-users-wants.html

What you expected: a readable webpage

Fennec Nightly 15.0a1 2012-05-29
(Reporter)

Comment 1

6 years ago
Created attachment 628163 [details]
Android Browser screenshot
Blogspot is giving us the desktop version of the page which doesn't work very well at all on small screens. It has large position:fixed elements that take up most of the space and leave only a small sliver of space for the actual content. The stock android browser gets a different page (the mobile version, which has ?m=1 appended to the URL). If I hand-edit the URL to have ?m=1 we render the mobile version quite nicely as well.

Moving to evangelism to get blogspot to send us their mobile version by default.
Component: General → Evangelism
QA Contact: general → evangelism

Updated

6 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Hardware: Other → ARM

Updated

5 years ago
Duplicate of this bug: 863642
(Assignee)

Comment 4

5 years ago
To contact Alex at Google.
Whiteboard: [MTD] → [serversniff] [country-all] [contactready]
(Assignee)

Comment 5

5 years ago
Contacted.

> Firefox for Android receives the desktop version of the content and then the sidebar is not collapsed (like in the android stock browser for example), making it difficult to read the content
> https://bugzilla.mozilla.org/show_bug.cgi?id=759599
> 
> As a note the same thing is happening for Opera Mobile. It would be cool to solve it for them too.
> 
> Firefox OS has another set of issues with two layers being mismatched it seems.
Whiteboard: [serversniff] [country-all] [contactready] → [serversniff] [country-all] [sitewait]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 743277
(Assignee)

Updated

5 years ago
Duplicate of this bug: 755584
(Assignee)

Comment 8

4 years ago
Still not working as of today
(Assignee)

Comment 9

4 years ago
hmmm. 
So it is kind of working. Or it's the impression I have. There are still glitches when you are navigating through menus. But it seems to be mostly ok.

What others are thinking?
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
(Assignee)

Comment 10

4 years ago
This looks like it has been fixed!
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.