Closed Bug 759599 Opened 10 years ago Closed 8 years ago

Broken layout on Blogger

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: francois, Assigned: karlcow)

References

()

Details

(Whiteboard: [serversniff] [country-all] [sitewait])

Attachments

(2 files)

Web page or screen you were on when you saw the issue: 

http://firstlineofcode.blogspot.co.nz/2012/05/what-firefox-users-wants.html

What you expected: a readable webpage

Fennec Nightly 15.0a1 2012-05-29
Blogspot is giving us the desktop version of the page which doesn't work very well at all on small screens. It has large position:fixed elements that take up most of the space and leave only a small sliver of space for the actual content. The stock android browser gets a different page (the mobile version, which has ?m=1 appended to the URL). If I hand-edit the URL to have ?m=1 we render the mobile version quite nicely as well.

Moving to evangelism to get blogspot to send us their mobile version by default.
Component: General → Evangelism
QA Contact: general → evangelism
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Hardware: Other → ARM
Duplicate of this bug: 863642
To contact Alex at Google.
Whiteboard: [MTD] → [serversniff] [country-all] [contactready]
Contacted.

> Firefox for Android receives the desktop version of the content and then the sidebar is not collapsed (like in the android stock browser for example), making it difficult to read the content
> https://bugzilla.mozilla.org/show_bug.cgi?id=759599
> 
> As a note the same thing is happening for Opera Mobile. It would be cool to solve it for them too.
> 
> Firefox OS has another set of issues with two layers being mismatched it seems.
Whiteboard: [serversniff] [country-all] [contactready] → [serversniff] [country-all] [sitewait]
Duplicate of this bug: 743277
Duplicate of this bug: 755584
Still not working as of today
hmmm. 
So it is kind of working. Or it's the impression I have. There are still glitches when you are navigating through menus. But it seems to be mostly ok.

What others are thinking?
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
This looks like it has been fixed!
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.