Last Comment Bug 759673 - Runnning with mail.chat.enabled to false makes global search results unclickable
: Runnning with mail.chat.enabled to false makes global search results unclickable
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 15.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
Depends on:
Blocks: 743235
  Show dependency treegraph
 
Reported: 2012-05-30 00:37 PDT by Jonathan Protzenko [:protz]
Modified: 2012-05-31 03:56 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (2.08 KB, patch)
2012-05-30 03:13 PDT, Florian Quèze [:florian] [:flo]
bugmail: review+
Details | Diff | Splinter Review

Description Jonathan Protzenko [:protz] 2012-05-30 00:37:14 PDT
Timestamp: 05/30/2012 09:36:00 AM
Error: Error: Unable to locate noun with name 'im-conversation', but I do know about: bool, number, string, date, fulltext, folder, account, conversation, message, contact, identity, attachment-infos, parameterized-identity, mime-type, tag, freetag
Source File: resource:///modules/gloda/gloda.js
Line: 995

Thanks,

jonathan
Comment 1 Florian Quèze [:florian] [:flo] 2012-05-30 03:13:24 PDT
Created attachment 628291 [details] [diff] [review]
Patch

This error occurs when attempting to display a preview of the message in the facet view, or when clicking a message title. The cause is the same in both cases.

Thanks for the report Jonathan! :-)
Comment 2 Andrew Sutherland [:asuth] 2012-05-30 10:24:15 PDT
Comment on attachment 628291 [details] [diff] [review]
Patch

Review of attachment 628291 [details] [diff] [review]:
-----------------------------------------------------------------

oopsies!  Yes, thanks Jonathan!
Comment 3 Jonathan Protzenko [:protz] 2012-05-30 10:36:04 PDT
I don't have much time for patches anymore but at least I can still file bugs :)
Comment 4 Florian Quèze [:florian] [:flo] 2012-05-31 03:56:18 PDT
https://hg.mozilla.org/comm-central/rev/5aa8ecd0c99a

Note You need to log in before you can comment on or make changes to this bug.