Last Comment Bug 759821 - Intermittent crash during crashtests/348811-2.xhtml [@ linux-gate.so@0x424] [@ nsBuiltinDecoder::Pause]
: Intermittent crash during crashtests/348811-2.xhtml [@ linux-gate.so@0x424] [...
Status: RESOLVED FIXED
: crash, intermittent-failure
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: ---
Assigned To: Matthew Gregan [:kinetik]
:
: Maire Reavy [:mreavy]
Mentors:
Depends on: 757707
Blocks: 438871 cubeb
  Show dependency treegraph
 
Reported: 2012-05-30 10:40 PDT by Ed Morley [:emorley]
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ed Morley [:emorley] 2012-05-30 10:40:28 PDT
Rev3 Fedora 12 fx-team pgo test crashtest on 2012-05-30 07:24:54 PDT for push ebe7a997ac58

slave: talos-r3-fed-014

https://tbpl.mozilla.org/php/getParsedLog.php?id=12197310&tree=Fx-Team

{
REFTEST TEST-START | file:///home/cltbld/talos-slave/test/build/reftest/tests/layout/mathml/crashtests/348811-2.xhtml | 1385 / 2061 (67%)
TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/test/build/reftest/tests/layout/mathml/crashtests/348811-2.xhtml | application timed out after 330 seconds with no output
XScreenSaver state: Disabled
User input has been idle for 1305 seconds
args: ['/home/cltbld/talos-slave/test/build/bin/screentopng']
SCREENSHOT: <attached>
INFO | automation.py | Application ran for: 0:07:29.178153
INFO | automation.py | Reading PID log: /tmp/tmpk9noFvpidlog
==> process 2142 launched child process 2172
==> process 2142 launched child process 2693
INFO | automation.py | Checking for orphan process with PID: 2172
INFO | automation.py | Checking for orphan process with PID: 2693
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-linux-pgo/1338382802/firefox-15.0a1.en-US.linux-i686.crashreporter-symbols.zip
PROCESS-CRASH | file:///home/cltbld/talos-slave/test/build/reftest/tests/layout/mathml/crashtests/348811-2.xhtml | application crashed (minidump found)
Crash dump filename: /tmp/tmpD6-Rrr/minidumps/65329294-8e0a-9719-0fc16992-148dd185.dmp
Operating system: Linux
                  0.0.0 Linux 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  SIGABRT
Crash address: 0x85b

Thread 0 (crashed)
 0  linux-gate.so + 0x424
    eip = 0x00443424   esp = 0xbfcaae84   ebp = 0xbfcaaeb8   ebx = 0xa8a7d9b4
    esi = 0x00000000   edi = 0x00000039   eax = 0xfffffffc   ecx = 0x00000080
    edx = 0x00000002   efl = 0x00200202
    Found by: given as instruction pointer in context
 1  libnspr4.so!PR_Lock [ptsynch.c:ebe7a997ac58 : 174 + 0x7]
    eip = 0x006983e2   esp = 0xbfcaaec0   ebp = 0xbfcaaed8
    Found by: previous frame's frame pointer
 2  libnspr4.so!PR_EnterMonitor [ptsynch.c:ebe7a997ac58 : 529 + 0xa]
    eip = 0x00698ad2   esp = 0xbfcaaee0   ebp = 0xbfcaaf08   ebx = 0x006a752c
    esi = 0xa8a7d9b0
    Found by: call frame info
 3  libxul.so!nsBuiltinDecoder::Pause [ReentrantMonitor.h : 71 + 0x7]
    eip = 0x017139c7   esp = 0xbfcaaf10   ebp = 0x00000000   ebx = 0x02595928
    esi = 0xa8cae240   edi = 0xa8cae2d4
    Found by: call frame info
 4  libxul.so!nsHTMLMediaElement::Pause [nsHTMLMediaElement.cpp:ebe7a997ac58 : 1351 + 0x7]
    eip = 0x014ddbed   esp = 0xbfcaaf30   ebp = 0x00000000   ebx = 0x02595928
    esi = 0x52799140   edi = 0x00000001
    Found by: call frame info
 5  libxul.so!nsHTMLMediaElement::UnbindFromTree [nsHTMLMediaElement.cpp:ebe7a997ac58 : 1910 + 0xa]
    eip = 0x014daa25   esp = 0xbfcaaf60   ebp = 0x00000000   ebx = 0x02595928
    esi = 0x52799140   edi = 0x00000001
    Found by: call frame info
 6  libxul.so!nsGenericElement::UnbindFromTree [nsGenericElement.cpp:ebe7a997ac58 : 3305 + 0x1a]
    eip = 0x01385bbd   esp = 0xbfcaaf80   ebp = 0x00000003   ebx = 0x02595928
    esi = 0xa05d1330   edi = 0x00000003
    Found by: call frame info
 7  libxul.so!nsGenericHTMLElement::UnbindFromTree [nsGenericHTMLElement.cpp:ebe7a997ac58 : 1143 + 0x15]
    eip = 0x01452d6b   esp = 0xbfcaaff0   ebp = 0x00000004   ebx = 0x02595928
    esi = 0xa05d1330   edi = 0x00000000
    Found by: call frame info
 8  libxul.so!nsGenericElement::UnbindFromTree [nsGenericElement.cpp:ebe7a997ac58 : 3305 + 0x1a]
    eip = 0x01385bbd   esp = 0xbfcab050   ebp = 0x00000004   ebx = 0x02595928
    esi = 0x9a2fa790   edi = 0x00000006
    Found by: call frame info
 9  libxul.so!nsGenericHTMLElement::UnbindFromTree [nsGenericHTMLElement.cpp:ebe7a997ac58 : 1143 + 0x15]
    eip = 0x01452d6b   esp = 0xbfcab0c0   ebp = 0x00000002   ebx = 0x02595928
    esi = 0x9a2fa790   edi = 0x00000000
}
Comment 1 Matthew Gregan [:kinetik] 2012-05-30 13:41:26 PDT
This looks like the same problem as bug 758198.
Comment 2 Matthew Gregan [:kinetik] 2012-05-30 13:42:19 PDT
I mean bug 757707.
Comment 3 Matthew Gregan [:kinetik] 2012-06-02 12:26:06 PDT
Should be fixed by bug 757707.

Note You need to log in before you can comment on or make changes to this bug.