Last Comment Bug 759970 - Result of reaching the end of a cursor should be 'null'
: Result of reaching the end of a cursor should be 'null'
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
: 765412 (view as bug list)
Depends on:
Blocks: 726378
  Show dependency treegraph
 
Reported: 2012-05-30 19:04 PDT by Jonas Sicking (:sicking) PTO Until July 5th
Modified: 2012-06-15 19:05 PDT (History)
2 users (show)
khuey: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.47 KB, patch)
2012-06-07 11:27 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
jonas: review+
Details | Diff | Splinter Review

Description Jonas Sicking (:sicking) PTO Until July 5th 2012-05-30 19:04:33 PDT
When iterating a cursor and reaching the end and we fire onsuccess, the .result should be set to 'null' (currently we set it to 'undefined')
Comment 1 Jonas Sicking (:sicking) PTO Until July 5th 2012-06-07 11:17:54 PDT
See step 3 at

http://dvcs.w3.org/hg/IndexedDB/raw-file/tip/Overview.html#cursor-iteration-operation
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-07 11:27:53 PDT
Created attachment 631058 [details] [diff] [review]
Patch
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-07 14:04:30 PDT
https://hg.mozilla.org/mozilla-central/rev/5891cc95eac7
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-15 19:05:28 PDT
*** Bug 765412 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.